• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1491
  • Last Modified:

PHP 5.4.0 can't connect to MySQL 5.0.77

We have a shared hosting account which hosts a website's files, and a VPS which hosts the database for that website. This setup was working for a while until we decided to upgrade the shared account's version of php to version 5.4.0 (the hosting provider allows you to select which version to use). On the VPS the MySQL server version is 5.0.77 as shown below:
~$ mysql --version
mysql  Ver 14.12 Distrib 5.0.77, for redhat-linux-gnu (x86_64) using readline 5.1

Open in new window

As mentioned this worked fine when we were using php version 5.2.x on the shared hosting environment. But now that we have upgraded, our joomla site fails to connect to the database. Since joomla doesn't actually give you the mysql error I wrote a short php script to print out the error it's encountering and found this:
Failed mysqlnd cannot connect to MySQL 4.1+ using the old insecure authentication. Please use an administration tool to reset your password with the command SET PASSWORD = PASSWORD('your_existing_password'). This will store a new, and more secure, hash value in mysql.user. If this user is used in other scripts executed by PHP 5.2 or earlier you might need to remove the old-passwords flag from your my.cnf file
 

Open in new window

this occurs on the call to mysql_connect ('server', 'user', 'pass'). So taking advice from the error message I went ahead and created a new user for the database (making sure to specify the correct host) in the fashion:
create user 'xxx'@'xxx' identified by password 'xxxhash';
grant all on xxx.* to 'xxx'@'xxx' identified by password 'xxxhash';

Open in new window

Where 'xxxhash' was replaced with the hash returned by "select password ('xxx');". Then I replaced the values in my test script on the shared hosting environment, and tried to connect again. To no avail, the same exact problem. I also just tried resetting the user's password using:
set password for 'xxx'@'xxx' = password ('xxx');

Open in new window

Also to no avail, and the same problem again. I'm really kinda stumped as to what is causing this. Can anyone shed some light?
0
ruavol2
Asked:
ruavol2
1 Solution
 
fundacionrtsAdministrador de SistemasCommented:
You need to set in my.cnf (Be aware with compatibility http://dev.mysql.com/doc/refman/5.5/en/server-options.html#option_mysqld_old-passwords):
...
old_passwords=0
...

and then restart MySQL.

To detect if the password assigned to user is in old format or new format use the next sql statement:

SELECT User, Host, Length(Password) FROM mysql.user

Old Password = 16
New password = 41
Empty pasword = 0

If you detect some Ol password format, set the password to this user:

SET PASSWORD FOR User@Host=PASSWORD('userpassword');
FLUSH Privileges
0
 
ruavol2Author Commented:
That was exactly what was needed. Thanks a ton
0

Featured Post

How to Use the Help Bell

Need to boost the visibility of your question for solutions? Use the Experts Exchange Help Bell to confirm priority levels and contact subject-matter experts for question attention.  Check out this how-to article for more information.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now