rdlc file not copied to bin\Debug during build

I have designed an rdlc file.  It is just like many others in the solution which were designed by others, and it runs just fine.  But I have to manually copy it into bin\Debug because it doesn't get put there during the build, as do the exisiting rdlc files.

What makes an rdlc file be included in the build so that it appears in bin\Debug and can be found in the path?  Is there a setting somewhere?
AmyAsked:
Who is Participating?
 
wdosanjosCommented:
By default rdlc files are embedded resources, meaning the Build Action of the rdlc file (Properties) is set to Embedded Resource.  So there will be no file copied to Debug/Release, because the content of the file is embedded on the .exe or .dll.

rdlc File Properties
If you do want to have it copied to the Debug/Release folders, set the properties as below:

rdlc File Properties (Content)
Hopefully that answers your question.
1
 
AndyAinscowFreelance programmer / ConsultantCommented:
Is it a file included in the solution (solution explorer) ?
0
 
Shaun KlineLead Software EngineerCommented:
Within visual studio, check the build action for your rdlc file. It should be set to content. Build action can be found be looking at the properties of the file.
0
Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

 
AmyAuthor Commented:
Andy - Yes, the report is listed in Solution Explorer, right next to the other rdlc files that aren't having this problem.

Shaun - Yes, the Build Action of this rdlc is already set to Content.
0
 
AndyAinscowFreelance programmer / ConsultantCommented:
OK, that simple idea bites the dust then.  :-(
0
 
Shaun KlineLead Software EngineerCommented:
Next simple question, is the configuration manager set to debug or release?
0
 
AmyAuthor Commented:
I didn't know about changing the configuration manager setting.  

It's been set to Debug.  I rebuilt with that setting.  Then I set it to Release and rebuilt.  Neither rebuild put the file in bin\Debug or bin\Release.
0
 
AmyAuthor Commented:
Wow!  That's it!  Thank you!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.