Solved

Cisco Router Config

Posted on 2012-03-12
17
1,884 Views
Last Modified: 2012-05-30
Would anyone help me to understand the router config below, and can this config can be made better, or is it missing something?

Thanks.





Building configuration...


Current configuration : 27852 bytes
!
! Last configuration change at 10:31:19 AEDT Wed Feb 29 2012 by services
! NVRAM config last updated at 15:29:14 AEDT Wed Dec 14 2011
!
version 15.0
no service pad
service timestamps debug datetime localtime
service timestamps log datetime localtime
service password-encryption
service sequence-numbers
!
hostname test
!
boot-start-marker
boot-end-marker
!
card type e1 0 1
logging buffered 32000 informational
no logging console
enable secret  
!
no aaa new-model
clock timezone EST 10
clock summer-time AEDT recurring 1 Sun Oct 2:00 1 Sun Apr 3:00
network-clock-participate wic 1
network-clock-select 1 E1 0/1/0
!
no ipv6 cef
ip source-route
ip cef
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 10.1.1.0 10.1.2.3
ip dhcp excluded-address 10.1.2.201 10.1.2.255
!
ip dhcp pool VOIP-VLAN320-POOL
   network 10.1.1.0 255.255.255.0
   default-router 10.1.2.10
   option 150 ip 10.1.2.10
   domain-name company.internal
   lease 4
!
!
no ip domain lookup
ip domain name company.internal
multilink bundle-name authenticated
!
!
stcapp ccm-group 1
stcapp
!
!
isdn switch-type primary-net5
!
!
crypto pki trustpoint TP-self-signed-
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-
 revocation-check none
 rsakeypair TP-self-signed-
!
!
voice-card 0
 dsp services dspfarm
 no local-bypass
!
!
no voice hunt unassigned-number
no voice hunt invalid-number
voice call send-alert
voice call convert-discpi-to-prog
voice rtp send-recv
!
voice service pots
 fax rate disable
!
voice service voip
 allow-connections h323 to h323
 allow-connections h323 to sip
 allow-connections sip to h323
 allow-connections sip to sip
 supplementary-service h450.12
 no supplementary-service sip moved-temporarily
 no supplementary-service sip refer
 fax protocol none
 modem passthrough nse codec g711ulaw
 sip
  registrar server expires max 36000 min 600
  no update-callerid
!
voice class codec 100
 codec preference 1 g711ulaw
 codec preference 2 g729r8
!
voice class h323 1
  h225 timeout setup 5
!
!
voice register global
 mode cme
 source-address 10.1.2.20 port 5060
 max-dn 192
 max-pool 58
 authenticate realm 10.1.2.10
 timezone 43
 create profile sync  
!
!
voice translation-rule 1
 rule 1 /533781/ /81/
 rule 2 /03533781/ /81/
!
!
voice translation-profile OutboundNumberChange
 translate calling 2
!
voice translation-profile xlate_2_VM
 translate calling 1
 translate called 1
!
!
license udi pid CISCO2921/K9 sn  
hw-module ism 0
!
hw-module pvdm 0/0
!
hw-module pvdm 0/1
!
!
!
archive
 log config
  hidekeys
username s  privilege 15 password 7  
!
redundancy
!
!
controller E1 0/1/0
 framing CRC4 test
 pri-group timeslots 1-10,16
 description **** E1 Voice Gateway (03) 5  ****
!
!
!
!
!
interface GigabitEthernet0/0
 description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-GE 0/0$
 no ip address
 duplex auto
 speed auto
!
interface GigabitEthernet0/0.310
 description SW LAN Data
 encapsulation dot1Q 310
 ip address 10.1.2.30 255.255.255.0
!
interface GigabitEthernet0/0.320
 description SW LAN Voice
 encapsulation dot1Q 320
 ip address 10.1.2.10 255.255.255.0
!
interface GigabitEthernet0/0.330
 description SW Wireless
 encapsulation dot1Q 330
 ip address 10.1.2.15 255.255.255.0
!
interface ISM0/0
 description Service Engine for Unity Express
 ip unnumbered GigabitEthernet0/0.320
 service-module ip address 10.1.2.20 255.255.255.0
 !Application: CUE Running on ISM
 service-module ip default-gateway 10.1.2.10
!
interface ISM0/1
 no ip address
 shutdown
!
interface GigabitEthernet0/1
 ip address 10.2.2.10 255.255.255.248
 ip flow ingress
 ip flow egress
 ip summary-address eigrp 4075 10.1.2.32 255.255.252.0
 duplex auto
 speed auto
!
interface GigabitEthernet0/2
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1/0:15
 description OnRamp 10 (03) 5
 no ip address
 encapsulation hdlc
 isdn switch-type primary-net5
 isdn incoming-voice voice
 no cdp enable
!
!
router eigrp 4075
 network 10.2.0.0
 network 10.3.0.0
!
ip forward-protocol nd
!
ip http server
ip http access-class 23
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
ip http path flash:gui
ip flow-export version 9
ip flow-export destination 172.16.128.77 2055
!
ip route 0.0.0.0 0.0.0.0 172.31.13.49
ip route 10.1.2.20 255.255.255.255 ISM0/0
!
kron occurrence TFTPBackup at 23:00 Sun recurring
 policy-list TFTPBackup
!
kron policy-list TFTPBackup
 cli show run | redirect tftp://10.0.0.0/vbtrtr0101-confg
!
!
!
tftp-server flash:HarpSynth.raw
tftp-server flash:Jamaica.raw
tftp-server flash:KotoEffect.raw
tftp-server flash:Chime.raw
tftp-server flash:Vibe.raw
tftp-server flash:AreYouThereF.raw
tftp-server flash:Analog1.raw
tftp-server flash:Analog2.raw
tftp-server flash:AreYouThere.raw
tftp-server flash:Bass.raw
tftp-server flash:CallBack.raw
tftp-server flash:Classic1.raw
tftp-server flash:Classic2.raw
tftp-server flash:ClockShop.raw
tftp-server flash:Drums1.raw
tftp-server flash:Drums2.raw
tftp-server flash:FilmScore.raw
tftp-server flash:MusicBox.raw
tftp-server flash:RingList.xml
tftp-server flash:DistinctiveRingList.xml
tftp-server flash:Piano1.raw
tftp-server flash:Piano2.raw
tftp-server flash:Pop.raw
tftp-server flash:Pulse1.raw
tftp-server flash:Ring1.raw
tftp-server flash:Ring2.raw
tftp-server flash:Ring3.raw
tftp-server flash:Ring4.raw
tftp-server flash:Ring5.raw
tftp-server flash:Ring6.raw
tftp-server flash:Ring7.raw
tftp-server flash:Sax1.raw
tftp-server flash:Sax2.raw
tftp-server flash:term31.default.loads
tftp-server flash:apps31.8-4-3-16.sbn
tftp-server flash:cnu31.8-4-3-16.sbn
tftp-server flash:cvm31sccp.8-4-3-16.sbn
tftp-server flash:dsp31.8-4-3-16.sbn
tftp-server flash:jar31sccp.8-4-3-16.sbn
tftp-server flash:SCCP31.8-4-4S.loads
!
control-plane
!
!
voice-port 0/1/0:15
 cptone AU
!
voice-port 0/2/0
 cptone AU
 caller-id enable
!
voice-port 0/2/1
 cptone AU
 timeouts ringing infinity
!
voice-port 0/2/2
 cptone AU
 timeouts ringing infinity
 caller-id enable
!
voice-port 0/2/3
 cptone AU
 timeouts ringing infinity
 caller-id enable
!
!
!
sccp local GigabitEthernet0/1
sccp
!
sccp ccm group 1
 bind interface GigabitEthernet0/1
!
dial-peer cor custom
 name local
 name national
 name international
 name mobile
 name internal
!
!
dial-peer cor list call-internal
 member internal
!
dial-peer cor list call-local
 member local
!
dial-peer cor list call-mobile
 member mobile
!
dial-peer cor list call-national
 member national
!
dial-peer cor list call-international
 member local
 member international
 member internal
!
dial-peer cor list user-national
 member local
 member national
 member mobile
 member internal
!
dial-peer cor list user-local
 member local
 member internal
!
dial-peer cor list user-international
 member local
 member national
 member international
 member mobile
 member internal
!
!
dial-peer voice 8196 pots
 destination-pattern 53
 port 0/2/0
!
dial-peer voice 8192 voip
 description ** cue prompt management **
 translation-profile outgoing xlate_2_VM
 destination-pattern 8192
 session protocol sipv2
 session target ipv4:10.2.3.15
 dtmf-relay sip-notify
 codec g711ulaw
 no vad
!
dial-peer voice 30 pots
 corlist outgoing call-mobile
 description MOBILE
 destination-pattern 004........
 clid network-number 10002000
 port 0/1/0:15
 forward-digits 10
!
dial-peer voice 20 pots
 corlist outgoing call-local
 description - Informational
 destination-pattern 0013
 clid network-number 10002000
 port 0/1/0:15
 forward-digits 3
!
dial-peer voice 25 pots
 corlist outgoing call-national
 description National (STD) calls -10 digits
 destination-pattern 00[2-8]........
 clid network-number 10002000
 port 0/1/0:15
 forward-digits 10
!
dial-peer voice 65 pots
 corlist outgoing call-local
 description Local Rate calls - 13, 6 digits long
 destination-pattern 013[1-35-9]...
 clid network-number 10002000
 port 0/1/0:15
 forward-digits 6
!
dial-peer voice 70 pots
 corlist outgoing call-local
 description Local Rate calls - 13, 6 digits long
 destination-pattern 0134[0-46-9]...
 clid network-number 10002000
 port 0/1/0:15
 forward-digits 6
!
dial-peer voice 85 pots
 corlist outgoing call-local
 description Telstra Customer Service - 1801, 8 digits long
 destination-pattern 01801....
 clid network-number 10002000
 port 0/1/0:15
 forward-digits 8
!
dial-peer voice 1 voip
 description **** SIP DIAL PEER TO CUE ***
 translation-profile outgoing xlate_2_VM
 preference 7
 destination-pattern 533781..
 session protocol sipv2
 session target ipv4:10.1.2.20
 dtmf-relay sip-notify
 codec g711ulaw
 no vad
!
dial-peer voice 8190 voip
 description ** cue voicemail pilot number **
 translation-profile outgoing xlate_2_VM
 destination-pattern 8190
 session protocol sipv2
 session target ipv4:10.1.2.20
 dtmf-relay sip-notify
 codec g711ulaw
 no vad
!
dial-peer voice 8191 voip
 description ** cue auto attendant number **
 translation-profile outgoing xlate_2_VM
 destination-pattern 8191
 session protocol sipv2
 session target ipv4:10.1.2.20
 dtmf-relay sip-notify
 codec g711ulaw
 no vad
!
dial-peer voice 2 pots
 description - enable direct inward dial on the PRI
 incoming called-number .
 direct-inward-dial
 port 0/1/0:15
!
dial-peer voice 10 pots
 description Emergency Calls - 000
 destination-pattern 0000
 clid network-number 10002000
 direct-inward-dial
 port 0/1/0:15
 forward-digits 3
!
dial-peer voice 8197 pots
 destination-pattern  
 port 0/2/1
!
dial-peer voice 8198 pots
 destination-pattern  
 port 0/2/2
!
dial-peer voice 8199 pots
 destination-pattern  
 port 0/2/3
!
dial-peer voice 2502 voip
 description Overhead Paging
 preference 1
 destination-pattern 60
 session protocol sipv2
 session target ipv4:10.2.5.5
 dtmf-relay sip-notify
 codec g711ulaw
 no vad
!
dial-peer voice 15 pots
 corlist outgoing call-international
 description International Calls
 destination-pattern 0001[1589]T
 clid network-number 10002000
 port 0/1/0:15
 prefix 001
!
dial-peer voice 35 pots
 corlist outgoing call-local
 description Talking Clock
 destination-pattern 01194
 clid network-number 10002000
 port 0/1/0:15
 forward-digits 4
!
dial-peer voice 40 pots
 corlist outgoing call-local
 description Weather
 destination-pattern 01196
 clid network-number 10002000
 port 0/1/0:15
 forward-digits 4
!
dial-peer voice 45 pots
 corlist outgoing call-local
 description - Directory Assistance
 destination-pattern 012[3-9]..
 clid network-number 10002000
 port 0/1/0:15
 forward-digits 5
!
dial-peer voice 50 pots
 corlist outgoing call-local
 description Telstra Directory Services
 destination-pattern 012[2-9].
 clid network-number 10002000
 port 0/1/0:15
 forward-digits 4
!
dial-peer voice 55 pots
 corlist outgoing call-local
 description Directory Assistance
 destination-pattern 01234
 clid network-number 10002000
 port 0/1/0:15
 forward-digits 4
!
dial-peer voice 60 pots
 corlist outgoing call-local
 description Local Rate calls - 13, 10 digits long
 destination-pattern 01300......
 clid network-number 10002000
 port 0/1/0:15
 forward-digits 10
!
dial-peer voice 75 pots
 corlist outgoing call-local
 description Local Rate calls - 13, 8 digits long
 destination-pattern 01345....
 clid network-number 10002000
 port 0/1/0:15
 forward-digits 8
!
dial-peer voice 80 pots
 corlist outgoing call-local
 description Freephone numbers - 1800, 10 digits long
 destination-pattern 01800......
 clid network-number 10002000
 port 0/1/0:15
 forward-digits 10
!
dial-peer voice 90 pots
 corlist outgoing call-local
 description Local VIC numbers
 translation-profile outgoing OutboundNumberChange
 destination-pattern 0[2-9].......
 clid network-number 10002000
 port 0/1/0:15
 forward-digits 8
!
!
sip-ua
!
!
!
gatekeeper
 shutdown
!
!
telephony-service
 max-ephones 60
 max-dn 100
 ip source-address 10.1.2.10 port 2000
 auto assign 20 to 27 type 7931
 auto assign 28 to 28 type CIPC
 auto assign 29 to 32 type anl
 service phone settingsAccess 2
 timeouts ringing 600
 system message Super A-mart
 url services http://10.1.2.20/voiceview/common/login.do
 url authentication http://10.1.2.20/voiceview/authentication/authenticate.do
 load 7931 SCCP31.8-4-4S
 time-zone 48
 time-format 24
 date-format dd-mm-yy
 dialplan-pattern 1 533781.. extension-length 4
 voicemail 8190
 max-conferences 2 gain -6
 call-forward pattern .T
 moh m .au
 web admin system name services secret 5  
 dn-webedit
 time-webedit
 transfer-system full-consult
 transfer-pattern .T
 secondary-dialtone 0
 night-service code *1234
 create cnf-files version-stamp 7960 Nov 30 2011 02:35:01
!
!
ephone-template  10
 softkeys idle  Redial Newcall Pickup Dnd Gpickup
 softkeys seized  Redial Endcall Pickup Gpickup Callback
 softkeys connected  Endcall Trnsfer Park Confrn Join RmLstC Select ConfList
 button-layout 7931 2
 night-service bell
 speed-dial 1 00733805590 label "Helpdesk"
 speed-dial 2 60 label "Furniture Paging"
 speed-dial 3 *1234 label "Night Service"
!
!
ephone-dn  1  dual-line
 number 8100 secondary 5
 label 8100
 description Ballarat
 name Main
 call-forward night-service 8191
 corlist incoming call-internal
 huntstop channel
 no huntstop
 night-service bell
!
!
ephone-dn  2  dual-line
 number 8120 secondary 5
 label Sales Group Ext 8120
 description Sales Group
 name Sales Group
 corlist incoming user-local
 hold-alert 30 originator
!
!
ephone-dn  4  dual-line
 number 8110 secondary 5
 label Office Group Ext 8110
 description Office Group
 name Office Group
 corlist incoming user-national
 hold-alert 30 originator
!
!
ephone-dn  5  dual-line
 number 8111 secondary 5
 label Office 1 Ext 8111
 description Office 1
 name Office 1
 corlist incoming user-national
 hold-alert 30 originator
!
!
ephone-dn  6  dual-line
 number 8112 secondary 5
 label Office 2 Ext 8112
 description Office 2
 name Office 2
 corlist incoming user-national
 hold-alert 30 originator
!
!
ephone-dn  7  dual-line
 number 8113 secondary 5
 label Office 3 Ext 8113
 description Office 3
 name Office 3
 corlist incoming user-national
 hold-alert 30 originator
!
!
ephone-dn  8  dual-line
 number 8114 secondary 5
 label Office 4 Ext 8114
 description Office 4
 name Office 4
 corlist incoming user-national
 hold-alert 30 originator
!
!
ephone-dn  9  dual-line
 number 8115 secondary 5
 label Office 5 Ext 8115
 description Office 5
 name Office 5
 corlist incoming user-national
 hold-alert 30 originator
!
!
ephone-dn  10  dual-line
 number 8116 secondary 5
 label Office 6 Ext 8116
 description Office 6
 name Office 6
 corlist incoming user-national
 hold-alert 30 originator
!
!
ephone-dn  11
 number 8121 secondary 5
 label Sales 1 Ext 8121
 description Sales 1
 name Sales 1
 corlist incoming user-national
 hold-alert 30 originator
!
!
ephone-dn  12  dual-line
 number 8122 secondary 5
 label Sales 2 Ext 8122
 description Sales 2
 name Sales 2
 corlist incoming user-national
 hold-alert 30 originator
!
!
ephone-dn  13  dual-line
 number 8123 secondary 5
 label Sales 3 Ext 8123
 description Sales 3
 name Sales 3
 corlist incoming user-national
 hold-alert 30 originator
!
!
ephone-dn  14  dual-line
 number 8124 secondary 53
 label Sales 4 Ext 8124
 description Sales 4
 name Sales 4
 corlist incoming user-national
 hold-alert 30 originator
!
!
ephone-dn  15  dual-line
 number 8125 secondary 53
 label Sales 5 Ext 8125
 description Sales 5
 name Sales 5
 corlist incoming user-local
 hold-alert 30 originator
!
!
ephone-dn  16  dual-line
 number 8126 secondary 53
 label Sales 6 Ext 8126
 description Sales 6
 name Sales 6
 corlist incoming user-national
 hold-alert 30 originator
!
!
ephone-dn  17  dual-line
 number 8127 secondary 53
 label Sales 7 Ext 8127
 description Sales 7
 name Sales 7
 corlist incoming user-local
 hold-alert 30 originator
!
!
ephone-dn  18  dual-line
 number 8128 secondary 53
 label Sales 8 Ext 8128
 description Sales 8
 name Sales 8
 corlist incoming user-local
 hold-alert 30 originator
!
!
ephone-dn  19  dual-line
 number 8129 secondary 53
 label Sales 9 Ext 8129
 description Sales 9
 name Sales 9
 corlist incoming user-local
 hold-alert 30 originator
!
!
ephone-dn  20  dual-line
 number 8145 secondary 53
 label Sales 10 Ext 8145
 description Sales 10
 name Sales 10
 corlist incoming user-local
 hold-alert 30 originator
!
!
ephone-dn  21  dual-line
 number 8146 secondary 53
 label Sales 11 Ext 8146
 description Sales 11
 name Sales 11
 corlist incoming user-local
 hold-alert 30 originator
!
!
ephone-dn  22  dual-line
 number 8131 secondary 53
 label Counter Left Ext 8131
 description Counter Left
 name Counter Left
 corlist incoming user-national
 hold-alert 30 originator
!
!
ephone-dn  23  dual-line
 number 8132 secondary 53
 label Counter Right Ext 8132
 description Counter Right
 name Counter Right
 corlist incoming user-national
 hold-alert 30 originator
!
!
ephone-dn  24  dual-line
 number 8141 secondary 53
 label Finance 1 Ext 8141
 description Finance 1
 name Finance 1
 corlist incoming user-national
 hold-alert 30 originator
!
!
ephone-dn  25  dual-line
 number 8133 secondary 53
 label Finance 2 Ext 8133
 description Finance 2
 name Finance 2
 corlist incoming user-national
 hold-alert 30 originator
!
!
ephone-dn  26  dual-line
 number 8134 secondary 53
 label Finance 3 Ext 8134
 description Finance 3
 name Finance 3
 corlist incoming user-national
 hold-alert 30 originator
!
!
ephone-dn  27  dual-line
 number 8151 secondary 53
 label Despatch 1 Ext 8151
 description Despatch 1
 name Despatch 1
 corlist incoming user-national
 hold-alert 30 originator
!
!
ephone-dn  28  dual-line
 number 8152 secondary 53
 label Despatch 2 Ext 8152
 description Despatch 2
 name Despatch 2
 corlist incoming user-national
 hold-alert 30 originator
!
!
ephone-dn  29  dual-line
 number 8104 secondary 53
 label Banking Room Ext 8104
 description Banking Room
 name Banking Room
 corlist incoming user-national
 hold-alert 30 originator
!
!
ephone-dn  30  dual-line
 number 8130 secondary 53
 label Counter Group Ext 8130
 description Counter Group
 name Counter Group
 corlist incoming user-national
 hold-alert 30 originator
!
!
ephone-dn  31  dual-line
 number 8140 secondary 5
 label Finance Group Ext 8140
 description Finance Group
 name Finance Group
 corlist incoming user-national
 hold-alert 30 originator
!
!
ephone-dn  32  dual-line
 number 8150 secondary 5
 label Despatch Group Ext 8150
 description Despatch Group
 name Despatch Group
 corlist incoming user-local
 hold-alert 30 originator
!
!
ephone-dn  33  dual-line
 number 8103 secondary 5
 label Manager Ext 8103
 description Manager
 name Manager
 corlist incoming user-international
 hold-alert 30 originator
!
!
ephone-dn  34
 number 8100 secondary 5
 label 8100
 description Ballarat L2
 name MainLine2
 preference 2
 corlist incoming call-internal
 no huntstop
!
!
ephone-dn  35
 number 8100 secondary 5
 label 8100
 description Ballarat L3
 name MainLine3
 preference 3
 corlist incoming call-internal
 no huntstop
!
!
ephone-dn  36
 number 8100 secondary 5
 label 8100
 description Ballarat L4
 name MainLine4
 preference 4
 corlist incoming call-internal
 no huntstop
!
!
ephone-dn  3
 number 8100 secondary 5
 label 8100
 description Ballarat L5
 name MainLine5
 preference 5
 corlist incoming call-internal
!
!
ephone-dn  38  dual-line
 number 8105 secondary 5
 label Lunch Room Ext 8105
 description Lunch Room
 name Lunch Room
 corlist incoming call-internal
 hold-alert 30 originator
!
!
ephone-dn  39
 number 8  secondary 5
 label Office 7 Ext 8
 description Office 7
 name Office 7
 corlist incoming user-national
 hold-alert 30 originator
!
!
ephone-dn  49
!
!
ephone-dn  50
!
!
ephone-dn  52
 number 8001....
 mwi off
!
!
ephone-dn  53
 number 1001
 label Ip Page 3
 name Ip Page 3
 paging ip 239.1.1.3 port 2000
!
!
ephone-dn  56
 number 1010
 park-slot timeout 30 limit 65535
 name CallPark1010
 no huntstop
!
!
ephone-dn  57
 number 1011
 park-slot timeout 30 limit 65535
 name CallPark1011
 no huntstop
!
!
ephone-dn  58
 number 1012
 park-slot timeout 30 limit 65535
 name CallPark1012
 no huntstop
!
!
ephone-dn  59
 number 1013
 park-slot timeout 30 limit 65535
 name CallPark1013
 no huntstop
!
!
ephone-dn  60
 number 1014
 park-slot timeout 30 limit 65535
 name CallPark1014
 no huntstop
!
!
ephone-dn  61
 number 1015
 park-slot timeout 30 limit 65535
 name CallPark1015
 no huntstop
!
!
ephone-dn  62
 number 1016
 park-slot timeout 30 limit 65535
 name Call Park1016
 no huntstop
!
!
banner exec %

#######################################################

 $(hostname) - S

#######################################################

%
banner login %

*********************************************************

 
enforcement officials.

*********************************************************

%
!
line con 0
 password 7  
 login local
line aux 0
line 131
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
 stopbits 1
line vty 0 4
 privilege level 15
 password 7  
 login local
 length 0
 transport input telnet ssh
line vty 5 15
 privilege level 15
 password 7  
 login local
 length 0
 transport input telnet ssh
!
scheduler allocate 20000 1000
ntp server 10.10.5.2
end
0
Comment
Question by:Leo
  • 8
  • 8
17 Comments
 
LVL 57

Expert Comment

by:giltjr
Comment Utility
Are there any specific questions you have?

Without knowing your level of knowledge to try and explain the whole config would take a LONG time and a lot of writing.

Generically it looks like this is a router that is configured to be a VOIP server.

As for making it "better", are you having any specific problems?
0
 
LVL 8

Author Comment

by:Leo
Comment Utility
just a generalize information on what its doing :-) so i can draw a network map of how everything is connected....

better means can i take some commands or statements out from this config, which are not necessarily required to make this config bit shorter...
thanks.
0
 
LVL 57

Expert Comment

by:giltjr
Comment Utility
Well generically it appears to be setup for the sole purpose of controlling VOIP phones.

How much networking knowledge do you have?  It fairly simple to draw a diagram of what is connected to which port.  Just look at the interface config.
0
 
LVL 8

Author Comment

by:Leo
Comment Utility
I have general knoweldge of networking, so one of he reasons i posted the config here, to get expert advice, and let me understand the config :-)
0
 
LVL 57

Expert Comment

by:giltjr
Comment Utility
Well, it would be easier if you had specific questions about specific parts.

Again generically, this is basically setup as a VOIP server.
0
 
LVL 8

Author Comment

by:Leo
Comment Utility
I already knew its runnin VOIP :-)
i just want to draw up a diagram and understand the whole config, and put a description of the rules of what they are doing.
0
 
LVL 36

Expert Comment

by:ArneLovius
Comment Utility
there is an error in the DHCP pool. you are using the 10.1.1.0/24 network but have the default-router and option-150 on the 10.1.2.0/24 network.
0
 
LVL 57

Expert Comment

by:giltjr
Comment Utility
I had noticed the DHCP default route earlier and though I had mentioned it, but I see I did not.

Although its not a real issue you also have:

ip dhcp excluded-address 10.1.2.201 10.1.2.255

The problem is that this router is not acting as a DHCP server for that subnet.

Reviewing the config more, is this actually up and working?

You also have:

!
interface GigabitEthernet0/0.310
 description SW LAN Data
 encapsulation dot1Q 310
 ip address 10.1.2.30 255.255.255.0
!
interface GigabitEthernet0/0.320
 description SW LAN Voice
 encapsulation dot1Q 320
 ip address 10.1.2.10 255.255.255.0
!
interface GigabitEthernet0/0.330
 description SW Wireless
 encapsulation dot1Q 330
 ip address 10.1.2.15 255.255.255.0
!

Which is 3 tag'ed VLAN on Interface Gi0/0.  Having tag'ed VLAN's is fine, but each of the VLAN's are within the same IP subnet, 10.1.2.0/24.  I'm fairly sure that will cause problems.  A VLAN can contain more than one IP subnet, but an IP subnet must be contained on the same VLAN.
0
VMware Disaster Recovery and Data Protection

In this expert guide, you’ll learn about the components of a Modern Data Center. You will use cases for the value-added capabilities of Veeam®, including combining backup and replication for VMware disaster recovery and using replication for data center migration.

 
LVL 8

Author Comment

by:Leo
Comment Utility
This router is not acting as a DHCP server, and the config I have posted I changed the IP addresses for that, so these devices are up and running  :-)
¿
Can you please clarify me bit more that what problems it will cause if VLANs are within the same IP subnet? And what you mean by IP subnet must be contained on same VLAN?
0
 
LVL 8

Author Comment

by:Leo
Comment Utility
and how can we rectify it?
thanks.
0
 
LVL 57

Expert Comment

by:giltjr
Comment Utility
--> This router is not acting as a DHCP server

Oh yes it is.  That is what the "ip dhcp pool VOIP-VLAN320-POOL" does.  It defines a DHCP pool.

It is handing out IP address for the subnet  network 10.1.1.0 255.255.255.0.

Well, don't take this the wrong way,  but obviously you don't understand VLAN's and IP subnets.  So I will try and explain this.

LAN's are layer 2 networks.  Meaning networking protocols like Ethernet or Token Ring.  They use MAC addresses to talk to each other.

A VLAN is a virtual LAN.  That means that you have devices that make it look like you have a physical LAN segment, when you really don't.

IP is a layer 3 protocol. A IP subnet is a range of addresses that can talk directly to each other without going through a router because they are on the same LAN/VLAN segment.  

Hosts on the same IP subnet find each other MAC address by issing a IP subnet broadcast.  An IP subnet broad cast uses a special IP address that every computer on that subnet will look at.  A IP level broadcast stays on the same LAN/VLAN.  It will not cross a LAN/VLAN segment.

Well, before you go start making changes.  Is this config actually working and working properly?
0
 
LVL 8

Author Comment

by:Leo
Comment Utility
Thanks for your info.

Well I have only joined this company 3 days back, and I have been advised that all the offsite locations are working properly and I was told that its not acting as a DHCP server, I guess from that VLAN pool it might be distributing IP addresses for the Cisco Phones, thats what I can think off.
0
 
LVL 57

Expert Comment

by:giltjr
Comment Utility
With the way its setup, it would be providing DHCP addresses for anything that it receives a DHCP broadcast for.

What is Gi0/0 connected to?  Since it is a tag'ed VLAN interface anything it is talking to should be sending tag'ed packets.

As I have never configured a single IP subnet spread across multiple tag'ed VLANs on the same interface I'm not sure what is going on within the network.

I would expect that the DHCP server would be handing out IP address on all 3 of the VLAN's that are defined on Gi0/0.  Which seems to include voice, wireless , and data.
0
 
LVL 8

Author Comment

by:Leo
Comment Utility
So in order to find out whats happening on that interface, would it best to enable infomation logging?
0
 
LVL 57

Expert Comment

by:giltjr
Comment Utility
What router model is this?

Off hand I would say connect a computer to one of the Gigabit interfaces that is not in use then setup a monitor session to mirror Gi0/0 to it.

Then have a computer connect to the mirror port running something like Wireshark to capture the data.
0
 
LVL 8

Author Comment

by:Leo
Comment Utility
the internal routers are cisco 1800 and 2900.

How can i setup a mirror Gi0/0 and mirror port.

thanks,
0
 
LVL 57

Accepted Solution

by:
giltjr earned 500 total points
Comment Utility
Looks like Gi0/2 is not in use so you should be able to issue the commands:

monitor session session source interface gi0/0 both

monitor session session destination interface gi0/2

Then to stop:


no monitor session session source interface gi0/0
no monitor session destination interface gi0/2

Connect your PC that is running the packet capture utility to gi0/2.  I use wireshark.  Let run for awhile and then look at what you have.

I take it you are new to Cisco routers and switches.  What type of equipment have you used before?  Or are you just new to networking?






no monitor session session destination interface type/slot/port [, | -]
0

Featured Post

Highfive + Dolby Voice = No More Audio Complaints!

Poor audio quality is one of the top reasons people don’t use video conferencing. Get the crispest, clearest audio powered by Dolby Voice in every meeting. Highfive and Dolby Voice deliver the best video conferencing and audio experience for every meeting and every room.

Join & Write a Comment

Data center, now-a-days, is referred as the home of all the advanced technologies. In-fact, most of the businesses are now establishing their entire organizational structure around the IT capabilities.
Shadow IT is coming out of the shadows as more businesses are choosing cloud-based applications. It is now a multi-cloud world for most organizations. Simultaneously, most businesses have yet to consolidate with one cloud provider or define an offic…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
In this tutorial you'll learn about bandwidth monitoring with flows and packet sniffing with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're interested in additional methods for monitoring bandwidt…

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now