Quickbooks 2010 Multi user mode issues

I have a users that have two seat licenses and are both setup as multi user mode. My one user (the admin) is having trouble getting onto Quickbooks if the other user logs on first.
The admin user has a 32 bit Windowz 7 PC and the other user has a 64 bit Windows 7 PC. If my user logs on first and then my admin use I get the attached message and it blocks out my admin user. However if my admin user gets on first and then the standard user it will allow both on.

I downloaded the Diagnostic Tool, followed the instructions to clear the fire wall but still receive the message.

Has anyone experienced this issue before?
Quickbook-Error.png
cmdolcetAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JohnBusiness Consultant (Owner)Commented:
Actually, I think what is happening is correct. The admin user apparently has the QuickBooks file and has it set to "Host Multi User Access" (different than multi user mode). So the admin has to have their computer on and QuickBooks running for the standard user to access. That should work that way.

If you require more independence (anyone can access anytime) then you need to do the following:
1. On the admin machine, turn off "Host Multi User Access"
2. Move the company data file (ledger) to a server location.
3. Install the server manager (QB DVD) on that server location.
4. Scan for the ledger.

Then either user should be able to access the file with this  second method.

The two methods (a) Host Multi User Access and (b) Server location and different from each other and use only one.  If the first way is working, it is set up properly.

..... Thinkpads_User
cmdolcetAuthor Commented:
The company database file is set to a server location. When we open a database we navigate to the store location and open it that way.

If the admin open the database first then both can get on however if the user opens the database first then only the user can get on and the admin see the attached error.
JohnBusiness Consultant (Owner)Commented:
Thanks.  Please review the following:

First: Close both occurences of QuickBooks on the client machines.

Then with respect to the server location:

1. Make sure the Server Manager is installed on the server and working.
2. Make sure the Server Manager is the same version as QuickBooks.
3. Make sure the ledger (Company File) is on the same partition (say C:) as the Server Manager.
4. Scan with the Server Manager for the ledger and make sure it is found.

Now:
1. Open QuickBooks on the admin machine. Close any open windows. Check File, Utilites and ensure "Host Multi User Access" is not checked. It should be unchecked. Now close the ledger.
2. Now use the main center button to Open an Existing File, navigate to the server location and open the file.
3. Go to File, Switch to Multi User mode.

Next:
1. Open QuickBooks on the other machine. Close any open windows. Check File, Utilites and ensure "Host Multi User Access" is not checked. Close the ledger if it it open (File, close company).
2. Use the main center button to Open an Existing File, navigate to the server location and open the file. It will force Multi User mode if necessary.

All should be working this way at this point.

Close the Company on both computers. Go to the second computer, open the comany and make sure Multi User Mode is selected.

Now go to the admin computer. The company file should open. Please let us know.

Issue to be concerned about:
-------------------------------------------
If the server is Server 2003, you should be fine. If the server is Server 2008 or newer, you need to upgrade to QuickBooks V2012. The newest version changed its networking structure and is the only version where the Server Manager works reliably on Server 2008.

Please let us know. .... Thinkpads_User

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Amazon Web Services

Are you thinking about creating an Amazon Web Services account for your business? Not sure where to start? In this course you’ll get an overview of the history of AWS and take a tour of their user interface.

cmdolcetAuthor Commented:
OK I think I understand what happend....in your earlier comment "The admin user apparently has the QuickBooks file and has it set to "Host Multi User Access" (different than multi user mode)"

I think we need to change both PC's (admin and user) to Multi user mode. But how can I do this?
JohnBusiness Consultant (Owner)Commented:
Sometimes people put a copy of the ledgers on their own computers. If you have the ledger properly and safely on your server and backed up, then delete any local copies. You sometimes need a local copy (verify/rebuild) but they should be deleted after restoring to the server. This is true for both computers. Neither one should have a local copy.

Now in case people have somehow put transactions in a local copy (see the mess that can happen), then "delete local copy" really means "move it to a safe place on the server"

Then, definitely, turn OFF "Host Multi User Access" on both computers.

Now review my directions above. Close all company files so that QuickBooks does not have any ledger open on either machine.   Use the Open button to navigate to the server (to ensure you are using the server location). Open the ledger and then File, Switch to Multi User Mode. Then use the Open button on the other computer to navigate to the server and open the ledger. Multi User Mode will force itself ON if the ledger is already open.

Look in QuickBooks and see File, Switch to Multi User Mode and also File, Utilities, Host Multi User Access and see that they are different. Ensure Host Multi User Access is always OFF on both computers. Do not let either computer host the ledger from their local computer
... Thinkpads_User
cmdolcetAuthor Commented:
Sorry we ran your suggestions above and it seemed to answer some question, however the question remains that only the database files are on the server. No other QuickBooks program is running on the server. I know the admins PC never had to be on when the other user needed to enter Quickbooks.

So where does that leave us now?
JohnBusiness Consultant (Owner)Commented:
>>> however the question remains that only the database files are on the server. No other QuickBooks program is running on the server.

You need to install the Server Manager on the Server. It is on the QuickBooks DVD. It is the option that says "install server manager, not QuickBooks, no license required" or words to that effect. You must install the server manager and your question implies you have not.

Keep QuickBooks closed on both computers while working on the server, installing and scanning.

... Thinkpads_User
cmdolcetAuthor Commented:
OK I can try that...but in the 6 years we have been using Quickbooks we have never needed the software installed on the server.

The only recent change in the whole working processs, we that the user received a Window 7 64 bit machine where the admin is still working on a Windows 7 32 bit machine
JohnBusiness Consultant (Owner)Commented:
The server manager came into place during that period you have been using QuickBooks. I have it running on all my multi-user clients and know it to work.

It should not matter, if you are not using it, what machine is being used but Windows 7 64-bit is picky on permissions and may cause an issue.  I, myself, use Windows 7 Pro 64-bit and I can use a QB ledger on a server with other users using XP Pro or whatever.

Also, your Windows 7 machines should be Pro, not Home, and Homegroup should be disabled.

.... Thinkpads_User
JohnBusiness Consultant (Owner)Commented:
Hello cmdolcet - Either by fixing the Host Multi User Access, or by adding the Server Manager, or both, did you manage to resolve the issue?

... Thinkpads_User
cmdolcetAuthor Commented:
I will need to attempt your suggestions on Friday
JohnBusiness Consultant (Owner)Commented:
That's fine. Please let us know then.   ... Thinkpads_User
JohnBusiness Consultant (Owner)Commented:
Hello - Any success yet? Please let us know. Thanks.
cmdolcetAuthor Commented:
We will be attempting it tomorrow.
JohnBusiness Consultant (Owner)Commented:
Thank you and thanks for the followup.  ... Thinkpads_User
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
QuickBooks

From novice to tech pro — start learning today.