Solved

Cant access Internet

Posted on 2012-03-13
12
381 Views
Last Modified: 2012-06-27
I have 5 DVR Camera Systems and 1 PC tied together in a workgroup.  I have a SonicWall router that connects those all together.   I am at the main branch and can view all the locations via the tunnel.   I can ping the routers fine.   But I can't get an internet connection on the PC.    I have the IP address, Subnet Mask, gateway, etc and have rechecked them several times.    What am I missing?   The PC is running Windows XP Pro.
0
Comment
Question by:bankwest
12 Comments
 
LVL 8

Expert Comment

by:Tymetwister
ID: 37717621
If you run an ipconfig /all does it give you an IP? Have you tried a release/renew since the install?
0
 
LVL 6

Expert Comment

by:jeffiepoo
ID: 37717641
Go to the command prompt and type: ping www.google.com

What happens?

Make sure you don't have any proxy setting set in 'Internet Options' in the control panel.

Make sure your network settings are set to detect IP and DNS automatically (see attached screenshot)

Are other computers on the network getting internet?
screenshot.JPG
0
 

Expert Comment

by:mpssasan
ID: 37717656
My understanding about your setup (correct me if I am wrong).
DVR camera on seperate locations connected to PC via private network.
Routing among locations are handled by private routers which are connected, again via private network and know about the routing peers.

Your PC is connected on your network, but doesn't know the gateway to internet. This request is handled by your DNS.
Check DNS of your PC (IPconfig /all)
If your DNS is local server on your private network, make sure DNS server have either root hints or have your ISP DNS servers as forwarder.

or condigure your DHCP scope and add ISP DNS in the DHCP scope.
0
 

Author Comment

by:bankwest
ID: 37717708
Ok, will try to get all the above addressed.
 If I type at cmd prompt    google.com....Nothing happens it will time out

I did an ipconfig /all and my PC has an IP address, the gateway (the router address) etc.  

The dns I was testing with was 4.2.2.2 and nothing worked there.

I tried release/renew and it says:   Operation failed as no adapter is in the state permissable for this operation.

I have tried the auto detect also and it still does not work.  

To late in the day but I will contact my ISP for a "correct" dns for their servers.
0
 
LVL 6

Expert Comment

by:jeffiepoo
ID: 37718396
Hmm, sounds like it is possible you could have a driver issue. Could you screenshot your device manager?

Also, check the latter 3 things I mentioned in my previous post. These are all good things to know.

What do you mean by 'The dns I was testing with was 4.2.2.2 and nothing worked there.'?

You shouldn't have to specify DNS, it should be provided to your computer via DHCP. Most network providers' change the IP addresses and DNS servers they lease to your modem over time via DHCP unless you pay extra to get a fixed address. Manually setting up any of this could be the issue depending on how your router is configured to lease out connections.

Hope this helps,

-Jeff
0
 
LVL 5

Expert Comment

by:andrew1812
ID: 37719368
Point 1

Is the default route on the router pointing to the tunnel or to the internet ?

Point 2

Did you check the default route on our PC ?

Check the route entry on windows using the route print command

Check for the interface which the default route ( 0.0.0.0 0.0.0.0) uses . Check if it is pointing to the correct gateway
0
Complete VMware vSphere® ESX(i) & Hyper-V Backup

Capture your entire system, including the host, with patented disk imaging integrated with VMware VADP / Microsoft VSS and RCT. RTOs is as low as 15 seconds with Acronis Active Restore™. You can enjoy unlimited P2V/V2V migrations from any source (even from a different hypervisor)

 
LVL 30

Expert Comment

by:flubbster
ID: 37719716
Try these commands from a command prompt to reset the winsock and tcp/ip stack.

Open a command prompt:
start>run>cmd  (enter)

netsh winsock reset catalog

netsh int ip reset reset.log
0
 

Author Comment

by:bankwest
ID: 37721019
Jeff,

No, I cannot ping google.com     It says ping could not find host.

I have confirmed dns ip with our ISP.

The proxy server in Internet Options is not checked.

The auto detect does not help.   Still cant get out on the web.

Verified gateway and I can ping it from the PC.
0
 
LVL 6

Expert Comment

by:jeffiepoo
ID: 37721319
Thanks for the answers, that rules out the most common problems.

If auto-detect was not ON that is strange, make sure it remains on and is not manually configured.  

Sorry this is taking so long, here are some more process of elimination things to try:

1) On the same window in the screenshot, also go to the 'Alternate Configuration' tab and make sure 'Automatic Private IP address' is checked.

2) Try this: http://www.snapfiles.com/get/winsockxpfix.html   (it will make you restart)

3) Run a virus and spyware scan.

4) Try to ping 74.125.224.113  (This is google). If this works it means there is something going on with DNS.

5) Try running Combofix. If there is a bad rootkit or something nasty sitting on your machine preventing internet access this will fix it. http://www.bleepingcomputer.com/download/anti-virus/combofix 

Other questions:

1) Are other computers on the network getting internet?

2) Please send a screenshot of the device manager if nothing above works.

Hope this helps,

-Jeff
0
 
LVL 6

Accepted Solution

by:
jeffiepoo earned 500 total points
ID: 37721393
Hmmm. It just occurred to me after reading your original post again that maybe your router isn't working right. This sounds like the only computer behind the router. If you had another working computer behind the router I would say to try the steps above, but you should rule out problems with the router first. Do this simply by:

Try connecting any other regular old working computer (ethernet+internet works with DHCP) to the router. See what happens. If it connects to the internet, its an issue with the computer, if it doesn't its an issue with the router. Simple as that. Always try a known working piece of hardware to isolate the issue.
0
 

Author Comment

by:bankwest
ID: 37722288
Jeff,

I tried the ping with google.com and then with the google IP.    Led me to wonder about the router.  It DID end up being a setting in the router.   It is working now.    I had to change network setting to NAT with PPoe.  

THANKS FOR ALL THE HELP
0
 

Author Closing Comment

by:bankwest
ID: 37722293
Great working with you.    Sometimes support is over my head when they try to explain what to try.   You made it easy for me.

Thanks so much
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Preface There are many applications where some computing systems need have their system clocks running synchronized within a small margin and eventually need to be in sync with the global time. There are different solutions for this, i.e. the W3…
Today, still in the boom of Apple, PC's and products, nearly 50% of the computer users use Windows as graphical operating systems. If you are among those users who love windows, but are grappling to keep the system's hard drive optimized, then you s…
Along with being a a promotional video for my three-day Annielytics Dashboard Seminor, this Micro Tutorial is an intro to Google Analytics API data.
Learn how to create flexible layouts using relative units in CSS.  New relative units added in CSS3 include vw(viewports width), vh(viewports height), vmin(minimum of viewports height and width), and vmax (maximum of viewports height and width).

911 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now