Solved

Internal Clients cannot access internet through PIX 501

Posted on 2012-03-13
5
726 Views
Last Modified: 2012-03-14
Hi Guys,

I have a PX 501 firewall installed in an SBS environment at a client location and we switched over to a new internet provider but now i can get traffic route from inside the network out. VPN users are able to connect and get access and remote sites are working

all i did was run the start up wizard to change the WAN IP and modified the access rules accordingly. It appears to be a routing problem but am not sure what to do as i am unfamiliar with Cisco firewalls. Any assistance would be greatly appreciated.

I'm using PIX Device manager 3.0 FYI

here is the config with external ip info omitted

Building configuration...
: Saved
:
PIX Version 6.3(5)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password HtfTMNR4gznMpo33 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
hostname pixfirewall
domain-name ciscopix.com
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
name x.x.x.x Spiretech
access-list outside-acl permit tcp any host Spiretech eq smtp
access-list outside-acl permit tcp any host Spiretech eq www
access-list outside-acl permit tcp any host Spiretech eq https
access-list outside-acl permit tcp any host Spiretech eq 3389
access-list outside-acl permit tcp any host Spiretech eq 4125
access-list outside-acl permit tcp any host Spiretech eq pop3
access-list outside-acl permit tcp any host Spiretech eq imap4
access-list outside-acl permit tcp any host Spiretech eq 26
access-list outside-acl permit tcp any host Spiretech eq 993
access-list inside_outbound_nat0_acl permit ip any 10.10.50.96 255.255.255.224
access-list inside_outbound_nat0_acl permit ip 192.168.1.0 255.255.255.0 10.10.50.96 255.255.255.224
access-list inside_outbound_nat0_acl permit ip 192.168.1.0 255.255.255.0 10.10.10.0 255.255.255.128
access-list outside_cryptomap_dyn_20 permit ip any 10.10.50.96 255.255.255.224
access-list outside_cryptomap_dyn_40 permit ip any 10.10.50.96 255.255.255.224
access-list outside_cryptomap_dyn_60 permit ip any 10.10.50.96 255.255.255.224
access-list outside_cryptomap_dyn_80 permit ip any 10.10.10.0 255.255.255.128
access-list APEX_splitTunnelAcl permit ip 192.168.1.0 255.255.255.0 any
access-list outside_cryptomap_dyn_100 permit ip any 10.10.10.0 255.255.255.128
pager lines 24
logging on
mtu outside 1500
mtu inside 1500
ip address outside Spiretech 255.255.255.0
ip address inside 192.168.1.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool Apexip 10.10.50.100-10.10.50.125
ip local pool Apexip2 10.10.10.50-10.10.10.75 mask 255.255.255.0
pdm location 192.168.1.3 255.255.255.255 inside
pdm location 10.10.50.96 255.255.255.224 outside
pdm location x.x.x.x 255.255.255.248 outside
pdm location 10.10.10.0 255.255.255.128 outside
pdm location Spiretech 255.255.255.255 inside
pdm location 192.168.1.4 255.255.255.255 inside
pdm logging alerts 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_outbound_nat0_acl
static (inside,outside) tcp interface smtp 192.168.1.3 smtp netmask 255.255.255.255 0 0
static (inside,outside) tcp interface www 192.168.1.3 www netmask 255.255.255.255 0 0
static (inside,outside) tcp interface https 192.168.1.3 https netmask 255.255.255.255 0 0
static (inside,outside) tcp interface 3389 192.168.1.3 3389 netmask 255.255.255.255 0 0
static (inside,outside) tcp interface 4125 192.168.1.3 4125 netmask 255.255.255.255 0 0
static (inside,outside) tcp interface pop3 192.168.1.3 pop3 netmask 255.255.255.255 0 0
static (inside,outside) tcp interface imap4 192.168.1.3 imap4 netmask 255.255.255.255 0 0
static (inside,outside) tcp interface 26 192.168.1.3 26 netmask 255.255.255.255 0 0
static (inside,outside) tcp interface 993 192.168.1.3 993 netmask 255.255.255.255 0 0
static (inside,outside) tcp interface 4433 192.168.1.4 4433 netmask 255.255.255.255 0 0
access-group outside-acl in interface outside
route outside 0.0.0.0 0.0.0.0 x.x.x.x 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto dynamic-map outside_dyn_map 20 match address outside_cryptomap_dyn_20
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-MD5
crypto dynamic-map outside_dyn_map 40 match address outside_cryptomap_dyn_40
crypto dynamic-map outside_dyn_map 40 set transform-set ESP-3DES-MD5
crypto dynamic-map outside_dyn_map 60 match address outside_cryptomap_dyn_60
crypto dynamic-map outside_dyn_map 60 set transform-set ESP-3DES-MD5
crypto dynamic-map outside_dyn_map 80 match address outside_cryptomap_dyn_80
crypto dynamic-map outside_dyn_map 80 set transform-set ESP-3DES-MD5
crypto dynamic-map outside_dyn_map 100 match address outside_cryptomap_dyn_100
crypto dynamic-map outside_dyn_map 100 set transform-set ESP-3DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map client authentication LOCAL
crypto map outside_map interface outside
isakmp enable outside
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash md5
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
isakmp policy 40 authentication rsa-sig
isakmp policy 40 encryption 3des
isakmp policy 40 hash md5
isakmp policy 40 group 2
isakmp policy 40 lifetime 86400
vpngroup APEX address-pool Apexip2
vpngroup APEX dns-server 192.168.1.3
vpngroup APEX wins-server 192.168.1.3
vpngroup APEX split-tunnel APEX_splitTunnelAcl
vpngroup APEX idle-time 1800
vpngroup APEX password ********
telnet timeout 5
ssh x.x.x.x 255.255.255.248 outside
ssh timeout 5
console timeout 0
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd auto_config outside
username aa password tLxmYByC8M9QbMmc encrypted privilege 15
username m.h password iK0Q464llOU2axLg encrypted privilege 15
username k password .i94TpHeIAGJSRa4 encrypted privilege 15
username j password uUp/8t3Tly.kntPD encrypted privilege 15
terminal width 80
Cryptochecksum:abc655889dd0aae046ec5ea4a0f1660c
: end
[OK]
0
Comment
Question by:breynolds01
  • 2
  • 2
5 Comments
 
LVL 17

Expert Comment

by:lruiz52
ID: 37718203
Since you modified acl's, Try to run command

Clear xlates
0
 
LVL 57

Expert Comment

by:Pete Long
ID: 37718789
You have no NAT Statement! Traffic cannot traverse the firewall m8 :)

add the following

nat (inside) 1 0.0.0.0 0.0.0.0 0 0

Then try ;)


Pete
0
 
LVL 2

Author Comment

by:breynolds01
ID: 37721240
Is there a way i can do this through the PDM?
0
 
LVL 57

Accepted Solution

by:
Pete Long earned 500 total points
ID: 37721386
I dont have a PDM handy to test sorry

connect to the firewall via CLI like this,

Connecting to and Managing Cisco Firewalls

Log in and issue these commands

enable
{enter the enable password - same as the pdm one}
conf t
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
write mem

Job done  - go have a coffee
0
 
LVL 2

Author Closing Comment

by:breynolds01
ID: 37721473
Thank You Kindly
0

Featured Post

Free Trending Threat Insights Every Day

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

Join & Write a Comment

I recently updated from an old PIX platform to the new ASA platform.  While upgrading, I was tremendously confused about how the VPN and AnyConnect licensing works.  It turns out that the ASA has 3 different VPN licensing schemes. "site-to-site" …
I recently attended Cisco Live! in Las Vegas, a conference that boasted over 28,000 techies in attendance, and a week of hands-on learning hosted by a solid partner with which Concerto goes to market.  Every year, Cisco displays cutting-edge technol…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

707 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now