Go Premium for a chance to win a PS4. Enter to Win

x
?
Solved

Problems deploying microsoft exchange 2010

Posted on 2012-03-13
6
Medium Priority
?
537 Views
Last Modified: 2012-08-13
When I try to add a mailbox database I receive this error. This is a new installation of exchange. I have set the preferred DC. Not sure what is happening. Any feedback is appreciated.
ss.png
0
Comment
Question by:J C
  • 4
6 Comments
 
LVL 43

Expert Comment

by:Adam Brown
ID: 37717819
I think you might have added the wrong screenshot. That shows the successful Outlook configuration screen.
0
 

Author Comment

by:J C
ID: 37717826
You're right will correct shortly
0
 

Author Comment

by:J C
ID: 37717834
Correct screenshot
ss.jpg
0
NEW Veeam Agent for Microsoft Windows

Backup and recover physical and cloud-based servers and workstations, as well as endpoint devices that belong to remote users. Avoid downtime and data loss quickly and easily for Windows-based physical or public cloud-based workloads!

 
LVL 5

Expert Comment

by:pradeep7880
ID: 37718576
Exchange 2010 Error New MailboxDatabase 000020B5

The Command
New-MailboxDatabase -Server 'GEMINI1' -NAME 'domain_local'-EdbFilePath 'K:\MailBoxDatabase\domain_local\domain_local.ebd'-LogFolderPath 'L:\MailboxLogs\domain_local' -Verbose

The Error
Active Directory operation failed on server2.domain.local. This erroris not retriable. Addition information: The name reference is invalid.
This may be caused by replication latency between Active Directory domain controllers.
Active directory response: 000020B5: AtrErr: DSID-03152804, #1: 0: 000020B5: DSID-03152804, Problem 1005 (CONSTRAINT_ATT_TYPE), data 0, Att 992e8635 (homeMDB)
+ CategoryInfo : NotSpecified: (0:Int32) [New-MailboxDatabase], ADOperationException
+ FullyQualifiedErrorId: 31d36CF7, Microsoft.Exchange.Management.SystemConfigurationTasks.NewMailboxDatabase


The Reason
Replication time between domain controllers will cause this issue, to keep this from happening In a multi domain enviorment the Configuration Domain Controller and the Preferred Domain Controllers settings in Exchange 2010 should be set to the same server

The Fix
get-adserversettings
set-adserversettings -preferredserver server1.domain.local
set-adserversettings -configurationdomaincontroller server1.domain.local
0
 

Accepted Solution

by:
J C earned 0 total points
ID: 37779529
I transferred all of the FSMO roles to the DC that the exchange 2010 server could communicate with. I reinstalled exchange 2010 with sp1 and did not run into this problem a second time after reinstalling.
0
 

Author Closing Comment

by:J C
ID: 37795199
The responses did not solve the problem I was having. I had already tried setting the preferredDNS server.
0

Featured Post

How to Use the Help Bell

Need to boost the visibility of your question for solutions? Use the Experts Exchange Help Bell to confirm priority levels and contact subject-matter experts for question attention.  Check out this how-to article for more information.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Steps to fix “Unable to mount database. (hr=0x80004005, ec=1108)”.
Stellar Exchange Toolkit: this 5 in 1 toolkit comes loaded with mega-software tool. Here’s an introduction to tools’ usage and advantages:
This video demonstrates how to sync Microsoft Exchange Public Folders with smartphones using CodeTwo Exchange Sync and Exchange ActiveSync. To learn more about CodeTwo Exchange Sync and download the free trial, go to: http://www.codetwo.com/excha…
If you're a developer or IT admin, you’re probably tasked with managing multiple websites, servers, applications, and levels of security on a daily basis. While this can be extremely time consuming, it can also be frustrating when systems aren't wor…
Suggested Courses

916 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question