Control Panel > Mail icon > your system needs more memory or system resources. close some windows and try again

I have a problem with my ability to open the "mail" icon in my control panel.

When I try I get an error "Your system needs more memory or system resources. Close some windows and try again".

Comp Spec:

Processor: Intel(R) Xeon(R) CPU W3520 @ 2.67GHz
Memory: 8 GB
System Type Windows 7 Enterprise 64bit
Office Version: Office 2010 64bit

I get this problem after a fresh reboot, it only started to happen recently.

So far I have just made sure I have all of the Windows updates up to date and ran a repair on Microsoft Office. I have also run outlook as an admin with the "/fixmapi" switch. I have also made sure the C:\Windows\System32\mapistub.dll is there. The problem happens across several users on the computer.

Anyone else have any dieas what the problem could be? It's only started to happen recently, I don't know exactly when.

Normal Outlook functions and features seem to work as normal.
ouch_mybrain_Asked:
Who is Participating?
 
ouch_mybrain_Connect With a Mentor Author Commented:
Just to let you know I fixed the problem by re-installing windows.
0
 
todd_beedyCommented:
Check your settings for page file. The system might have a corrupt page file.
0
 
ouch_mybrain_Author Commented:
Ok so I did the microsoft "fix it" link on this page:

http://support.microsoft.com/kb/314834

Still have the same problem though...

Thanks.
0
Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
junaidITCommented:
http://answers.microsoft.com/en-us/office/forum/office_2010-outlook/outlook-wont-run-up-mail-control-panel-applet-says/ea4b9da2-4dc0-4951-bb34-30135578746e

chck above URL. talks about couple of registry edits required. hope that helps out.

gud luck and pos tback .
0
 
ouch_mybrain_Author Commented:
Did as the instructions said on your link junaidIT but no I still have the same problem :(
0
 
ouch_mybrain_Author Commented:
No one else provided a solution that worked.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.