How to configure a 2nd NIC card on Ubuntu Server 10.04

Hello Experts,
I have to configure a Linux system as a web server and my choice is Ubuntu Server v.10.04. I installed it with a single NIC  card (the server is VM and initial setup was with single NIC card) and installed GUI as well. Later on I added a 2nd NIC card, I booted up Ubuntu Server with GUI and when I run ifconfig on the command line I can see both Eth0 (default NIC that I setup during the initial OS setup) and Eth1 however I couldn't figure out how to manually configure the IP settings on eth1. I'm new to Linux and any help will be greatly appreciated.
dahterAsked:
Who is Participating?
 
farzanjCommented:
You can sure modify it.  Which editor did you use?  You have to use it as root.

You can do

sudo su -
vi /etc/network/interfaces
or
gedit /etc/network/interfaces

or whatever editor you are using but you have to be root.

If it still gives you problem in modifying it, you can allow root to modify it as

chmod u+w /etc/network/interfaces

No harm in allowing root to modify it.
0
 
farzanjCommented:
You can first try to issue a temporary IP address using the command

sudo ifconfig eth1 10.0.0.100 netmask 255.255.255.0

Open in new window


I am assuming that it is already maked as eth1.  If it is not recognized, you will have to follow the detailed instructions below.

In order to permanently assign an IP address (persistent after reboot) you have to modify file /etc/network/interfaces. See details below.

Detailed instructions are here:

https://help.ubuntu.com/10.04/serverguide/C/network-configuration.html
0
 
dahterAuthor Commented:
I read this article before however /etc/network/interfaces can not be manually modified as the file is read only. I couldn't modify the file.
0
 
dubeyrupeshCommented:
use command
mii-tool
check the all ethernet card is poprtly installed
then use system setting and fix the ip in 2nd eth
0
 
gheistCommented:
Is your system still virtualised? I do not see a good purpose of having complexity of two video cards unless you have a good reason to not use VLAN.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.