Document has been deleted error after document is restored

I have a call log database that was supposed to run an agent overnight and copy any document over 90 days old to a "archive" database and then remove the document from the live call log database.

Well the agent ran last night and moved ALL documents to the "archive" database.  So this morning I wrote a small agent to copy back any document under 90 days to the live database.  

This worked fine but, this database also sends out an email to our level 2 support team. They can no longer open the document links on the past documents that are still being worked on.  The error is "Document is deleted".  Is there a way to fix this so that the emails with the document links open the call log?
kali958Asked:
Who is Participating?
 
doninjaCommented:
This is probably doe to the documents using the Documents UniversalID as a reference. When the document was copied the Document ID would probably have stayed the same when being copied into the archive, but certainly when placed back into original database as a deletion stub with that ID would have existed.

First to see if this is correct, look at links that are used and see if it uses the 16character docID.
Look at document in Archive and Now in Origional and see if DocID matches either. Use Document properties and beanie hat tab on the right.

If no docid matches then there are some apps around I think to manipulate the DocID but it is not recommended by most as it can open up different issues.

If by luck the copied document in the archive is correct then  it is feasible to copy the document back using the same docid if the deletion stubs are removed.
First backup the database. Remove all the newly copied documents or the ones you want to fix. Go to space saving tab and select the delete documents not modified in x days and set to 0 days but do not check the mark on the left. Compact the database and reset the value back to a reasonable value.
In your notes client  make sure there is no value in the notes.ini like CopyToDatabase_New_UNID=1 and set to 0 if it does exist.
Now copy the archive document from archive to original database and it should keep the UNID.

Of course changing the links sent out to use a value in a view rather than the docid would be a nice fix for future issues.
0
 
kali958Author Commented:
I dont have the rights to make the changes to the actual NSF File. I am having our admin people right now get me a restore of the document.  Using an agent to move the documents back from the "archive" database did not work, the UNID are not the same on the doc link.  So once the restore is done I am thinking I have to remove the documents I moved back into the NSF and then just copy/paste the docs from the restore and hope that works.  That is all I can think to do.
0
 
doninjaCommented:
if you copy and past from the restore you will probably find the UNID will not be the same because of the deletion stubs in the original database.

Have to remove them as mentioned above.

Or on a restored DB, make sure you make some change to every document and then replicate with server db. Should replace the deletion stubs as change was more recent.
0
Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 
kali958Author Commented:
The space saving tab - is that on the database properties box? The second tab?  I dont see the option for the "select the delete documents not modified in x days and set to 0 days but do not check the mark on the left."

I have tried to use a restore from the day before, that did not work. I have tired to move back from the archive and that did not.  So I am going to have to give instructions to my admin team to help me with this.  Or tell all the associates that any document links in emails will not work on dates 3/13/2012 and older.
0
 
doninjaCommented:
Sorry this is in Replication Options (File:Replication:options for this application)
It is at the top of the space savers tab "Remove documents not modified in the last (days)"

Before copying the documents around again confirm that the issue is the UniversalID
0
 
kali958Author Commented:
I just found it. I am working with my Admin now - I tried the direct copy cut paste and that bombed and then i was looking at the document properties and the link properties and holy cow, I am up  a creek with out a paddle.

I have having my admin work on the deletion stubs now.
0
 
kali958Author Commented:
OH The issue is the Universal ID - It is different in the replica copy then the original....

But then again I am assuming that no one should be using the database at this time either?????
0
 
kali958Author Commented:
I documented what needed to be changed and the option to purge the deletion stubs is on hold.  Right now the people using the database are not impacted, only the past email document links.  

I did try to match the universal ID from the restore copy to the live copy and they did not match.  The live version might be ON862579C2 but the restore copy would be ON862579C0 and when the copied over, it would go to C1 and the link would still say "Document is Deleted".  So the manual work aroudn is that they will have to look up the number in the database with a search.

Thanks for your help!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.