Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Goldmine/Crystal Query Results from Goldmine different from Crystal

Posted on 2012-03-14
5
Medium Priority
?
345 Views
Last Modified: 2012-03-15
Greetings!

I have a Crystal Report (tried with both 9 and XI) used with Goldmine 6.7 which using the selcet expert I have the following:

trimright({CONTSUPP.RECTYPE}) = "P" and
trimright({CONTSUPP.CONTACT}) = "Investmt-Company"

when I run the report, a different "P" data "E-mail Address" shows in addtion to the correct query results... but only when I run this report from Goldmine.  

When I run the preview from crystal, the "E-mail Address" data does not show (as its supposed to not show).

I have tried running the select expert with
trimright({CONTSUPP.CONTACT}) <> "E-mail Address"

and I get the same result... in Crystal I see the desirable result but no when its run from goldmine.

Any input would be appreciated.
0
Comment
Question by:efgee17
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
5 Comments
 
LVL 12

Expert Comment

by:GMGenius
ID: 37721188
could you provide a copy of the report or a demo report with the same results?
0
 

Accepted Solution

by:
efgee17 earned 0 total points
ID: 37722300
So I saved the file again in Crystal 11 and it stopped leaking out incorrect query results.  Go figure.  Very happy now.
0
 

Author Comment

by:efgee17
ID: 37722962
I've requested that this question be closed as follows:

Accepted answer: 0 points for efgee17's comment #37722300

for the following reason:

I inhereted this report so I don' t know which version the report was originally created in. &nbsp;I know it was giving the eratic results for a long time... several years. &nbsp;I finally noticed an inconsistency in the preview data on Crystal 9 which prompted me to open it again in Crystal 11. &nbsp;Then it looked perfect, so I ran it from Goldmine and the result was clean.
0
 
LVL 12

Expert Comment

by:GMGenius
ID: 37722963
Your problem is possibly you have it set to save report data with the file.

on the file menu make sure you untick to save data with report. usually clicking "Refresh" once the report is open should fetch the new data.

Save Data with Report is to allow you to send the report with data when disconnected from the server!
0

Featured Post

Does Your Cloud Backup Use Blockchain Technology?

Blockchain technology has already revolutionized finance thanks to Bitcoin. Now it's disrupting other areas, including the realm of data protection. Learn how blockchain is now being used to authenticate backup files and keep them safe from hackers.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article shows gives you an overview on SQL Server 2016 row level security. You will also get to know the usages of row-level-security and how it works
Ready to get certified? Check out some courses that help you prepare for third-party exams.
This video shows how to set up a shell script to accept a positional parameter when called, pass that to a SQL script, accept the output from the statement back and then manipulate it in the Shell.
Viewers will learn how to use the UPDATE and DELETE statements to change or remove existing data from their tables. Make a table: Update a specific column given a specific row using the UPDATE statement: Remove a set of values using the DELETE s…

722 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question