Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 672
  • Last Modified:

Allowing access to a remote server to access MySQL database.

We are trying to set up our Moodle installation to access an external MySQL database on another server for controlling users.  I'm not entirely sure what details are pertinent.  What I cannot determine is whether or not the problem lies with the information I gave to Moodle or the set up of the server.  I apologize, but I don't know what information is needed.  Please advise and I will post.
0
MCUIT
Asked:
MCUIT
  • 14
  • 11
1 Solution
 
SANDY_SKCommented:
Are you saying that your module is not able to connect to the external MySQL server???

If so what is the error you getting??

Also has the user you accessing given the right privileges in the MySQL server??
0
 
MCUITAuthor Commented:
The External Database module (I think it's a module) cannot connect, yes.  It seems like it knows to look for the external database:  when I try to login using a user/pass that is in the database, it takes longer to process than it does if I use a user/pass that is entered into Moodle directly.  What it looks like is happening is that Moodle is looking for the database but cannot find it for whatever reason.

I'm not getting an error other than the user/pass combination I am entering is incorrect.

I'm not sure what you mean by the last question.  Moodle asks for the user an pass for the database, and I am double sure I have entered the correct one, if that is what you mean.
0
 
SANDY_SKCommented:
OK...

in Mysql the user's created can be given access to a specific IP address only, so what i am asking is that if the user/password that you using has access to the DB from the IP that your module is running?

this module is in which language? and which version of MySQL??

this login/password is the application login and password or the DB user login and password??
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
MCUITAuthor Commented:
If I understand correctly, yes.  What I think you are asking is if, under the DB username I am giving Moodle, have I set up the remote MySQL access to allow the Moodle server's ip.  If so, yes.  Though,  I don't know if it is important, but the Moodle installation is on a shared host, so it shares it's IP with several other sites.

All of our modules are in English.  MySQL version is 4.1.22.

The login/pass I am speaking of that is not working is a login for the Moodle site that is on the DB.  THe DB is supposed to be handling the users for Moodle.  It gives us a level of automation in the creation and deletion of users for Moodle.
0
 
SANDY_SKCommented:
By language i meant is it in java / php / ASP/ jsp/ etc.

Is this module creating some kind of a log file or something?
0
 
MCUITAuthor Commented:
I'm fairly sure it's in PHP, however, our Moodle installation is hosted by an outside company and we have very limited access to the nuts and bolts of Moodle.  We have access to all of the settings inside of Moodle's interface, but if it is keeping a system log file, we don't have direct access to it.  If it is necessary, I can talk to our hosters about getting a copy.
0
 
SANDY_SKCommented:
If i understand this correctly, what you are saying is that
1. You have got a module that is supposed to access a MySQL database
2. The module is hosted by an outside company
3. This module is not developed by you.
4. When you try logging in to this module then it is giving an error "incorrect login/password"

If my above understanding is correct, Try the following
1. Re confirm if the user name and password you giving is correct or not.
2. check if there are some sort of settings / configurations that is used to mention the DB details
3. Yes please check if it is creating a log file of some sort and check if you can get it

Also may i ask the name of this module  you are using?
0
 
MCUITAuthor Commented:
As far as I am aware, the External Database Authentication module is part of the core of Moodle.  It's developed by the same people who made Moodle.  I'm not logging into the module as much as I am using the module to import users into Moodle from an external database.

I have requested the log file, though it may take some time to get.
0
 
MCUITAuthor Commented:
Our hosts have stated that the log file is nothing more than log in attempts.  Is there any more information I can give that might help?
0
 
SANDY_SKCommented:
can you post the screen shot of the message
0
 
MCUITAuthor Commented:
Screenshot of host response
This is all they said.
0
 
MCUITAuthor Commented:
I'm pretty sure that the problem lies with my server set up.  Do you know how I can set up the MySQL server to allow the Moodle server to access it?
0
 
SANDY_SKCommented:
You can try doing the following

1. check if the moodle server is having a static IP or is it always changing.
2. In the MySQL users instead of giving access to a specific IP give it generic that is % and check. This is not recommended but this is just for testing
3. Disable any kind of firewall that is present on the MySQL server
4. If all the four above are set, check by installing a mySql client and check if it is able to connect.
0
 
MCUITAuthor Commented:
1.  Moodle's IP is static.
2.  It's now set to '%'.
3.  I could not find a setting for a firewall, so I am not sure where to disable it.
4.  After changing what I could, I tried loggin in with Sequel Pro and got this error: Lost connection to MySQL server at 'reading initial communication packet', system error: 61.
0
 
SANDY_SKCommented:
ok..

in you MysQL server there should be a my.cnf file, post that file
0
 
MCUITAuthor Commented:
# Example MySQL config file for very large systems.
#
# This is for a large system with memory of 1G-2G where the system runs mainly
# MySQL.
#
# You can copy this file to
# /etc/my.cnf to set global options,
# mysql-data-dir/my.cnf to set server-specific options (in this
# installation this directory is /var/lib/mysql) or
# ~/.my.cnf to set user-specific options.
#
# In this file, you can use all long options that a program supports.
# If you want to know which options a program supports, run the program
# with the "--help" option.

# The following options will be passed to all MySQL clients
[client]
#password	= your_password
port		= 3306
socket		= /var/lib/mysql/mysql.sock

# Here follows entries for some specific programs

# The MySQL server
[mysqld]
port		= 3306
socket		= /var/lib/mysql/mysql.sock
skip-locking
key_buffer = 384M
max_allowed_packet = 128M
table_cache = 512
sort_buffer_size = 4M
read_buffer_size = 4M
read_rnd_buffer_size = 8M
myisam_sort_buffer_size = 64M
thread_cache_size = 8
query_cache_size = 32M
# Try number of CPU's*2 for thread_concurrency
thread_concurrency = 8

# Don't listen on a TCP/IP port at all. This can be a security enhancement,
# if all processes that need to connect to mysqld run on the same host.
# All interaction with mysqld must be made via Unix sockets or named pipes.
# Note that using this option without enabling named pipes on Windows
# (via the "enable-named-pipe" option) will render mysqld useless!
# 
#skip-networking

# Disable Federated by default
skip-federated

# Replication Master Server (default)
# binary logging is required for replication
log-bin=mysql-bin

# required unique id between 1 and 2^32 - 1
# defaults to 1 if master-host is not set
# but will not function as a master if omitted
server-id	= 1

# Replication Slave (comment out master section to use this)
#
# To configure this host as a replication slave, you can choose between
# two methods :
#
# 1) Use the CHANGE MASTER TO command (fully described in our manual) -
#    the syntax is:
#
#    CHANGE MASTER TO MASTER_HOST=<host>, MASTER_PORT=<port>,
#    MASTER_USER=<user>, MASTER_PASSWORD=<password> ;
#
#    where you replace <host>, <user>, <password> by quoted strings and
#    <port> by the master's port number (3306 by default).
#
#    Example:
#
#    CHANGE MASTER TO MASTER_HOST='125.564.12.1', MASTER_PORT=3306,
#    MASTER_USER='joe', MASTER_PASSWORD='secret';
#
# OR
#
# 2) Set the variables below. However, in case you choose this method, then
#    start replication for the first time (even unsuccessfully, for example
#    if you mistyped the password in master-password and the slave fails to
#    connect), the slave will create a master.info file, and any later
#    change in this file to the variables' values below will be ignored and
#    overridden by the content of the master.info file, unless you shutdown
#    the slave server, delete master.info and restart the slaver server.
#    For that reason, you may want to leave the lines below untouched
#    (commented) and instead use CHANGE MASTER TO (see above)
#
# required unique id between 2 and 2^32 - 1
# (and different from the master)
# defaults to 2 if master-host is set
# but will not function as a slave if omitted
#server-id       = 2
#
# The replication master for this slave - required
#master-host     =   <hostname>
#
# The username the slave will use for authentication when connecting
# to the master - required
#master-user     =   <username>
#
# The password the slave will authenticate with when connecting to
# the master - required
#master-password =   <password>
#
# The port the master is listening on.
# optional - defaults to 3306
#master-port     =  <port>
#
# binary logging - not required for slaves, but recommended
#log-bin=mysql-bin

# Point the following paths to different dedicated disks
#tmpdir		= /tmp/		
#log-update 	= /path-to-dedicated-directory/hostname

# Uncomment the following if you are using BDB tables
#bdb_cache_size = 384M
#bdb_max_lock = 100000

# Uncomment the following if you are using InnoDB tables
#innodb_data_home_dir = /var/lib/mysql/
#innodb_data_file_path = ibdata1:2000M;ibdata2:10M:autoextend
#innodb_log_group_home_dir = /var/lib/mysql/
#innodb_log_arch_dir = /var/lib/mysql/
# You can set .._buffer_pool_size up to 50 - 80 %
# of RAM but beware of setting memory usage too high
#innodb_buffer_pool_size = 384M
#innodb_additional_mem_pool_size = 20M
# Set .._log_file_size to 25 % of buffer pool size
#innodb_log_file_size = 100M
#innodb_log_buffer_size = 8M
#innodb_flush_log_at_trx_commit = 1
#innodb_lock_wait_timeout = 50

[mysqldump]
quick
max_allowed_packet = 128M

[mysql]
no-auto-rehash
# Remove the next comment character if you are not familiar with SQL
#safe-updates

[isamchk]
key_buffer = 256M
sort_buffer_size = 256M
read_buffer = 2M
write_buffer = 2M

[myisamchk]
key_buffer = 256M
sort_buffer_size = 256M
read_buffer = 2M
write_buffer = 2M

[mysqlhotcopy]
interactive-timeout

Open in new window

0
 
SANDY_SKCommented:
from where your moodle server is try doing a telnet to your MySQL server on the 3306 port

telnet <DB server IP> 3306
0
 
MCUITAuthor Commented:
I'm not able to.  The folks that host our Moodle install do not give us access to anything but Moodle itself.  I did try to telnet from my local computer and it said:
telnet: connect to address ***.***.***.75: Connection refused
telnet: Unable to connect to remote host
0
 
SANDY_SKCommented:
Hmmm... the MySQL is installed on what OS?? and is it on the same network as the moodle server??
0
 
MCUITAuthor Commented:
It's a linux box, and no, it's a separate server.
0
 
SANDY_SKCommented:
connection refused means it is for sure to do with your firewall....
0
 
MCUITAuthor Commented:
I figured as much, but I don't have the first clue on how to disable/modify it.
0
 
SANDY_SKCommented:
hmmm... Linux box...

you will have to check how to change the firewall settings there...

Sorry, I am also not so sure with a Linux box, but it is something to do with IPTables and configuring the same.

May be you can start another thread asking how to allow IPs on a firewall on a linux box
0
 
MCUITAuthor Commented:
I will do that.  Thank you for your help.
0
 
MCUITAuthor Commented:
Did not get a solution, but helped a lot in getting me closer to one.
0

Featured Post

Ask an Anonymous Question!

Don't feel intimidated by what you don't know. Ask your question anonymously. It's easy! Learn more and upgrade.

  • 14
  • 11
Tackle projects and never again get stuck behind a technical roadblock.
Join Now