Solved

Citrix application launch is taking long time and disappears without Errors

Posted on 2012-03-14
15
1,756 Views
Last Modified: 2015-01-02
Hi

Suddenly the Citrix Xenapp 6.5 server when users try to connect to via web, the launch starts and then disappears automatically without prompting and there is no errors.

We have 2 servers in Load balancing mode ?

Can someone help ?
0
Comment
Question by:gkumar72
  • 8
  • 4
  • 2
  • +1
15 Comments
 
LVL 23

Expert Comment

by:Ayman Bakr
ID: 37722073
In the farm properties in the Access Management Console, have you used CPU sharing?

Then disable it and test again.

This is a bug which I am not sure whether the latest hotfixes resolves or not - try applying the latest hotfixes:

http://support.citrix.com/product/xa/v6.5_2008r2/hotfix/general/
0
 

Author Comment

by:gkumar72
ID: 37723334
CPU is not shared. still down
0
 
LVL 23

Expert Comment

by:Ayman Bakr
ID: 37723571
Have you applied the hotfixes?

Check also the event viewer for any events logged. Provide with the event IDs.
0
Netscaler Common Configuration How To guides

If you use NetScaler you will want to see these guides. The NetScaler How To Guides show administrators how to get NetScaler up and configured by providing instructions for common scenarios and some not so common ones.

 
LVL 7

Expert Comment

by:Jayanta Sarmah
ID: 37724157
If this is not the bug Mutawadi is reffering to, then I will like to see the below results,

1. Publish a notepad give access to a admin account , and verfy that application can be launch , or same issue for the same.

 --> If it does launch fine, verify the permission for your remote users in the particular application location and also Read/execute to system root etc.

2. Connect the servers from the Citrix console , by going to connect server --> Connect to server desktop, These all steps will confirm you that ICA is working fine , and servers are responding to the ICA connection.

Gud luck
0
 

Author Comment

by:gkumar72
ID: 37724366
we tried the above option of publishing notepad and the same error.

We are currently installing the hotfixes...
0
 

Author Comment

by:gkumar72
ID: 37724680
after installing hotfixes also it is not working. any other suggestions ?
0
 
LVL 7

Expert Comment

by:Jayanta Sarmah
ID: 37724960
Did you tried connecting to the servers from the console,  Connect to server - Connect to server desktop , try logging in as Admin if teh login window pops up.

Next make sure firewall is disabled in both the servers , Atleast temporarill for now.


Then make sure you have not selected any unappropriate Load balanced policy by mistake ..

thats all I can think of for now
0
 

Author Comment

by:gkumar72
ID: 37726522
No change... when we connect to the application piblished it states waiting for Local Session Manager and then disappears..

All hotfixes are installed..

Any suggestions will be very helpful
0
 
LVL 23

Expert Comment

by:Ayman Bakr
ID: 37729073
Can you test with one user while trying to launch an application and check during the launch on the server whether the process TSTheme.exe is hanging for the user. Kill this process and see if the user can successfully start his application.

If this is true then browse to the TSTheme.exe: C:\Windows\System32\TSTheme.exe and open its NTFS security properties. Remove your users from the list of NTFS permissions.

Some people did this and didn't find any adverse effect of doing so. But I would recommend you to monitor it until you are confident that there are no adverse effects of doing this.

Hope this helps.
0
 

Author Comment

by:gkumar72
ID: 37734052
not able to find TSTheme.exe... any other help....
0
 
LVL 23

Expert Comment

by:Ayman Bakr
ID: 37734165
It is a system and hidden file. You have to change your view to show hidden and system files.

Also try looking for it under:

C:\Windows\SysWOW64\
0
 

Author Comment

by:gkumar72
ID: 37813179
We now built a Xenapp 6.0 and we have the same issue. Can this be due to Active Directory any policy setting which is preventing the application launch...

Please suggest...
0
 
LVL 8

Expert Comment

by:piyushranusri
ID: 38550290
Please refer this article and do this
revert what output you get

http://community.spiceworks.com/topic/150806-published-application-connects-then-disappears
0
 

Accepted Solution

by:
gkumar72 earned 0 total points
ID: 40520368
the Domain controller was not natvie AD once that was fixed the issue disappearewd
0
 

Author Closing Comment

by:gkumar72
ID: 40527490
that is what fixed the issue
0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Citrix VMs 5 79
XenApp without license server 8 44
xenapp 78 shadowing options 4 50
citrix acess gateway logs 5 37
After several days of searching and hunting for limited documentation, I wanted to share this guide to hopefully save someone the hassle of trying to figure this out on their own. I have tested this on Xendesktop 7.1 and PS 4.5 running simultaneous…
Citrix policies are the most efficient method to configure and tune XenDesktop environments, allowing organizations to control connection, security and bandwidth settings based on various combinations of users, devices or connection types.  Citrix …
How to install and configure Citrix XenApp 6.5 - Part 1. In this video tutorial we have explained step by step installation of Citrix XenApp 6.5 Server on Windows Server 2008 R2 is explained in this video. We have explained the difference between…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.

776 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question