Solved

Not your typical "Cannot view web site added to IIS 7 either internally OR externally"

Posted on 2012-03-14
1
321 Views
Last Modified: 2012-03-17
OK. This is driving me insane. I'm new to IIS7. I just developed a web site in Expressions Web 4, sent it over to my web server, added the site to IIS 7, and much to my chagrin, cannot view it at localhost or at www.myurl.com. How annoying is that?

1. It shouldn't be a firewall issue. I CAN get the default IIS 7 web pg to come up internally AND externally if I don't have my web site registered in IIS 7., both by using my URL or localhost.
2. I'm using Anonymous Authorization for starters, what I really want is Basic Auth and HTTPS.
3. The Application Pool Identity DOES have permissions on my web site folder, as does IUSR.
4. the IIS default site's bindings are on HTTP, all unassigned.
5. My site's bindings are on HTTP, my internal ip address (192.168.5.5 for example), www.myurl.com for host.
6. The web server is running on Windows 7 Ultimate sp1, as VM on a Windows 2008 R2 server sp1. The actual NIC address (the physical nic in the box) used for that VLAN is 192.168.5.1
7. As I said, it shouldn't be firewall issue. I have packet filter rules allowing all HTTP to virtual web server @ 192.168.5.5, and appropriate masquerading rules.
8. It's not the pg itself. If I go to the folder physically and double click the pg I can view it just fine.

Oh, when I say I can't access the page internally or externally, this is what I mean: It just hangs there in the browser waiting for some type of response from the server. Nothing. I've looked in the firewall log, and the packets are getting routed to the correct machine. And Windows Firewall is disabled on the web server. It's just IIS settings which are messed up, I think.

Any ideas? I've wasted hours on this.

Thanks,
Julie
0
Comment
Question by:jtittler
1 Comment
 

Accepted Solution

by:
jtittler earned 0 total points
ID: 37733223
I fixed it. I had a faulty web config file, and I had all the user permissions on the site's folder correct, but I seemed to need to add the same permissions to the site's parent folder. So, for a web site folder of c:\WebSites\mysite, I had to fix the permissions on c:\WebSites. The question can be closed.
0

Featured Post

Three Reasons Why Backup is Strategic

Backup is strategic to your business because your data is strategic to your business. Without backup, your business will fail. This white paper explains why it is vital for you to design and immediately execute a backup strategy to protect 100 percent of your data.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Although it can be difficult to imagine, someday your child will have a career of his or her own. He or she will likely start a family, buy a home and start having their own children. So, while being a kid is still extremely important, it’s also …
Boost your ability to deliver ambitious and competitive web apps by choosing the right JavaScript framework to best suit your project’s needs.
The viewer will learn how to look for a specific file type in a local or remote server directory using PHP.
Any person in technology especially those working for big companies should at least know about the basics of web accessibility. Believe it or not there are even laws in place that require businesses to provide such means for the disabled and aging p…

776 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question