Solved

MS CRM 4.0 postal code field won't except 0 as first number

Posted on 2012-03-14
10
513 Views
Last Modified: 2012-03-26
I just noticed that CRM removes the first character of a zip code if it is a Zero. This is a problem because there are states such as NJ and RI that have zero as the first number in the sequence.

I was wondering does anyone know how to make CRM leave the first zero there?
0
Comment
Question by:bigjdve
  • 5
  • 3
  • 2
10 Comments
 
LVL 27

Expert Comment

by:Chinmay Patel
ID: 37722173
Hi bigjdve,

How about using a text datatype? I think you tried with a number datatype.

Regards,
Chinmay.
0
 
LVL 3

Author Comment

by:bigjdve
ID: 37722185
I have looked at that since that would be the way to fix it in Excel. However in CRM that field is predetermined and is set as a NVARCHAR.
0
 
LVL 27

Expert Comment

by:Chinmay Patel
ID: 37722283
Could you take a screen shot of the attribute and post it here?
0
 
LVL 3

Author Comment

by:bigjdve
ID: 37722480
Here is the screenshot.
attribute.docx
0
 
LVL 27

Assisted Solution

by:Chinmay Patel
Chinmay Patel earned 250 total points
ID: 37728652
Can you check if someone has inserted custom script on this field?
0
U.S. Department of Agriculture and Acronis Access

With the new era of mobile computing, smartphones and tablets, wireless communications and cloud services, the USDA sought to take advantage of a mobilized workforce and the blurring lines between personal and corporate computing resources.

 
LVL 3

Author Comment

by:bigjdve
ID: 37748611
Nobody has made any changes to this particular field.

Any nvarchar field that you create by default will remove any 0 from the beginning.

I am trying to find a way to not have  that happen.
0
 
LVL 29

Assisted Solution

by:Feridun Kadir
Feridun Kadir earned 250 total points
ID: 37748649
That is definitely not normal behaviour for Dynamics CRM. Are you saying this happens to any field that you create of type nvarchar?
0
 
LVL 3

Accepted Solution

by:
bigjdve earned 0 total points
ID: 37749406
It looks like I found the issue.

The attribute was set to IME_Mode = inactive

I set it to IME_Mode = auto

and now it is working.

I compared against a couple other Nvarchar fields and found the one difference listed above and tried it.

Now it works.
0
 
LVL 29

Expert Comment

by:Feridun Kadir
ID: 37749716
Amazing, IME stands for input method editor and I thought it was only relevant for languages with complicated character sets. I've never changed the setting from auto but I'm surprised that setting it to inactive has the effect that it does.  One to remember.

Thanks for the points - a fair allocation.
0
 
LVL 3

Author Closing Comment

by:bigjdve
ID: 37764974
Feridun - I am giving you 1/2 the points as your comment got me to look more closely at all of the settings on the field.

Chinmay_patel - I am giving you 1/2 as well.

After seeing comments from both experts, I was able to fix the issue myself.
0

Featured Post

Backup Your Microsoft Windows Server®

Backup all your Microsoft Windows Server – on-premises, in remote locations, in private and hybrid clouds. Your entire Windows Server will be backed up in one easy step with patented, block-level disk imaging. We achieve RTOs (recovery time objectives) as low as 15 seconds.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I wanted to share this with fellow Experts, who might not know. How often have you wanted to learn something, only to be set back by either restrictions imposed on "trial" or "evaluation" software?  How often have you had to rebuild a home networ…
This very simple solution applies to a narrow cross-section of the "needs to close" variety. In this case, the full message in Event Viewer was in applog, Event ID 1000: Faulting application iexplore.exe, version 8.0.6001.18702, faulting module …
Viewers will learn how to maximize accessibility options in an Excel workbook for users with accessibility issues.
The viewer will learn how to simulate a series of sales calls dependent on a single skill level and learn how to simulate a series of sales calls dependent on two skill levels. Simulating Independent Sales Calls: Enter .75 into cell C2 – “skill leve…

929 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now