iPhone email issues

I have a user that uses an iphone 4s.  It is connected to our Microsoft exchange server. This person claims that they receive email fine when they are up around the main network.  (In the same area of the wireless network, which is on the same network as the exchange server.)  They say when they travel away from this network, they get no email on the iphone.

The rest of us here use blackberries and they have no problem receiving email when away from the main wireless network.  From what I understand these emails are sent and received over the Verizon network, and not wifi, which is what makes them work in other locations.

I set the iphone up in the typical way by going into email settings and entering the name of the server.  Is there some settings that is causing this phone to only receive email over wifi?  I believe the issue is that the iphone isn't receiving email over the verizon network, but I could be wrong.  I'm not sure what the problem is but if anyone can shed some light on this I would appreciate it.
ercaseyAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

raeldriCommented:
did you enter the full FQDN of the server name that would be used externally? if its the internal name then of course it wont resolve externally.
0
rtayIT DirectorCommented:
I would agree it is a DNS issue with your FQDN.  Test this by turning the Wifi off on the iphone and set up the user again.  I have the same, but opposite issue.  Phone recieves email on cell network, but not wifi.  this is because i never set the DNS to resolve the FQDN from the inside out.  your FQDN should look something like emai.yourdomain.com.  It is what you set up for OWA.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Alvin PetittCommented:
Also, and this may sound goofy and obvious, but check the Settings>Network>Cellular Data and make sure it's On. If that is Off, then data will only come through via a WiFi connection.
0
Cloud Class® Course: MCSA MCSE Windows Server 2012

This course teaches how to install and configure Windows Server 2012 R2.  It is the first step on your path to becoming a Microsoft Certified Solutions Expert (MCSE).

ercaseyAuthor Commented:
I think you are correct rtay it seems to be a name resolution problem.  I had entered the server as: servername.domain.local.  When I took your suggestion and used mail.domain.com format the phone was able to receive email in other locations.
0
ercaseyAuthor Commented:
Ok this works as long as I turn off Wifi when they are in range of the main network.  However, the phone will not receive email when connected by Wifi to the main network.  I know this has to do with name resolution because internally it receives mail fine at servername.domain.local.  How does a person set this up so it works everywhere?  I feel like I'm missing something when I say just turn off Wifi when around main network.
0
ercaseyAuthor Commented:
Thanks for your help alanhardisty.  Turns out the previous administrator had the owa primary zone and A record already configured.  I changed the server name on the phone to owa.domain.com. and now it appears to be working on both the internal wifi network and the Verizon network.
0
Alan HardistyCo-OwnerCommented:
:) - Glad it is working for you.

Alan
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
iPhone

From novice to tech pro — start learning today.