• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1447
  • Last Modified:

VPN Server: Connects but no Internet Access

Hi,

I configured VPN Server on my windows 2003 VPS which has a single NIC using this link:
http://www.howtonetworking.com/vpn/2003vpn11.htm
I also set the static IP address from 192.168.10.1 to 192.168.10.100.
I enabled Dial-In for "vpntest" user.

Now my device connects to the server through PPTP VPN. The server assigns 192.168.10.6 to it. I can ping server on my device. also on server I can ping the device successfully.

the problem is that my device does not have Internet access. Here is my route table. I thought there should be something wrong with routing process:

=================================================================
Active Routes:
Network Destination        Netmask          Gateway       Interface  Metric
          0.0.0.0          0.0.0.0    178.162.154.1  178.162.154.241     20
     31.58.19.110  255.255.255.255    178.162.154.1  178.162.154.241     20
        127.0.0.0        255.0.0.0        127.0.0.1        127.0.0.1      1
    178.162.154.0    255.255.255.0  178.162.154.241  178.162.154.241     20
  178.162.154.241  255.255.255.255        127.0.0.1        127.0.0.1     20
  178.162.255.255  255.255.255.255  178.162.154.241  178.162.154.241     20
     192.168.10.1  255.255.255.255        127.0.0.1        127.0.0.1     50
     192.168.10.6  255.255.255.255     192.168.10.1     192.168.10.1      1
        224.0.0.0        240.0.0.0  178.162.154.241  178.162.154.241     20
  255.255.255.255  255.255.255.255  178.162.154.241  178.162.154.241      1
Default Gateway:     178.162.154.1


I am a software developer and I have no strong networking or server background. Would you please help me what should I do to grant my device to access Internet?
0
Hamidreza Vakilian
Asked:
Hamidreza Vakilian
  • 3
1 Solution
 
dubeyrupeshCommented:
in vpn setting use remove the tick on vpn gateway ip
0
 
Hamidreza VakilianSenior iOS DeveloperAuthor Commented:
Sorry I don't know where should I find this setting.
0
 
Hamidreza VakilianSenior iOS DeveloperAuthor Commented:
I found the answer myself. I should have enabled NAT/basic firewall when I configured routing and remote access. Then in NAT/basic firewall I should create a new interface. Tick the public interface and enable NAT on this interface.
0
 
Hamidreza VakilianSenior iOS DeveloperAuthor Commented:
I found it myself.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Improved Protection from Phishing Attacks

WatchGuard DNSWatch reduces malware infections by detecting and blocking malicious DNS requests, improving your ability to protect employees from phishing attacks. Learn more about our newest service included in Total Security Suite today!

  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now