sql2008 freeze due to low memory

I can't login to sql server now due to low memory, when I check the error log it found following:

2012-03-15 07:29:24.12 spid59      Configuration option 'max server memory (MB)' changed from 30000 to 16. Run the RECONFIGURE statement to install.

what I can do now to again login to sql and change memory to bigger size ?
motioneyeAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

QPRCommented:
I'd restart the service to unload all currently used memory and then quickly jump in and change the max server memory...

http://msdn.microsoft.com/en-us/library/ms191144.aspx
BuggyCoderCommented:
somehow the minimum memory assigned automatically by SQL has been assigned in your case.

Use the following:-
sp_configure 'show advanced options', 1;
GO
RECONFIGURE;
GO
sp_configure 'max server memory', 4096;
GO
RECONFIGURE;
GO

Here is a link that tells you how to modify the same:-
http://msdn.microsoft.com/en-us/library/ms178067.aspx
http://www.sqlservercentral.com/blogs/glennberry/2009/10/29/suggested-max-memory-settings-for-sql-server-2005_2F00_2008/

Here are some other utility links for your help:-
http://msdn.microsoft.com/en-us/library/ms180797.aspx

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
sachinpatil10dCommented:
Enable advanced options:
USE master
EXEC sp_configure 'show advanced options', 1
RECONFIGURE WITH OVERRIDE

Open in new window

To set a max server memory limit of 1 GB depending on your RAM:
USE master
EXEC sp_configure 'max server memory (MB)', 1024
RECONFIGURE WITH OVERRIDE

Open in new window

Display new set configuration:
USE master
EXEC sp_configure 'max server memory (MB)'

Open in new window

Disable advanced options:
USE master
EXEC sp_configure 'show advanced options', 0
RECONFIGURE WITH OVERRIDE

Open in new window

It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SQL Server

From novice to tech pro — start learning today.