Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 924
  • Last Modified:

2008 Terminal Services - Having to login twice?

How can I get rid of that ? When I put my password it doesn't do anything except that I have to do it once more and then it logs me in.

Thanks
Cheers
0
Bianchi928
Asked:
Bianchi928
  • 2
1 Solution
 
dkumar82Commented:
If I understood your question – You have problem with Single sign on.

Please try to check the below hot fix - http://support.microsoft.com/kb/977507
“WebSSO (Web Single Sign On) does not work as expected, causing a "double prompt" for credentials in applications launched via RemoteApps published via Remote Desktop Web Access in Windows Server 2008 R2.”
0
 
Bianchi928Author Commented:
That's the solution for it

Browse to HKLM\SYSTEM\CurrentControlSet\Control\Lsa

- Locate Security Packages and add tspkg to the bottom of the list

- Browse to HKLM\System\CurrentControlSet\Control\SecurityProv iders

- Locate Security Providers and add , credssp.dll at the end

- Restart the computer

- Now check that Network Level Authentication is enabled as above

In the RDP file that you use to connect, make sure you've got the following settings:

authentication level:i:0
prompt for credentials:i:0
promptcredentialonce:i:1
enablecredsspsupport:i:1
0
 
Bianchi928Author Commented:
It solved the problem.
0

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now