FIREWALLPORTS for SQL 2008 cluster on windows 2008 R2

HI, building a sharepoint farm, on 2008 R2, with SQL 2008 and SHarepoint 2010

The desihn insisist on the windows firewall being left on,  but I cant seem to get the right ports.

Do you know of any resources that could helo me with this please.

what ports to open. would be a good start
thank you
mhamerAsked:
Who is Participating?
 
b_levittConnect With a Mentor Commented:
Port 1433 is only the case if the sql server is the default instance. in the case of a named instance (SQLSERVER/InstanceName), the client first attepts to connect via udp to port 1434 to get the proper port number and then connects to that port.  If you are using a firewall then you can set a fixed port for the named instance and then open both that port (tcp) and the udp 1434 port.  You can also add an exclusion for sqlserver.exe  I believe this article describes it well:
http://www.mssqltips.com/sqlservertip/1929/configure-windows-firewall-to-work-with-sql-server/

However, your cluster complicates things with a known issue.  When the client connects to the cluster ip on udp 1434, the server replies with a packet having the dedicated ip as the source address, causing the client firewall to drop the response as an unsolicited packet.  There are three workarounds that I know of:  
One, configure the client firewall to allow all inbound udp.  This allows the client to correctly receive the port number to connect to for the named instance.

Or Two, configure the clients to connect to the host/port combination rather than the host/named instance.  This eliminates the need for the udp lookup for the instance port.

Or three, give the server an additional IP and put the instance on that ip with port 1433 (using the sql server configuration manager as shown in the above article).  Then you would need to configure clients to connect to this new ip rather than the old ip/instance combination.  This also eliminates the need for the udp lookup for the instance port.

This blog post documents the issue:
http://blogs.technet.com/b/nettracer/archive/2010/10/05/sql-browser-may-not-be-reachable-through-firewalls-when-it-runs-on-a-cluster.aspx
0
 
shan2supportCommented:
Hi mhamer

 Please run below command. or chek the link please


netsh firewall set portopening protocol = TCP port = 1433 name = SQLPort mode = ENABLE scope = SUBNET profile = CURRENT

A similar example using the Windows Firewall for Advanced Security helper:

netsh advfirewall firewall add rule name = SQLPort dir = in protocol = tcp action = allow localport = 1433 remoteip = localsubnet profile = DOMAIN



http://technet.microsoft.com/en-us/library/cc646023.aspx
0
 
mhamerAuthor Commented:
the link to blog post had lots of good information
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.