Solved

exchange 2010 install

Posted on 2012-03-15
28
783 Views
Last Modified: 2012-04-01
Hi
I am in the process of replaceing my exchange 03 box with a new mail server. Both are currently running and interacting together.My next step is to create a send connector in the exchange 2010 box that will use my current published MX record of the old server. I would like some pointers on the proceedure to use. The default "internet" connector erronously picks up the IP of my firewall as the IP of the new mail server.
send/receive Internal mail is functioning on the new server as well as receiving external mail.

Thx
0
Comment
Question by:fred_lambert
  • 15
  • 12
28 Comments
 
LVL 15

Expert Comment

by:markdmac
ID: 37729601
Simply create a new send connector and walk through the wizard. Leave the default stuff as is.
0
 

Author Comment

by:fred_lambert
ID: 37729908
Hi

I did that the first time and the mail server picked up the wrong ip address. specifically the public IP of our firewall.
0
 
LVL 15

Expert Comment

by:GreatVargas
ID: 37741964
The send connector picked up the ip address? please explain. If you are moving from 2k3 to 2k10. all you have to do is create a new send connector, configure it to use smarthost or DNS, bind it to the 2010 HUB server. And then you will have two send connectors. one from 2003 and one from 2010, because send connectors are organization wide. Disable or delete the 2003 send connector and test the mail flow. The send connector wont get no IP address. he just send mail for the org either through a smarthost or directly
0
 

Author Comment

by:fred_lambert
ID: 37742164
Hi

Yes, the new mail server "assumed" the IP of our firewall replaceing the current "old" mail server on all sent emails with the name of the new server and IP of the firewall. We did use the new connector wizard and chose DNS.
0
 
LVL 15

Expert Comment

by:GreatVargas
ID: 37742193
where do you see that information? on the message options of a sent message? the new mail server, when using a send connector created on the 2010 server, would not send the mail back to the 2003 server to then be sent into the Internet. He would send directly as this is the normal behavior and what you want him to do. 2003 will be decomissioned and you want 2010 to send direct. So if mail is going in and out of the org, just make sure as well that mail comes in directly to 2010, that will send to 2003 if the mailbox is still there.. after having mail coming in and out through 2010 then you are ok to go further on other migration steps.
0
 

Author Comment

by:fred_lambert
ID: 37742629
Yes on message options of sent email. .... Will look again at the relationship between the two servers... the current MX record is for the old server at this point however. Are you suggesting to register another MX for the new server as well?
0
 
LVL 15

Expert Comment

by:GreatVargas
ID: 37742706
No. does the old server has an external ip address? or are you nating port 25 there? if he has an external ip address then you can either change that ip to the 2010 server or create a new mx record with another ip. if you are nating the port 25 just change the nat to point to the 2010 server. be sure that 2010 receive connector accepts anonymous relay to get mail from the internet.
0
 

Author Comment

by:fred_lambert
ID: 37771343
OK Still working on this issue...... Here is my objective

To use the old 03 exchange server as a bridghead and the new 2010 exchange server as a hub.
Mail flow will continue to move through the 03 server until functionality/stability of the new server is verified.
Presently:
mail flow works between the two exchange servers.
incomming mail from the internet also works on both servers
outgoing mail from the 2010 server does not work even after creating a number of variations of send connectors. 2010 exchange queue indicates send failure "a matching connector cannot be found to route the external recipient".  
Thx again for all your help!
0
 
LVL 15

Expert Comment

by:GreatVargas
ID: 37771378
On Exchange 2010 go to organization configuration->Hub transport and send connectors tab. do you have how many send connectors there? You should be using the 2003 send connector and mail flow will go through the routing group connector to 2003 and then sent to the internet. or you can create a new send connector, binded to the 2010 hub and with the address space * to send directly.
0
 

Author Comment

by:fred_lambert
ID: 37771795
Here is some info on the existing routing groups

[PS] C:\Users\administrator.COVENTRYCT\Desktop>GET-ROUTINGGROUPCONNECTOR MESSAGI
NG2-COVMAIL

Name                      SourceRoutingGroup         TargetRoutingGroup
----                      ------------------         ------------------
messaging2-covmail        Exchange Routing Group ... First Routing Group
messaging2-covmail        First Routing Group        Exchange Routing Group ...


Both are reflected in the 03 box as messaging2-covmail
I have created a send connector which does not show up under this command.
send connector is "covsend" address space SMTP address coventryct.org cost 1 smart host messaging2.coventryct.org source server covmail. external send mail returns the same error message. Should I be using the same name "messaging2-covmail" ?
0
 
LVL 15

Expert Comment

by:GreatVargas
ID: 37771904
Routing group connectors are just for mail to flow between 2003 and 2010

do a get-sendconnector command on 2010 or use the EMC to see them.

you need a send connector with * address space. this is to have mail sent to the Internet.

you dont need a send connector with the internal address space on it.
0
 

Author Comment

by:fred_lambert
ID: 37772104
get-sendconnector returns  COVSEND  addressSpaces SMTP:COVENTRYCT.ORG;1 enabled
0
 
LVL 15

Expert Comment

by:GreatVargas
ID: 37772132
that is why you cannot send mail to internet. that send connector just binds mails sent to @conventryct.org

is that your internal domain?

if you send an email to @xpto.com he wont find any send connector that matches that address space. so create one with * which will cover all domains and have that connector binded to the hub server. use smarthost if needed and test sending mail both from 2003 and 2010 mailboxes. it should work.
0
 

Author Comment

by:fred_lambert
ID: 37772338
just set up another send connector
GET-SENDCONNECTOR returns GLOBALSEND addressSpaces SMTP:*;1 ENABLED.
Outside send email attempts from new server never leave the Queue but shows no errors. Outside send messages from the old server are working.
0
Free book by J.Peter Bruzzese, Microsoft MVP

Are you using Office 365? Trying to set up email signatures but you’re struggling with transport rules and connectors? Let renowned Microsoft MVP J.Peter Bruzzese show you how in this exclusive e-book on Office 365 email signatures. Better yet, it’s free!

 

Accepted Solution

by:
fred_lambert earned 0 total points
ID: 37772937
Send now working ........ was a security setting. Thx for you help!
Next is verification, smartphone integration and retirement of 03 exchange
0
 

Author Comment

by:fred_lambert
ID: 37776932
OK Looks like I tried to close this too soon...... Send connector worked great for about 40 minutes and then all outgoing mail started populating the 2010 queue with "loop detected" errors attached to emails.
Again the objective is to route all outgoing outside mail through the 2003 exchange box. I'm baffled...
0
 

Author Comment

by:fred_lambert
ID: 37777077
Tried to close too soon..... other issues popped up
0
 
LVL 15

Expert Comment

by:GreatVargas
ID: 37778034
Ok. so the problem was what i told you. you needed to have the * on the send connector address space, like i told you.

now, how many send connectors do you have? only one on 2003? if you have more than one than delete all the others. As last resort i would say delete ALL the send connectors (check on ESM 2003 and EMC 2010) and create only ONE, with the address space * and on the smarthost DO NOT configure the other e-mail server (if created in 2010 do not put 2003 as smarthost and the opposite also applies). smarthosts are ONLY FOR NON EXCHANGE platforms relaying the mail outside.
the ROUTING GROUP connector should make sure that mail flows between 2003 and 2010. and you can test it by sending mail from a 2003 user to a 2010 user. if it works DONT CHANGE the routing group connector.
0
 

Author Comment

by:fred_lambert
ID: 37778082
Yup the wildcard did take care of the send message issue. I have removed the send connector and checked through the console that there were none. Recreated the send connector (on the 2010 box) with the 2003 box identified as a smart host. Ran fine again for about 30 to 45 minutes and started failing all outside sent emails and collecting them in the 2010 queue as looping errors
0
 
LVL 15

Expert Comment

by:GreatVargas
ID: 37778224
you cannot specify the 2003 as smarthost. like i told you smarthosts are not exchange servers. if you specificy the 2003 as smarthost what happens is:
message from 2003 user:
2003->2010->2003(because the 2010 as 2003 as smarthost)->2010->2003... etc

thats a loop!!!

if you have an appliance that relays incoming and outgoing mail, specify that on the smarthost. if you dont, dont specify anything.
0
 

Author Comment

by:fred_lambert
ID: 37778258
Then I will end up with my first issue .... choosing use DNS  "MX" records to route mail worked fine. Sent emails went through the 2010 box to the internet with the "wrong" ip address however causing us to be black listed as a potential spam server..... as the IP and server name did not match our published MX records.  Perhaps I missed some crucial setting here?
0
 
LVL 15

Expert Comment

by:GreatVargas
ID: 37778361
Yes you are. questions:

how is the mail routed inside?

Internet->router-> Nated to exchange?

or is it: Internet->e-mail appliance->Exchange?
you need to configure your router to do one to one nat on port 25. and he must deliver mail (NAT) to the Exchange 2010 Box.. (who needs to have anonymous auth on the receive connector to get mail from the Internet.
It's as simple as, mail comes, gets nated to the internal IP of the exchange server and goes out with a nat with the same external IP. Do you have external ips on your Exchange servers? you shouldnt, but if you do, then create the send connector only on 2003 so that mail goes out from 2003 and with that IP. But like i said. NO EXCHANGE on smarthosts
0
 

Author Comment

by:fred_lambert
ID: 37778394
Understand...... Yes Internet > public IP>Sonicwall>privite IP > Exchange 2003 and of course the reverse.  New server is set the same but no published MX only A record.
0
 
LVL 15

Expert Comment

by:GreatVargas
ID: 37778712
you dont need to mx for the two servers. just one.

set incoming as:
Internet->sonicwall->Exchange 2010-> Exchange 2003 (dont need to do nothing. it will go to 2003 if the mailbox is there)

and set as smarthost for the outgoing the sonicwall ip. allow the exchange 2010 ip to relay on the sonicwall configs.
0
 
LVL 15

Expert Comment

by:GreatVargas
ID: 37778715
and if needed configure sonic wall to forward all mail from a domain that is not your email domain(s) to forward it to the Internet
0
 

Author Comment

by:fred_lambert
ID: 37781256
Had set 2010 origionally this way... It picked up the IP of the sonicwall and my Exchange server was flagged as a spam server due to the different IP. Am going to try to NAT the new server to user the public IP of the old server in the SonicWall. Any thoughts?
0
 
LVL 15

Expert Comment

by:GreatVargas
ID: 37781285
To use the public IP? do you have public IP's on your exchange servers network cards?

NAT should forward port 25 traffic to the new server. And send connector should forward outgoing traffic to sonicwall.
0
 

Author Closing Comment

by:fred_lambert
ID: 37792689
send connector syntax ended up being the problem.  Was using the domain name in the name space and should have used a wildcard (*) only. Minor adjustments in security finished the task.
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

We are happy to announce a brand new addition to our line of acclaimed email signature management products – CodeTwo Email Signatures for Office 365.
Resolve DNS query failed errors for Exchange
The basic steps you have just learned will be implemented in this video. The basic steps are shown to configure an Exchange DAG in a live working Exchange Server Environment and manage the same (Exchange Server 2010 Software is used in a Windows Ser…
This video discusses moving either the default database or any database to a new volume.

743 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now