Does HELO command works on exchange 2007.

We have recently moved from Exchange 2003 to Exchange 2007. There are lots of internal apps and tools running on different servers in our organization which sent mail alerts and reports to the concerned teams.
All tools/apps are sending alerts except one, although i have added its IP to my HUB transport servers anonymous relay like i did for others, below is the error i got in logs:

"javax.mail.MessagingException: Failure sending HELO command to SMTP server"

it was working fine when we were on exchange 2003.
When i am trying to telnet my HUB transport on port 25 from the server catering that app, it letting me thru with 220************  response.
pdixit1977Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

pdixit1977Author Commented:
Looks like you gave me 100 pages book. i was thinking that experts are here but it looks like experts exchange have google searchers only.....

can anyone please help me with this please
0
pdixit1977Author Commented:
@gudii9:
please have a look again on my question, i m NOT asking to remove internal info from header my friend.
0
Jamie McKillopIT ManagerCommented:
Hello,

The problem is that the javamail application on your server is not sending a correct HELO command to Exchange. It is likely that the javamail app is unable to retrieve the hostname of the server it is on. I would reach out to whoever built the application and have them assist in troubleshooting the issue.

JJ
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
pdixit1977Author Commented:
jjmck:
i was also suspecting the same but just wanted to confirm.
I have opened a case with that application vendor and let him know the issue. will update you..
Thanks
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.