[Webinar] Streamline your web hosting managementRegister Today

x
?
Solved

Setting up exchange 2010 on sbs 2011

Posted on 2012-03-15
17
Medium Priority
?
747 Views
Last Modified: 2016-11-23
I have setup sbs 2011. and Dell pro help has confirmed that it is setup correctly.  server software found an error by running check network wizard and fixed it.  Port mapping for sending email hadn't been setup.  I don't know why that is or how to check for that.

I have static ip address and have setup a record pointing to the ip address of my router and port forwarded port 25 to local ip address.  I have had at&t create reverse ip address for the public ip address of my router.

My server name is exchange.  the domain is samuelscompany.com.  The local domain is samuelscompany.local.  

The work stations connect to the exchange server.  Email goes and comes from the server.  I haven't changed the mx record yet, still letting old hosted exchange server function.

But I thought that I should be able to send email out.  I have tried, but the email never gets to its destination.

Are there any clues here as to what I have done wrong.

Or do I have to wait until I change the mx record?

thanks
0
Comment
Question by:topprops
  • 10
  • 2
  • 2
  • +2
17 Comments
 
LVL 8

Assisted Solution

by:Elmar Koschka
Elmar Koschka earned 668 total points
ID: 37725254
You run the "Connect to Internet Wizzard" without errors ?

What says https://www.testexchangeconnectivity.com/
0
 

Author Comment

by:topprops
ID: 37725285
yes ran connet internet without errors
0
 

Author Comment

by:topprops
ID: 37725425
is there some where to look on server for error messages about outgoing email.  or a way to test smtp sending.
0
Easily manage email signatures in Office 365

Managing email signatures in Office 365 can be a challenging task if you don't have the right tool. CodeTwo Email Signatures for Office 365 will help you implement a unified email signature look, no matter what email client is used by users. Test it for free!

 
LVL 8

Expert Comment

by:Elmar Koschka
ID: 37725449
via telnet:

telnet mailserver 25

HowTo: http://support.microsoft.com/kb/153119
0
 

Author Comment

by:topprops
ID: 37725569
I can telnet into server from local computer.

I have used mxtoolbox.com to test server.  I get the following response.

220 remote.samuelscompany.local Microsoft ESMTP MAIL Service ready at Thu, 15 Mar 2012 09:20:14 -0700
 OK - 76.209.185.251 resolves to exchange.samuelscompany.com
 Warning - Reverse DNS does not match SMTP Banner
 Supports TLS.
 0 seconds - Good on Connection time
 Not an open relay.
 5.304 seconds - Warning on Transaction time

this is a test on my public ip address since I haven't changed mx record yet


but I get connect failed if I telnet from my home computer  could not open connection to the host on port 25
telnet 76.209.185.251 25
0
 
LVL 44

Expert Comment

by:Adam Brown
ID: 37725576
If you have your MX records set to talk to Hosted Exchange, there's a good chance that the email from your server is getting blocked by reverse DNS spam filters. One common spam filtering technique is to run a reverse DNS lookup on the email address domain and see if the sending server matches that domain. If it doesn't, the mail is often dropped.
0
 

Author Comment

by:topprops
ID: 37725596
I set up reverse dns with at&t.  but the banner doesn't match what ever that means.  see response from mxtoolbox above
0
 
LVL 44

Assisted Solution

by:Adam Brown
Adam Brown earned 668 total points
ID: 37725633
The SMTP banner is the domain name that is set up on the Send/Receive connector. If you go to Server Config/Hub Transport, open your Receive connectors and set the FQDN to match your External DNS info. Do the same for send connectors under Organization Config\Hub Transport. And your home connection might actually be blocking port 25. It's not uncommon for residential ISPs to block that port. I'm able to get to it from my work location without issues.
0
 
LVL 4

Assisted Solution

by:kdubendorf
kdubendorf earned 664 total points
ID: 37725642
You should be able to send from this box before you throw the MX record.

How is your send connector set up?

Exchange Management Console > Organization Configuration > Hub Transport

Then go to the Send Connector tab.  Right click on the default and select properties.

You should have it configured to use the Domain Name System.    Is that set up?
0
 

Author Comment

by:topprops
ID: 37726421
yes send connector set to use dns.  

mail is still not getting to recipient.

and I setup exchange.samuelscompany.com in receive connector

I can telnet in from computers outside office.  just not my home computer.
0
 

Author Comment

by:topprops
ID: 37726424
I'm trying to send email to my home computer but my mail server is in england somewhere
0
 

Author Comment

by:topprops
ID: 37726486
I think it is a dns problem.  but I can get to websites so I dns must be working just not for email sending
0
 

Author Comment

by:topprops
ID: 37726495
I still get warning about reverse lookup smtp banner not matching
0
 
LVL 4

Expert Comment

by:kdubendorf
ID: 37727063
I think it's your reverse DNS.   Many organizations will not accept email from you if it is not set up properly.

Try setting up a SmartHost using an account on your ISP.   This will fix the reverse DNS issue.


You'll do it from the same Window where you're telling the computer to use DNS.
0
 
LVL 97

Expert Comment

by:Lee W, MVP
ID: 37727285
If your server isn't authorized to send mail and/or doesn't have an MX record defined, the receiving mail server (whoever runs that) may have decided to ignore your message/treat it as spam since it appears to be coming from a fake source.  Create an MX record for your server with a higher priority (with MX records, the lowest number is the "primary" server) and adjust your SPF record if you have one (and if you don't look into creating one).  And try sending to other accounts on different mail systems - example, if you've been testing with your gmail account, ask a neighbor (business) with their own server if you can send them a message.  Try Yahoo, Hotmail, or another provider.  They don't ALL use the same rules... but as it is, messages you're sending from the server probably look suspicious until you completely configure it to be your mail server.
0
 

Accepted Solution

by:
topprops earned 0 total points
ID: 37727301
That is what I did.  I have mx record set to 100.

but thanks.  I solved the problem by running the wizards again.  And I'm not sure this mattered, but I had two routers one from at&t and a stand along netgear router.  I set the at&t netopia router to bridge mode.  then reran the wizards and the problem was solved.  so I don't know if changing the router helped or if it was just an internal problem in sbs 2011.  I didnt see it do anything different on the new running of wizards.

thanks

Jon
0
 

Author Closing Comment

by:topprops
ID: 37741276
because I solved problem with help of Dell pro support rather than the advice here.  though the advice here was also helpful.
0

Featured Post

Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This applies to Dell but may also apply to other manufacturers as well. We ran across a few machines that just dropped recently it trust relationship with the server. After doing the basic removing and joining the domain again, it changed to No logo…
In my humble opinion (IMHO), TouchDown from Symantec is the best in class for this type of application, but Symantec has end-of-lifed it and although one can keep using it, it will no longer be supported or upgraded.  Time to look for alternatives t…
In this video we show how to create an email address policy in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Mail Flow…
This video tutorial shows you the steps to go through to set up what I believe to be the best email app on the android platform to read Exchange mail.  Get the app on your phone: The first step is to make sure you have the Samsung Email app on your …
Suggested Courses

640 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question