Displaying html pages within SharePoint

Hi;

I have a collection of htlm pages I would like to use within SharePoint.  I would like to avoid rebuilding them into ASP pages in Visual Studio if I can.  I am trying to use the page viewer web part within  SharePoint Designer to view the pages inside of a SharePoint page.  I have uploaded all the htlm files needed and placed them into a Site Assest library and then pointed the viewer at the relavant library folder.  The viewer is supposed to be able to display remote web content within the SharePoint page.  I can see the htlm page opened and displayed within a frame on the SharePoint page when I am in design mode.  However, when I open the page with a browser, the browser wants to download the .htm page rather than open it within SharePoint.  Is there some type of setting or properties changes i can make so that it will display the web page instead of trying to download it ? Thank you in advance for your help.
GWAllenAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Ted BouskillSenior Software DeveloperCommented:
It's easier than that.  Just put the pages into a standard document library, then use the page viewer web part.  The site asset library is used for other customization purposes.  You don't even need SharePoint Designer.

I actually used a legacy document tool to publish HTML documents this way and it worked great.
0
GWAllenAuthor Commented:
That sounds encouraging, I will give it a go.  Thanks
0
Ted BouskillSenior Software DeveloperCommented:
You can also put them into site folders directly like the Pages folder or the root of a site.  It depends on what you are trying to do.
0
Protecting & Securing Your Critical Data

Considering 93 percent of companies file for bankruptcy within 12 months of a disaster that blocked access to their data for 10 days or more, planning for the worst is just smart business. Learn how Acronis Backup integrates security at every stage

GWAllenAuthor Commented:
I think I must be overlooking something basic.  When I point page viewer to the .htm file and then open the page with the page viewer, instead of opening the .htm it wants to download it. Similar to if I clicked on file in a document library, it prompts to download the file.  What do I need to do to have it open and display the html page instead of downloading it ?  I tried different page viewer settings, but link only seem to work if I set page viewer to web page.  I can use the same path, but as folder or file, the link is not valid.  I am wondering if I was able to set it link as file it would open the file, as opposed to trying to download the file, which is what happen at on the web page setting ?
0
Ted BouskillSenior Software DeveloperCommented:
Yes, the page viewer should be set as a "Web Page" because the web page viewer becomes essentially an IFRAME.  Why didn't that setting work for you?
0
GWAllenAuthor Commented:
It basicaly has the same behavor as if I clicked on the file within the library, it wants to download the htlm page instead of open it.  I am using a short cut I copied from where htlm file is store as the link and the behavor on that page (I take it) is to download the document when the document is selected and off course I want the page opened.  Thanks for following along with me on this.  I imagine it is something small I am overlooking.
0
Ted BouskillSenior Software DeveloperCommented:
Hmm.  It's been awhile since I did this and you are right, there is probably a simple step you are missing.  What type of document library did you create?  When you create a document library you can set the type of document library.

Also, you could try just putting the HTML files into the root of the site using SharePoint designer and reference them that way.
0
GWAllenAuthor Commented:
I will look into both of those suggestions and get back to you.  Thanks
0
Robin HallSenior Web Solutions ArchitectCommented:
I had a similar issue in my SharePoint 2010 environment.  We were trying to open a PDF file and it kept asking us to save it instead of just opening it.  What ended up being the problem for me is that there was a setting at the Web Application level that was causing issues with non-Microsoft files.

I went to Central Admin > Manage Web Applications.  I then chose my Web Application and clicked on the "General Settings" button.  I then changed the Browser File Handling from "Strict" to "Permissive" and that fixed my issue.  I've included an attachment of the setting so you can read the text associated with it.

Browser Handling Screen Shot
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
GWAllenAuthor Commented:
This looks like it is what I need.  Is that Centeral Admin within SharePoint ? I am trying this on a remote SharePoint site and do not have admin access to the site management.  I can however pass it along.  Thank you very much
0
Robin HallSenior Web Solutions ArchitectCommented:
Yes it is the Central Admin site.  The url for it usually looks like http://servername:port

Whomever can manage your Central Admin (usually a Farm Administrator or whomever owns the SharePoint Server) will definitely be able to check and/or change the settings.  Hope it helps!
0
GWAllenAuthor Commented:
I tried it out on a different SharePoint server, where I do have adminstrative access, and it worked great !  That was exactly the fix it needed.  I have passed it a long to the folks managing the server where I want to use the htlm pages.  Many Thanks
0
GWAllenAuthor Commented:
Exactly what was needed and easy to impliment as well.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SharePoint

From novice to tech pro — start learning today.