Excel in Windows 7

This program really changed from the XP version.  I'm currently having problems in two areas;

1) How can I put two workbooks side by side on the desktop?

2) How can I use "paste special" or "paste values"

Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.


Open the Excel file for the first window.  For the second excel window, go to start and click on Excel.  

Right click on the cell for the paste special.
Also you can click on the Home tab, Paste arrow for the Paste Special.
open the first excel file and maximize it you will see two set of min max(toggle) and close buttons on top right corner of the excel window

select the max toggle button to bring the windows size to a small box in the center of screen (depending on the original position of the excel window)
then open the second excel file and do the same steps then manually drag the border of the each excel file to cover the half of the screen. this is how you view two excel side by side

to do past special

select the cell you intend to copy (assuming with formula) then select the cell you wish to paste then press the key on a full keyboard which represent a right click of mouse, or right click with mouse. then press S key and V key.

this action will copy just the value of source cell.
10 Tips to Protect Your Business from Ransomware

Did you know that ransomware is the most widespread, destructive malware in the world today? It accounts for 39% of all security breaches, with ransomware gangsters projected to make $11.5B in profits from online extortion by 2019.

Zerox HoopLinux AdminCommented:
check this site for paste special and paste values

menu - edit-paste special - paste values - OK.

Excel provides a simple solution for users who want to open all Excel files in separate windows. To access this setting, open Microsoft Excel. Click the Office Button and then click Excel Options, which is down at the bottom right side of the menu. Select Advanced, which is on the left, and then scroll down to Display. Select the Show All Windows in Taskbar checkbox and then click OK.
Q1) How can I put two workbooks side by side on the desktop?

Assuming you mean you want to see two Excel 2010 open workbooks side by side, Excel has a feature on the View Tab that will size your windows automatically.

  1. Open the workbooks that you want to arrange.

      You'll want to open at least two workbooks and select the worksheet in
      each workbook that you want to display.

  2. Click the Arrange All button in the Window group on the View tab.

      The Arrange Windows dialog box appears.

      Select the desired Arrange setting in the Arrange Windows dialog box.

  3. Make one of the following selections:

     *Tiled: Select this option button to have Excel arrange and size the windows
       so that they all fit side by side on the screen in the order in which you
       opened them.

     *Horizontal: Select this option button to have Excel size the windows equally
       and place them one above the other.

     *Vertical: Select this option button to have Excel size the windows equally
       and place them side by side.

     *Cascade: Select this option button to have Excel arrange and size the
       windows so that they overlap one another with only their title bars showing.

  4. Click OK.

After you arrange windows, activate the one you want to use (if it's not already selected) by clicking it. In the case of the cascade arrangement, you need to click the worksheet window's title bar, or you can access the worksheet from the Windows taskbar.
If you close one of the windows you've arranged, Excel doesn't automatically resize the other open windows to fill in the gap. To fix this, click the Arrange All command again on the View tab, select the desired arrangement, and click OK.

Q2) How can I use "paste special" or "paste values"

Excel normally copies all the information in the range of cells you select when you paste the data. Use Excel's Paste Special command to specify other options, such as pasting only the cell values (without the formatting) or only the formatting (without the cell contents).

To paste particular parts of a cell selection, click the Paste button arrow on the Ribbon's Home tab. Then, click Paste Special on its drop-down menu to open the Paste Special dialog box.

You can specify which parts of the current cell selection to use by selecting the appropriate Paste Special options:

  *Values (to convert formulas in the current cell selection to their calculated values)
  *All Using Source Theme
  *All Except Borders
  *Column Widths
  *Formulas and Number Formats
  *Values and Number Formats
  *All Merging
Raymond PengSystems EngineerCommented:
You need two instances of Excel running to have documents side by side (dual monitor usage).

start > run > excel and open a document
start > run > excel open 2nd one.
camtzAuthor Commented:
Thanks much for your suggestions.  While I was able to do everything I needed to do (including the "paste special"), I'm still not content.  What I would like to do is what I did with Windows XP (AS A DEFAULT) which is to put two or more complete workbooks on the desktop,

Right now, when I open a second workbook it superimposes on the one that it's already opened and the original goes away.  I want to be able to manipulate "each workbook" separately so that I can re-size them, move them around and put them wherever I want on the desktop.

On XP, I had to change the default on the way Excel opened but don't know about Windows 7.
With 7, if you click and drag the title bar of a window all the way over to the left, it will resize it to half the screen. Do the same with the other window but drag it over to the right, and they will be perfectly side-by-side. Kind of a nifty little feature in 7 that I'm not sure a if lot of people know of.
camtzAuthor Commented:
Well, I got half of it to work.  I opened one workbook and dragged it over to the left and it did just as you said.  I opened the second workbook and it superimposed over the first one (just like before) but when I dragged it over to the  right it did as you said, (displayed on half of the screen) but I could not see the first workbook.

However, and this is the weird thing, when I hit the red X to close the workbook guess what was under it?  The first one that I opened.
camtzAuthor Commented:
Are you able to see more than one Excel Workbook on your desktop? I tried double clicking the workbook(s) to open them and I tried your suggestion of using the run program but it doesn't matter.  Once I have one opened, the second one covers up the first and I can't separate them.  This is really important to me and I hope I can find a solution. Thanks
byundtMechanical EngineerCommented:
Are you wanting each workbook to have its own toolbar (ribbon)? If so, you will need to open each one in a separate instance of Excel as suggested by l33tf0b. To facilitate this, I like to check the box for "Ignore other applications" in the File...Options button...Advanced tab (Excel 2010) or Office icon...Options button...Advanced tab (Excel 2007) or Tools...Options menu item (Excel 2003).

If you don't mind having one toolbar/ribbon, then you should open both workbooks in the same instance of Excel. One will cover the other until you use View...Arrange All...Vertical as suggested by csoussan.
byundtMechanical EngineerCommented:
Separate instances of Excel
Single instance of Excel
camtzAuthor Commented:
I think I just hit on something.  When I go to Start/Run/Excel, it only pulls up (2003 files that have been converted but still have the .xls extension).  I have several .xlsx workbooks that I have created using Windows 10 that came with this computer but it doesn't show any of them.  

I just want to be clear.  Is it not the same if I go to My Documents folder and double click a file with an .xlsx and open it as going to the Start button?  If it makes a difference I would like to know.

Tomorrow when I get my laptop with XP I will send a screenshot of what I am talking about and that way you will be able to see it.  Thank you all very much for helping out.
byundtMechanical EngineerCommented:
Which version of Excel do you use, both at home and at work?

If you have the file converter installed, you should be able to see and open .xlsx files even with Excel 2003. http://www.microsoft.com/download/en/details.aspx?id=3 

camtzAuthor Commented:
Correction.  Last night I said I was using Windows 10.  My computer came with Windows 7 - so sorry for that.  For years I have used Windows XP and when I got my new laptop I transferred some of my Excel .xls files to the new computer.  The new computer, using Windows 7, automatically converted the old files (at least to the point where I could see them and work with them) but, they retained the .xls extension.  

New Excel files carry the xlsx extension and those are the ones I was trying to open in Windows 7 and trying to place them on my desktop.  I am sending a screenshot of what I want to do in Windows 7 but have not been able to and no one so far understands what I am talking about.  Please note that each workbook opens up as a single instance (just like you can open up many Explorer windows and have them display on the desktop at the same time).

That's what I want to do in 7.  Can it be done and if so, please show me how. Thanks
byundtMechanical EngineerCommented:
You opened each file in a separate instance of Excel as originally suggested by l33tf0b.

To facilitate this, I like to check the box for "Ignore other applications" in the File...Options button...Advanced tab (Excel 2010). If you use Excel 2007, I believe this setting is reached using Office icon...Options button...Advanced tab. On Excel 2003 and earlier, you get to it using or Tools...Options...General menu item.

Having made this setting, you then launch a new instance of Excel from the Start menu and open up the file from within Excel.
camtzAuthor Commented:
Sorry to be such a problem.  I use Windows 7 Home Premium Version 6.1.  How do I get to Office icon.../options button/advance tab?
byundtMechanical EngineerCommented:
It does not matter which version of Windows that you use. It does matter which version of Excel. If you do not know, could you please post a screenshot showing your Excel window?
camtzAuthor Commented:
I'm not able to tell.  It no longer has the "about" item on the menu so here is a screenshot.
byundtMechanical EngineerCommented:
You have Office 2007.

1) Click the "meatball" (Office icon) at the top left corner of the window
2) Click the Excel Options button at the bottom right of the resulting dialog
3) Click the Advanced tab on the pane at the left
4) Scroll down about 80% of the way on the right, then check the box for "Ignore other applications that use Dynamic Data Exchange (DDE)"
5) Close Excel
6) Relaunch Excel from the Start menu. Open the first file.
7) Relaunch Excel from the Start menu. Open the second file.
8) Size the windows to suit
byundtMechanical EngineerCommented:
If you click the ? icon at upper right of the window, the Table of Contents for Help will appear. It will tell you that you have Excel 2007.

1) Click the meatball (Office icon) at upper left
2) Click the Excel Options button at the bottom of the resulting dialog
3) Go to the Resources tab by clicking it on the pane at the left
4) Click the About button at the bottom of the pane on the right
camtzAuthor Commented:
Well, believe it or not, I'm making headway.  I did as you said and put a checkmark on DDE.

I went to start and put "run excel" and it called up eight documents (all of which had the .xls extension).  I tried to open a couple and got a dialog box that says "There was a problem sending the command to the program"

I then opened up My Documents folder and double clicked a file with an .xlsx extension and got the same message.

Lastly, I went back to the start menu and double clicked Excel from the list of programs and it opened up Workbook number 1.  I did it again, and it opened up workbook number 2.  I then re sized  each workbook and they showed up independent of each other just like I want.

So the question becomes, will this only apply to new workbooks that I create from here on?
And, once created, can't I just go to my documents folder and double click the file?
byundtMechanical EngineerCommented:
<<I went to start and put "run excel" and it called up eight documents (all of which had the .xls extension).  I tried to open a couple and got a dialog box that says "There was a problem sending the command to the program">>  I don't open files this way. When I tried, I saw were a bunch of emails plus one zip archive. Excel isn't going to do very well with those.

<<I then opened up My Documents folder and double clicked a file with an .xlsx extension and got the same message. >>  This approach should have worked perfectly.

<<Lastly, I went back to the start menu and double clicked Excel from the list of programs and it opened up Workbook number 1.  I did it again, and it opened up workbook number 2.  I then re sized  each workbook and they showed up independent of each other just like I want.>>  I launch Excel this way, and then use Excel's File...Open menu item to pick the file(s) I want to view.

The "Ignore other applications" setting ought to apply to both old and new workbooks. As you can see from the picture I posted, it certainly works on old workbooks for me.
camtzAuthor Commented:
Well I'm not a quitter so I'll just have to keep trying.  Just wanted you to know that when I tried to open any Excel (pre-existing) file I keep getting the same message and the screenshot shows what is left after I close the window.  A blank workbook which is not even useful.

I removed the check mark for DDE and it lets me open any file I want without the dialog window popping up.  I'm thinking that the only way it might work is for me to check the DDE box as you suggested and recreate all new files and maybe then I might be able to use the program the way I want.  I will experiment with this tomorrow by creating a couple of small files after I click the box and reboot the computer.
byundtMechanical EngineerCommented:
It is worth noting that checking the box to "Ignore other applications" has the side-effect of not allowing you to open a file by double-clicking it. http://support.microsoft.com/kb/211494  I wouldn't blame you if you decided this side-effect overcame the advantage in making it easy to start multiple instances of Excel.

It is also worth noting that Excel 2011 (for Macintosh) is designed for multiple monitors. Each file opens into its own window with its own copy of the ribbon/toolbar--a nice improvement, and exactly the feature you are asking for.
camtzAuthor Commented:
Well, I've tried evething I could think of and nothing worked.  The screenshot I'm sending was accomplished by going to Start/Opening a new Excel document, and even though they super imposed on top of the other, I was able to separate them and move them around on the desktop.  

I was pretty exited about that until I saved all three in My Documents folder and right clicked each one and went to open and got the same message as before; "There was a problem sending the command to the program"  

I read your Microsoft notes and they are saying that you can't double click a file to open it unless you uncheck the DDE box but they don't tell you how you can open these documents. Which leads me to this question.  What version of Excel do you use that allows you to do that?  I have Microsoft Excel - Non Commercial Use.  Could that be the problem?
byundtMechanical EngineerCommented:
Here is how I open files:
1) Launch Excel 2007 from the Start menu
2) Click the Office icon within Excel, then choose Open
3) Browse to the desired file

My reason for doing it this way is to ensure that I match the desired version of Excel with the file. I've got Excel 97, 2000, 2002, 2003, 2007, 2010, 2004, 2008 and 2011 all installed on my laptop so I can offer specific instructions to people asking questions on Experts Exchange. My laptop is a Macintosh, so I run the Windows versions on a virtual machine.

More particular to your problem at hand: if you try opening files from within Excel, you won't have any difficulty. It is only the ability to open files by double-clicking them that you lose by checking the box for "Ignore other applications".

camtzAuthor Commented:
You are correct.  If I attempt to open an Excel file from whithin Excelm it will open all of them without a problem.  This is what I will do in the future.  However, it still doesn't solve my problem of being able to separate one from the other.  They just overlap one another and are not treated as a separate instance so if I hit the center box on the right upper corner it makes them all smaller and centers them on the screen.  Even then I'm not able to separate them.

In order to accomplished this in Office 2003 I had to go to
Folder Options
File Types
XLS Worksheets
Put "%1" at the end
Remove the check mark to use DDE

The "%1", I believe is what forces Excel to open as a separate instance.
byundtMechanical EngineerCommented:
I just made the switch from Windows XP to Windows 7 myself, and don't know where to find the equivalent dialog in Windows 7.

I just repeated the experiment with checking the box for "Ignore other applications".  Each time I went to the Start menu, it launched a separate instance of Excel. This new instance of Excel was exactly the same size window as the previously opened instance, and the windows completely overlapped. However, I could drag the top one off to the right and down. I could also resize the windows by dragging on the lower right corner of the window. The cursor changed to a diagonal double headed arrow when I did that.
camtzAuthor Commented:
That's exactly what I showed you via a previous JPG.  Please look back and you will see that I successfully opened three (separate) workbooks and positioned them on the screen.  The problem was that they were "all new workbooks" - not pre-existing ones and after I saved them, I could not open them and perform the same operation because they overlapped each other and I could not separate them.
byundtMechanical EngineerCommented:

But once you have an empty workbook in the properly sized window, you can open a pre-existing workbook in the same window. It will replace the empty workbook, as you can see in the View...Switch Workbooks menu item.

I can also open a full-sized workbook in one instance of Excel, and then another full-sized workbook in another instance of Excel. When I click the middle window resize icon (to left of the red X), I can then resize the window as desired. I then repeat the process on the other window.
Ignore other applications box checked, Excel 2007
byundtMechanical EngineerCommented:
By the way, have you also checked the option to "Show all windows in the taskbar"? You will find this option by:
1) Click the Office icon
2) Click Excel Options button
3) Go to Advanced tab
4) The option is near the top, in the Display section

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Legacy OS

From novice to tech pro — start learning today.