Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Rman won't delete archivelogs

Posted on 2012-03-15
12
Medium Priority
?
3,517 Views
Last Modified: 2012-05-31
Hello,
I have an oracle 11.2.0 database which i backup nightly using rman.  This database used to have a standby database, which recently was removed from the system.  I have deferred log shipping to this destination.  

When i run an rman backup though i get the following message:

RMAN-08137: WARNING: archived log not deleted, needed for standby or upstream capture process

Open in new window


I was wondering how i can get RMAN to delete archive logs, and stop saving them for my non-existent standby database.


Thank You
0
Comment
Question by:Alex Matzinger
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
  • 2
  • +2
12 Comments
 
LVL 24

Accepted Solution

by:
johanntagle earned 375 total points
ID: 37728042
Encountered something similar before, where I just used the FORCE option to delete the archive logs.  But I would also like to know the permanent fix for this.
0
 
LVL 38

Assisted Solution

by:Geert Gruwez
Geert Gruwez earned 375 total points
ID: 37728114
in rman run
show all;
to see all the parameters
0
 
LVL 38

Expert Comment

by:Geert Gruwez
ID: 37728116
the script for deletion may also include a option
what command do you give rman to delete archivelogs ?
0
Will your db performance match your db growth?

In Percona’s white paper “Performance at Scale: Keeping Your Database on Its Toes,” we take a high-level approach to what you need to think about when planning for database scalability.

 
LVL 16

Assisted Solution

by:Richard Olutola
Richard Olutola earned 375 total points
ID: 37728328
Check your persistent RMAN configuration and look for
CONFIGURE ARCHIVELOG DELETION POLICY and ensure it is set to NONE.

So it should look like:
CONFIGURE ARCHIVELOG DELETION POLICY TO NONE;

R.
0
 
LVL 4

Author Comment

by:Alex Matzinger
ID: 37730087
i've checked the show all command, and it shows this:

CONFIGURE ARCHIVELOG DELETION POLICY TO NONE; # default

The command i use to delete the logs is this:

  backup
     as compressed backupset
     skip inaccessible
     archivelog until time 'sysdate-2'
     format '/u07/oraflash/ORATEST/ORATEST.arc_%U.rman'
    delete input;

Open in new window

0
 
LVL 16

Expert Comment

by:Richard Olutola
ID: 37730163
Have you manually deleted any archivelogs? If so, you'll need to run crossckeck archivelog all;
Subsequently, try the backup command again and see if it deletes the appropriate copies.

R.
0
 
LVL 4

Author Comment

by:Alex Matzinger
ID: 37730219
Yes, i have deleted the archive logs by hand.  I also have been running a crossckeck archivelog all; whenever i do this.  Even after crosschecking the logs, they still not being deleted by rman.
0
 
LVL 16

Expert Comment

by:Richard Olutola
ID: 37730314
Have you tried running things on the command line rather than in a run block?

Try the following:

Now that you've run the crosscheck command then try this:
delete noprompt expired archivelog all;

BTW, did you get any messages when you ran the crosscheck command?

R.
0
 
LVL 29

Assisted Solution

by:MikeOM_DBA
MikeOM_DBA earned 375 total points
ID: 37730430
Better try this:
ALLOCATE CHANNEL FOR MAINTENANCE DEVICE TYPE DISK;
CHANGE ARCHIVELOG ALL CROSSCHECK;

Open in new window

:p
0
 
LVL 4

Author Comment

by:Alex Matzinger
ID: 37739858
I've run the cross check, and got the standard, these logs failed, and then the i found these logs that it gives when you crosscheck.

I'm going to try and add in delete force input into my backup script tonight, and hope this solves the issue.  I was able to delete them using delete force from the command line.

I've also opened up an SR with oracle to try and find a true solution for getting rman to forget about a standby database.
0
 
LVL 29

Expert Comment

by:MikeOM_DBA
ID: 37742462
Notice I posted:
CHANGE ARCHIVELOG ALL CROSSCHECK;
And not:
CROSSCHECK ARCHIVELOG ALL;
Which are different.
0
 
LVL 4

Author Closing Comment

by:Alex Matzinger
ID: 38034628
This problem worked itself out (a mysterious "oh it just started working again issue").  We tried several parameter changes as suggested by oracle, but they didn't seem to work, and we were directed to change them back to default, then it started working, not sure how, thanks to everyone for your suggestions
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In this series, we will discuss common questions received as a database Solutions Engineer at Percona. In this role, we speak with a wide array of MySQL and MongoDB users responsible for both extremely large and complex environments to smaller singl…
Instead of error trapping or hard-coding for non-updateable fields when using QODBC, let VBA automatically disable them when forms open. This way, users can view but not change the data. Part 1 explained how to use schema tables to do this. Part 2 h…
This video shows how to set up a shell script to accept a positional parameter when called, pass that to a SQL script, accept the output from the statement back and then manipulate it in the Shell.
In this video, Percona Solutions Engineer Barrett Chambers discusses some of the basic syntax differences between MySQL and MongoDB. To learn more check out our webinar on MongoDB administration for MySQL DBA: https://www.percona.com/resources/we…

721 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question