Solved

Your login attempt was not successful. Please try again.

Posted on 2012-03-15
3
928 Views
Last Modified: 2012-06-27
I'm trying to put an app on the web and I'm having some trouble with the login control.  Everytime I try to log in I get this error:  Your login attempt was not successful. Please try again.

I've gone through this entire site:  http://www.codeproject.com/Articles/27682/Your-Login-Attempt-was-not-Successful-Please-Try

and i applied all the tricks and it still isnt working.  I think I may have boffed something up in the web.config.  Here is my web.config:  

<?xml version="1.0" encoding="UTF-8"?>
<!--
  For more information on how to configure your ASP.NET application, please visit
  http://go.microsoft.com/fwlink/?LinkId=169433
  -->
<configuration>
  <connectionStrings>
        <remove name="LocalMySqlServer" />
    <remove name="LocalSqlServer" />
    <add name="MembershipProvider" connectionString="Data Source=SERVER1\SQLEXPRESS;Initial Catalog=aquarium;Persist Security Info=True;User ID=user;Password=!password!" />
 
  </connectionStrings>
  <system.web>
    <compilation debug="true" strict="false" explicit="true" targetFramework="4.0">
      <assemblies>
        <add assembly="System.Data.Linq, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089" />
      </assemblies>
    </compilation>
    <customErrors mode="Off" />
    <authentication mode="Forms">
      <forms loginUrl="~/Account/Login.aspx" timeout="2880" />
    </authentication>
    <membership hashAlgorithmType="SHA1">
      
      <providers>
        <clear />
        <add name="AspNetSqlMembershipProvider" 
             type="System.Web.Security.SqlMembershipProvider" 
             connectionStringName="MembershipProvider" 
             enablePasswordRetrieval="false"
             enablePasswordReset="true" 
             requiresQuestionAndAnswer="false"
             requiresUniqueEmail="false" 
             maxInvalidPasswordAttempts="5" 
             minRequiredPasswordLength="6" 
             minRequiredNonalphanumericCharacters="0" 
             passwordAttemptWindow="10" 
             applicationName="Goldfish" />
      </providers>
    </membership>
    <profile defaultProvider="SqlProvider">
      <providers>
        <clear />
        <add name="AspNetSqlProfileProvider" type="System.Web.Profile.SqlProfileProvider" connectionStringName="MembershipProvider" applicationName="Goldfish" />
      </providers>
      <properties>
        <add name="FirstName" />
        <add name="LastName" />
        <add name="Birthday" />
      </properties>
    </profile>
    <roleManager enabled="true">
      <providers>
        <clear />
        <add connectionStringName="MembershipProvider" applicationName="Goldfish" name="AspNetSqlRoleProvider" type="System.Web.Security.SqlRoleProvider" />
       
      </providers>
    </roleManager>
  </system.web>
  <system.webServer>
    <modules runAllManagedModulesForAllRequests="true" />
    <directoryBrowse enabled="false" />
    <defaultDocument>
      <files>
        <clear />
        <add value="Default.htm" />
        <add value="Default.asp" />
        <add value="index.htm" />
        <add value="index.html" />
        <add value="iisstart.htm" />
        <add value="default.aspx" />
        <add value="index.php" />
      </files>
    </defaultDocument>
  </system.webServer>
</configuration>

Open in new window


I also added a gridview to test the permissions to the membership tables and my user can access each...

Any ideas?  This is starting to drive me mad and as always thanks for all the help experts!!
0
Comment
Question by:rpzach
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
3 Comments
 
LVL 83

Accepted Solution

by:
CodeCruiser earned 500 total points
ID: 37726132
And obviously the user you are trying to login as already exists in database?
0
 
LVL 1

Author Comment

by:rpzach
ID: 37726202
yes very much so,  not locked either
0
 
LVL 1

Author Comment

by:rpzach
ID: 37726234
okay nevermind they were locked... in the eternal words of homer j: d'oheth.
0

Featured Post

[Live Webinar] The Cloud Skills Gap

As Cloud technologies come of age, business leaders grapple with the impact it has on their team's skills and the gap associated with the use of a cloud platform.

Join experts from 451 Research and Concerto Cloud Services on July 27th where we will examine fact and fiction.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

IntroductionWhile developing web applications, a single page might contain many regions and each region might contain many number of controls with the capability to perform  postback. Many times you might need to perform some action on an ASP.NET po…
User art_snob (http://www.experts-exchange.com/M_6114203.html) encountered strange behavior of Android Web browser on his Mobile Web site. It took a while to find the true cause. It happens so, that the Android Web browser (at least up to OS ver. 2.…
Monitoring a network: why having a policy is the best policy? Michael Kulchisky, MCSE, MCSA, MCP, VTSP, VSP, CCSP outlines the enormous benefits of having a policy-based approach when monitoring medium and large networks. Software utilized in this v…
In this video you will find out how to export Office 365 mailboxes using the built in eDiscovery tool. Bear in mind that although this method might be useful in some cases, using PST files as Office 365 backup is troublesome in a long run (more on t…

627 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question