Solved

Gmail to company Exchange Server delayed

Posted on 2012-03-15
15
1,542 Views
Last Modified: 2012-09-11
Hi,

Wondering if anyone has experienced an issue with senders complaining that gmail sent to a company Exchange server is delayed for 1 - 2 days?

Running SBS 2003 with Exchange 2003.  Have an ongoing problem with gmail being delayed.  It is only gmail, every other email is accepted within seconds however any email sent from a gmail account is delayed for 1 - 2 days with the following message:

This is an automatically generated Delivery Status Notification

THIS IS A WARNING MESSAGE ONLY.

YOU DO NOT NEED TO RESEND YOUR MESSAGE.

Delivery to the following recipient has been delayed:

     user@companyemail.com

Message will be retried for 2 more day(s)

Technical details of temporary failure:
Unspecified Error (SENT_SECOND_EHLO): Unknown error 18446744073709551615

I have read a number of forums that it may be due to the self signed server certificate, however after installing a new certificate using the SBS internet connection wizard I get the same problem.

I have run a blacklist check and the domain is not blacklisted, the only Spam filter on the server is the Exchange Intelligent Message Filter and the SCL is set to 4 and all archived spam does not show any gmail messages.

The reverse DNS has been set up correctly from the ISP side.

Help with additional troublshooting tips on why only gmail messages are affected would be greatly appreciated?

Thanks,

Lance
0
Comment
Question by:krismlj
  • 10
  • 2
  • 2
  • +1
15 Comments
 
LVL 18

Accepted Solution

by:
suriyaehnop earned 250 total points
ID: 37727722
0
 

Author Comment

by:krismlj
ID: 37727930
I have read that link, it refers to the server certificate which does not appear to be the problem in this case.
0
 
LVL 7

Expert Comment

by:withtu
ID: 37728142
It's a delay but not deliver failed. The messages will be sent and received finally, so I don't believe that's a certificate issue.
You can test this scenario by other email providers however, like yahoo or hotmail, if that's issue still reoccur on those providers and not only GMAIL, check your internet connection provider for more info. I met a similar case before and that client told me the employees cannot get the emails from a biz partner, and the root cause was the internet provider.
0
Are your AD admin tools letting you down?

Managing Active Directory can get complicated.  Often, the native tools for managing AD are just not up to the task.  The largest Active Directory installations in the world have relied on one tool to manage their day-to-day administration tasks: Hyena. Start your trial today.

 
LVL 7

Expert Comment

by:Abbas Haidar
ID: 37728313
is this happening with Gmail only and only Gmail?
0
 

Author Comment

by:krismlj
ID: 37728819
yes only gmail.  yahoo mail works, hotmail works, numerous other domains work, the only one that gets delayed is gmail.  have tested with loads of other free email services and commercial domains and they all turn up instantly.  gmail eventually turns up it just gets delayed by about 24 - 36 hours.
0
 

Author Comment

by:krismlj
ID: 37728824
have also had the isp check things out.  the domain was originally blacklisted on sorbs database because it was flagged as being in a dynamic address range, this was due to the reverse dns not pointing to the domain name of the server but rather to the isp.  requested the isp to add reverse dns and now everything is ok.  no longer blacklisted, but gmail is still delayed.
0
 

Author Comment

by:krismlj
ID: 37728837
I manage a number of other sbs 2003 machines and all are configured with self signed server certificates and none experience any issues with gmail delays. the only obvious difference between the sbs 2003 machines is the isp but after numerous talks with them they feel they have done everything and it is a server config issue!  The ISP did set up and manages the adsl modem/router so not sure what they may have done differently there.  the firewall just has port 25 smtp traffic forwarded straight to the SBS 2003 box, it does not distinguish between email domains.  but if it was a device config or server config problem i would expect it to affect all email not just email from one domain?!
0
 
LVL 7

Expert Comment

by:withtu
ID: 37729240
Don't worry about your SBS server and there is nothing to do with the configurations. I think there is something wrong on Google side, the email flow may not be handled in time so you get the incoming message late.
0
 

Author Comment

by:krismlj
ID: 37731465
that is my thinking too.  it wouldn't be such a big deal except there are many business partners who use gmail and they place orders via gmail and a delay of 1 - 2 days would mean we would miss their order, so i really need to find a way to fix this.  perhaps looking through the google forums might turn something up other than the link suriyaehnop provided. or maybe someone on EE has experienced this before and knows what is causing it and how to fix it?  Thanks to everyone so far for your contributions.
0
 
LVL 18

Expert Comment

by:suriyaehnop
ID: 37736011
0
 

Author Comment

by:krismlj
ID: 37755332
thanks suriyaehnop, i am working through the process with google and see what they can do.
0
 

Assisted Solution

by:krismlj
krismlj earned 0 total points
ID: 38374968
Just thought I'd update this as it has been a while and I have found a solution to the problem.  This is unique to SBS 2003 or Exchange 2003.  When you create a new certificate using the SBS wizard it does not automatically update the Exchange Virtual SMTP server certificate and it needs to be manually added.  Not doing this can cause the TLS issues I was experiencing with GMail.  This is not the case in SBS 2008 or SBS 2011 as it automatically updates Exchange certificates as well.

more information about the issue can be found here:

http://productforums.google.com/forum/#!topic/gmail/eD2Vm5LacQQ

Hope this helps someone.
0
 

Author Comment

by:krismlj
ID: 38374996
I've requested that this question be closed as follows:

Accepted answer: 0 points for krismlj's comment #a38374968

for the following reason:

after extensive toubleshooting and research was able to find a solution to my own problem.  No one on EE was able to provide a solution to this issue.
0
 

Author Comment

by:krismlj
ID: 38374997
noticed that there was a link to a similar article posted by another user.  need to allocate points to him too.
0
 

Author Closing Comment

by:krismlj
ID: 38386103
needed more information about the certificate.  the article I was directed to did not mention updating the Exchange Virtual SMTP server certificate just the Server certificate.  took a while to find this out.
0

Featured Post

NAS Cloud Backup Strategies

This article explains backup scenarios when using network storage. We review the so-called “3-2-1 strategy” and summarize the methods you can use to send NAS data to the cloud

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Follow this checklist to learn more about the 15 things you should never include in an email signature from personal quotes, animated gifs and out-of-date marketing content.
How to resolve IMCEAEX NDRs in Exchange or Exchange Online related to invalid X500 addresses.
In this video we show how to create an email address policy in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Mail Flow…
To add imagery to an HTML email signature, you have two options available to you. You can either add a logo/image by embedding it directly into the signature or hosting it externally and linking to it. The vast majority of email clients display l…

830 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question