Solved

Remote Desktop Slow when connecting via win 7 but fine with wyse device

Posted on 2012-03-15
6
1,426 Views
Last Modified: 2016-11-23
I am connecting to a Windows Server 2008 R2 Remote Desktop Session Host (Terminal) Server through a very fast WAN connection (4 mb up with 15ms latency) using RDP 7.1. (NOT virtualized)  I am using a proprietary database application used for Dental Practice Management.  I connect using new Dell Windows 7 64-Bit Professional machines in a domain between remote offices. I connect and log in quickly and proceed to open the software.  During the application startup process it takes about 45-60 seconds for the application to get a login prompt.  If I open the app locally or through a Wyse device I do not see the delay in login taking 5-10 seconds.  After the app is loaded I get very poor performance and the app seems to "lock up" with slow page scrolling, moving between screens and viewing\scheduling using the calendar.  I have tried with or without remoteFX.  Changing the connection settings, ie.  16-bit video, no local resources and setting the experiance to 56k.  With remoteFX  I get much better performance taking advantage of the WAN 10mb experience and remoteFX.  If i use RDP through the LAN I do not experience the issue.  The connectivity over WAN is very good.  Fair refresh time, no problems loading graphics or even scrolling through .jpg  icons.   I have used Ericom Blaze and found it to help significantly but the underlying problem is still there.  If I connect using a Wyse device over WAN I DO NOT experiance the slow application loading or the general slow RDP symptoms.  I am hoping someone may have a recommendation that takes into account the fact that the internet line and latency do not seem to be the problem.  Also I do not believ this is a remotefx issue.  I think it is unique to RDP from Windows 7 SP1 to Server 2008 R2 SP1.  Finally I have duplicated the problem at both locations.  What I mean is that I have the same problem connecting from server A to location B and server B to location A.  Different but identical Dell T710 servers with Dual Zeon X5670 processor’s, 4-15k Drives with 2 Raid 1 virtual drives and 24 GB Ram.  Same OS, updates, Anti-Virus and domain setup as well as software and user setup and security.The Remote Desktop Servers connect to a 2nd separate domain controller and have no other services (DNS,DHCP, AD) loaded other then Remote Desktop Session Host.
0
Comment
Question by:simplypc08
  • 3
  • 3
6 Comments
 
LVL 23

Accepted Solution

by:
Dirk Kotte earned 500 total points
ID: 37735288
I have seen this with to big MTU-size.
The default size are to big with WAN or VPN sometimes.
After shrinking the MTU-size the RDP-connections are fast over WAN also.

i use "SetMTU.exe" from Cisco-vpn-client to make the changes.
0
 

Author Comment

by:simplypc08
ID: 37736098
I have read about before.  I think I remember it saying to change it from 1500 to 1492 or do you have another recommendation.
0
 
LVL 23

Expert Comment

by:Dirk Kotte
ID: 37737945
with MTU of 1300 or less you have a little bit more overhead - but 1492 are to big for some connections also.
With MTU 800 it also works ...
0
Does Powershell have you tied up in knots?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 

Author Comment

by:simplypc08
ID: 37745663
I am changed the setting to 1440 and saw some good results but still am hoping for more.  I have changed the mtu settings on the routers after running an mtu test.  Do I have to change the mtu settings on all of the network adaptors in the remote desktop servers that provide rdp access?  What are the drawbacks to having the mtu size set lower.
0
 
LVL 23

Expert Comment

by:Dirk Kotte
ID: 37748583
the session MTU are searched with MTU-discovery.
if your session works, the setting at one point are enough.
If MTU-Discovery give no results, you have to do the settings at the interfaces the packet leaving the server ... and sometimes at the client also.
 

with decrasing the MTU you only decrase the payload, the overhead keeps the same.
so with verry tittle packets you have more overhead than with bigger packets.
... but with WAN and VoIP litte packets are recomended - because QOS works better.

with MTU 1400 ~5% of the packet are overhead , with MTU of 800 ~10%
but thats not realy a problem.
0
 

Author Closing Comment

by:simplypc08
ID: 37761534
I changed the mtu at the routers between the two offices in question.  I did not need to change the  nics.   Thanks
0

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

The recent Microsoft changes on update philosophy for Windows pre-10 and their impact on existing WSUS implementations.
A procedure for exporting installed hotfix details of remote computers using powershell
This tutorial will give a short introduction and overview of Backup Exec 2012 and how to navigate and perform basic functions. Click on the Backup Exec button in the upper left corner. From here, are global settings for the application such as conne…
This tutorial will walk an individual through locating and launching the BEUtility application to properly change the service account username and\or password in situation where it may be necessary or where the password has been inadvertently change…

809 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question