Solved

Disable automatic reboot of win7 pc's and 2008 server, 2003

Posted on 2012-03-16
4
678 Views
Last Modified: 2012-05-18
Hi all,

This is getting on my nerves , I have a couple of servers sbs 2003, sbs 2008, sbs 2011
I find that they regularly try to install updates by themself this is not a big deal.
But afterwards it reboots as well clients pc's (while they are working)
And also the server. Some servers don't boot up automatic and need user interaction.
So, I'm looking for a way to disable client pc (xp, win7) to not automatic restart after updates.
And also for the server

On client pc's (win7) I have configured Computer policy gpedit.msc and one of the settings is to not reboot after updates. But yesterday I had a pc who rebooted anyway (during work)
SO, what is the trick to prevent computers and servers from not automatically reboot after updates?

Thanks for advice
0
Comment
Question by:osa2
4 Comments
 
LVL 6

Accepted Solution

by:
xeroxzerox earned 400 total points
Comment Utility
Please recheck this step

   Go to gpedit.msc
   Expand Local Computer Policy / Computer Configuration / Administrative Templates / Windows Components / Windows Update
  Double-click "No auto-restart for scheduled Automatic Updates installations"
  Select "Enabled", then OK. Close the Group Policy configuration program.
You need Administrator priveleges to make this setting.
 Some people complained that Windows ignored the "no auto-restart" setting for the WMF patch. Potentially a ID 10T error, though.


Group Policy settings to disable Automatic Updates from rebooting computer
0
 
LVL 1

Author Comment

by:osa2
Comment Utility
The strange thing is I set this option to enabled and now it is disabled again when I check it.
Does 2008 server overwrite the group policy settings from the server side to clients?
0
 
LVL 38

Assisted Solution

by:Adam Brown
Adam Brown earned 100 total points
Comment Utility
You'll need to set this in a Group Policy Object rather than GPedit.msc. GPEdit modifies local policy, which is over-written by any GPOs that set the same settings. You probably already have a GPO set to define the Update action. You'll need to figure out which GPO it is and then set that GPO with the settings mentioned. You can do this with RSOP.msc or through the Group Policy Management Console.
0
 

Expert Comment

by:smihi19
Comment Utility
I also had problems with the automatic reboots after updates, that's why I started to use WuInstall - maybe it will help you, too. It is a commad-line tool which allows you to decide when to do which updates. By default there won't be any reboots but if you wish one you can force it with a command like /reboot.
0

Featured Post

Want to promote your upcoming event?

Attending an event? Speaking at a conference? Or exhibiting at a tradeshow? Easily inform your contacts by using a promotional banner in your email signature. This will ensure your organization’s most important contacts are in the know.

Join & Write a Comment

A quick step-by-step overview of installing and configuring Carbonite Server Backup.
Learn about cloud computing and its benefits for small business owners.
This tutorial will walk an individual through the steps necessary to join and promote the first Windows Server 2012 domain controller into an Active Directory environment running on Windows Server 2008. Determine the location of the FSMO roles by lo…
This tutorial will walk an individual through setting the global and backup job media overwrite and protection periods in Backup Exec 2012. Log onto the Backup Exec Central Administration Server. Examine the services. If all or most of them are stop…

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

6 Experts available now in Live!

Get 1:1 Help Now