NFS on Solaris, how to enable write from nfs client end ?

I have configured a NFS server and a client nod following this link http://technodope.com/index.php?option=com_content&view=article&id=51:how-to-configure-nfs-data-source-on-solaris-10&catid=50:unix&Itemid=78

Both are Solaris 10 x86 servers.

I have created a test file in the NFS server's shared folder. And I can access it from the NFS client nod's mounted folder. So NFS is working fine it's seems.

And also I need to edit that file from the NFS client nod. I have given 777 permission to the same file on the NFS server's end. But it wont allow me to edit it.

Please help me to resolve this !
Shakthi777Asked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
legolasthehansyConnect With a Mentor Commented:
Try this on the Solaris server,

share -F nfs -o rw,root=nfs_client_ip /nfs_share_dir

This enables the root user on the NFS client to modify files
0
 
legolasthehansyConnect With a Mentor Commented:
Are you trying to access the share on the client using root or as a user? If you are accessing as root you would need to make sure no_root_squash option is defined
0
 
Shakthi777Author Commented:
The both of the boxes are configured with the same root password, I didn't use any other authentication. Please advise ?
0
 
Duncan RoeConnect With a Mentor Software DeveloperCommented:
You have to read the man page for /etc/fstab or whatever the file is under Solaris that you edited to create the NFS mount. Also the NFS-specific section of the man page for the mount command (i.e. man mount). Then you would understand about no_root_squash. No I'm not going to post a brief summary here.
0
 
Shakthi777Author Commented:
tnx !
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.