ubuntu script

Can I ask, (ubuntu/linux beginner), this site:

Asks me to download a script:

My question is, from firefox, a) how do I save it, as what (file extension etc), and then from the command terminal, how do I run it? Do I need to navigate to the folder its saved in as you would on a windows command prompt, i.e. CD command? Whats the ubuntu equivalent?
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

try doing it via a webget from cmd

sudo -s

type admin password to get to root it saves it in you download folder

webget https://svn.wald.intevation.org/svn/openvas/trunk/tools/openvas-check-setup

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ibrahim52Team LeaderCommented:
pma111Author Commented:
I entered sudo -s from cmd terminal
entered the password
then entered:
webget https://svn.wald.intevation.org/svn/openvas/trunk/tools/openvas-check-setup

And it doesnt like it.

root@ubuntu:~# webget webget https://svn.wald.intevation.org/svn/openvas/trunk/tools/openvas-check-setup
No command 'webget' found, did you mean:
 Command 'debget' from package 'debian-goodies' (main)
 Command 'debget' from package 'debget' (universe)
 Command 'webgen' from package 'webgen0.4' (universe)
 Command 'webgen' from package 'webgen' (universe)
 Command 'webgen' from package 'webgen0.5' (universe)
webget: command not found
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

pma111Author Commented:
Ibrahim Ive followed their guide and it didnt work, so this script is apparently a diagnositc that may give suggestions on why
pma111Author Commented:
maybe it wget
Dear Pma111,

It's wget you are right.

With wget you download the file "openvas-check-setup" that is a shell script file (.sh) you don't need to have extension like Windows to run it. This file will be saved from where you run the command, then for example if you are currently in your /home/pma111 folder it will be saved there.

After you only need to set the execution right to the file by doing :
chmod +x openvas-check-setup

And for run it after :
pma111Author Commented:
Thanks so much madshiva I will login to the ubuntu and try this and feedback
Kerem ERSOYPresidentCommented:

The problem with the site is it presents an invalid certificate ( certificate with wrong  common name) . So that when I tried with wget I've got this error:

wget https://svn.wald.intevation.org/svn/openvas/trunk/tools/openvas-check-setup
--2012-03-17 14:24:25--  https://svn.wald.intevation.org/svn/openvas/trunk/tools/openvas-check-setup
Resolving svn.wald.intevation.org...
Connecting to svn.wald.intevation.org||:443... connected.
ERROR: cannot verify svn.wald.intevation.org's certificate, issued by `/C=DE/O=Intevation GmbH/CN=Server CA 2010':
  Unable to locally verify the issuer's authority.
ERROR: certificate common name `wald.intevation.org' doesn't match requested host name `svn.wald.intevation.org'.
To connect to svn.wald.intevation.org insecurely, use `--no-check-certificate'.
Unable to establish SSL connection.

Open in new window

So you'd better try it with this instead:

# wget --no-check-certificate https://svn.wald.intevation.org/svn/openvas/trunk/tools/openvas-check-setup

Open in new window

Kerem ERSOYPresidentCommented:
The Certificate eror is why can not you get the file. The client aborts with invalid certificate error before it downloads. For the rest you can follow MadShiva's comment. Since this is not a windows system you don2t need definite file extensions. The file you get is a script file so when you assign execution permission it should go and do what is intended for.

Kerem ERSOYPresidentCommented:
But don't forget that this script must be run after you've setup openVAS over your system. So please install the binary for your system here:


Select the binary for Ubuntu and install it.

It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Distributions

From novice to tech pro — start learning today.