• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 745
  • Last Modified:

Activesync issues after ESXi P2V conversion

Hi all,

I have a 2003SBS which was recently moved from a physical machine into a virtual machine hosted on ESXi 5.0.  All is working fine except activesync, which is behaving strangely, and causing all the iphones that are syncing with the server to keep re-downloading all the emails and contacts in everyones' mailboxes.

There isn't much in the event logs other than some 3005 errors in the application log (but not often):

Unexpected Exchange mailbox Server error: Server: [servername] User: [user] HTTP status code: [500]. Verify that the Exchange mailbox Server is working correctly.

The HTTP code is sometimes 500, sometimes 503 - but OWA and everything else Exchange-related is working okay.

I have had a look around online and everything I have seen has pointed to network card binding order after a P2V conversion, but as far as I can see, this is set as it should be.

Could anyone help please as it is causing me a massive headache!

Thanks in advance.
0
chris3879
Asked:
chris3879
  • 2
1 Solution
 
EvertGCommented:
Did you removed the old nic configuration ?
this can cause some weird problems with this.

1.Click Start > Run.
2.Type cmd.exe, and click Enter.
3.At the command prompt, run this command:

set devmgr_show_nonpresent_devices=1

Note: If this command does not work (a possibility in Windows Server 2000 and 2003), you may need to add the parameter to Windows and set its value:

a.Right-click the My Computer desktop icon and choose Properties.
b.Click the Advanced tab and select Environment Variables.
c.In the System variables section, click New.
d.Set the Variable name to devmgr_show_nonpresent_devices and set the Variable value to
1 to enable the parameter.
Click OK to add the variable to Windows.
4.In the same command prompt window as in step 2, enter start devmgmt.msc and press Enter to start Device Manager.
5.Select View > Show Hidden Devices.
6.Expand the Network Adapters tree (select the plus sign next to the Network adapters entry).
7.Right-click the dimmed network adapter, and then click Uninstall.
8.Once all of the grayed out NICs are uninstalled, assign the IP address to the virtual NIC.
9.Close Device Manager.  

Original link

Good luck.
0
 
EvertGCommented:
Second possible solution

1. Go to properties of Default Web Site
2. Under Web Site, click on Advanced of the IP Address
3. Highlight the IP address and select Edit
4. Remove anything you can see in there
0
 
chris3879Author Commented:
Thanks for the quick reply.  I hadn't removed the hidden network card but have done now and done an iisreset.

I've spoken to the person who had the biggest issue with their phone and it's now resyncing - seems a lot faster than it was previously too so hopefully that has sorted it, but I will let you know conclusively once I have had the all clear from everyone.

Thanks again ever so much - if this works I will be a very happy man indeed!

Cheers

Chris
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now