Windows Vista detects DVDRW Drive as CD Drive and wont autorun DVD Playback.

Hi Everyone

This particular fault is quite strange.  Although the drive is being detected and reads the contents of a DVD it will not autorun or allow you to right click and select Play in My Computer (Vista Basic x86).

The drive in My Computer is listed as a CD-Drive instead of a DVD-RW.  The built in Toshiba DVD player will play the disc if you open it first then click play, but not from My Computer.

The laptop has been running Norton 360 which is what I supect has caused the issue.  It also looks as if someone has removed the Upper & Lower filters from the registry to clear the known drive detection problem.

I have tried the following: upper/lower filters check, remove from device manager and re-installing the drivers, removing Norton 360, Intel drivers, turn off UAC and the Microsoft Fix it tool.  All to no avail.

Any help would be greatfully appreciated
kp7Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

CallandorCommented:
Check your registry to see if autoplay is enabled:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\CDRom
'AutoRun' should be 0x00000001 (1)

If the machine is part of a network, see http://answers.microsoft.com/en-us/windows/forum/windows_vista-hardware/autoplay-option-doesnt-work-on-windows-vista/c0489f77-0fa6-4a12-b469-49d39dfdd301

"Ask your network administrator if AutoPlay is restricted by Group Policy, and if so, what to do instead.

Close other programs that might be interfering.

Follow these steps:

Click the Start button , click All Programs, click Accessories, and then right-click Command Prompt.
Click Run as administrator.

At the command prompt, type net start shellhwdetection, and then press ENTER.

Restart your computer."
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
kp7Author Commented:
Thankyou Callandor.

Method 1 on the Microsoft answers page done the trick.

The Shell Hardware Detection service was disabled and once it was set to Automatic and the system restarted the optical drive changed from being displayed as a CD-Drive to a DVD-RW drive with all the autorun features not working.

Thanks again Callandor, I was pulling my hair out with this one.

Kind Regards
0
kp7Author Commented:
typo: should have said - with all the autorun features "now" working.

Thankyou again.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Vista

From novice to tech pro — start learning today.