DMP file import issue

I am using oracle 10g. I am trying to import a DMP file and at the load message it shows scott.SYS_IMPORT_SCHEMA_01 is loaded. But I am not able to find that table in SQLDeveloper or query in it SQLPlus. When I query a select statement from that table it says "Table or view doesn not exist". Please help with any ideas or thoughts.
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Scott in most cases is a test Oracle schema.

So the correct way to access the tables of 'scott' will be:

SQL>connect scott/tiger@alias
SQL> SELECT * FROM user_tables;

Now you will see all tables of the scott schema.

If I mistaken your question, then see the Import log. It will display you which tables are imported and if there are errors.
thomaszhwangAuthor Commented:
That is how I was initially connected. And I can see only sample tables.
Please help.

SQL> select table_name from user_tables;

slightwv (䄆 Netminder) Commented:
>>scott.SYS_IMPORT_SCHEMA_01 is loaded.

Did it not say: Job scott.SYS_IMPORT_SCHEMA_01 completed?

I believe that SYS_IMPORT_SCHEMA_01 is the datapump job name.
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

thomaszhwangAuthor Commented:
Yes. This is the line,

Job "SCOTT"."SYS_IMPORT_SCHEMA_01" completed with 1359 error(s) at 11:04:02.

Even with errors previously I saw the table SYS_IMPORT_SCHEMA_01 creating under my connection. Every time I run it I see the table, I drop the table and run it again. Now after a while it had stopped creating in the fist place. This happens with the SYS user as well. Please help.
slightwv (䄆 Netminder) Commented:
The word "Job" is the important word here.

SYS_IMPORT_SCHEMA_01 is not a table.  It is a database job created by datapump.  It is cleaned up when finished.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
thomaszhwangAuthor Commented:
But what about the previous times when I actually saw those tables?

Say if it is cleanup but technically where should I find the table after import succeeds?

DavidSenior Oracle Database AdministratorCommented:
Just for fun, let's alter the first advice 37729895, and ensure the import worked for schemas other than SCOTT.  Try:

SELECT owner, table_name FROM sys.all_tables
slightwv (䄆 Netminder) Commented:
>>technically where should I find the table after import succeeds?

I'm not up on all aspects of datapump but it might create some working tables while it is running.  I do know it creates a database job.

The SCOTT schema out of the box does not come with a table called SYS_IMPORT_SCHEMA_01.  If you didn't create it, I would not expect it to be there after the import completes.

Check the docs:

Nowhere in the list does it say it is importing a talbe called SYS_IMPORT_SCHEMA_01.
slightwv (䄆 Netminder) Commented:
I did find a reference to in on Oracle's Support site:
Datapump Import Results in ORA-39001: invalid argument value ORA-01775: looping chain of synonyms [ID 459151.1]

There is a temporary 'master' table created during impdp.  It is cleaned up automatically when the job completes.
thomaszhwangAuthor Commented:
Yes maybe it was a temporary table which cleared out after the job. I tried the import one more time but now I didn't see any temporary table creating on that name.

Anyways if the import succeeds I should find the table under by connection with
scott/tiger-->tables right?
DavidSenior Oracle Database AdministratorCommented:
Just the four sample tables OWNED by SCOTT, not any others.  See my above query.
slightwv (䄆 Netminder) Commented:
>>scott/tiger-->tables right?

For SCOTT's objects yes.  An import might have objects from other schemas.  It all depends on how it was exported.
thomaszhwangAuthor Commented:
Hmm thanks. I will get back if I have more questions.
you have to post how you invoke the import.
The user you use for connection, what kind of import is it (schema, table)
Without these details is  a hard task to guess what has happened.
slightwv (䄆 Netminder) Commented:
>>Without these details is  a hard task to guess what has happened.

I believe everything has been resolved.

In the original question : "at the load message it shows scott.SYS_IMPORT_SCHEMA_01"

That is the job completed message.  This was suggested in htttp:#a37729993 and confirmed in http:#a37730019

Then there was a secondary question about an actual table seen while impdp was running but not after.  This was resolved in http:#a37730104
thomaszhwangAuthor Commented:
Okay here is another issue I am facing. I am trying to import a DMP file into a NEW database which as no grants,users etc that are present in the export file. All I need is data and I don't care about users,grants,sequences etc.

Below is a simple import statement which I used,

IMPDP scott/********@alias directory=TEST_DIR dumpfile=godirectBackup.dmp content=all schemas=GODIRECT logfile=imp3.log ( refer to imp-5193errors log)

But after looking at the errors, I tried to exclude certain things from the import and then the errors reduced.

IMPDP scott/********@alias dumpfile=godirectBackup.dmp table_exists_action=replace schemas=godirect directory=TEST_DIR exclude=grant,user,sequence,view,role_grant,default_role,tablespace_quota logfile=mylog.log ( refer imp-1358errors log)

Even when I don’t add “exclude=tablespace” in the import statement it has the same errors as 1358 file. Now I think all the errors are pointing to godirect tablespace and the other errors are dependent on it.

Should I create a tablespace manually? Or please help me proceed. Thanks.
slightwv (䄆 Netminder) Commented:
>>Okay here is another issue I am facing.

This is a new question and should be asked as one.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Oracle Database

From novice to tech pro — start learning today.