AxSpreadSheet control ClassFactory Error

Hello EE,

I have a form in vb.net with a OWC11 control

I have the references :

AxInterop.OWC11
Microsoft.Office.Interop.Owc11

It works very well on my machine.
works also at some clients.

there is one developer here that cannot open the form and he's having the error:

ClassFactory cannot supply requested class (Exception from HRESULT: 0x80040111 (CLASS_E_CLASSNOTAVAILABLE))

when loading the solution on his visual studio, trying to open the Design Form, Im having same error.

Both machine working and not working have same frameworks...has Office web 2003 components..


I dont know where to search anymore

can you help ?
LVL 1
PhilippeRenaudAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

CodeCruiserCommented:
Try reregistering the component using regsvr32.
0
PhilippeRenaudAuthor Commented:
Do you mean the Dll's ?
0
PhilippeRenaudAuthor Commented:
it is saying:  C:\Elk\9_....\bin\AxInterop.OWC11.dll was loaded, but the DllRegisterServer entry point was not found.

this file can not be registered.


when I try to do instead:

regsvr32 "DLL C:\Elk\9_...\bin\AxInterop.OWC11.dll"
im having:

LoadLibrary("C:\Elk\9_....\bin\AxInterop.OWC11.dll") failed - The specified module could not be found
0
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

PhilippeRenaudAuthor Commented:
CodeCruiser, can you help me some more ?
0
CodeCruiserCommented:
Sorry mate I am out of ideas. I had this question open in my window since your last comment and I actually did some more research TODAY thinking I will post more info but could not find anything.
0
PhilippeRenaudAuthor Commented:
Can you maybe tell me why i cannot register and or unregister the dll?
0
CodeCruiserCommented:
That's probably because its not a COM component. The AX*** is a .NET assembly. Did you try regsvr32 on the OWC assembly itself?
0
PhilippeRenaudAuthor Commented:
what do I need to type to get OWC assembly itself?  not sure to understand
0
CodeCruiserCommented:
This would be in program files somewhere such as


C:\Program Files\Common Files\Microsoft Shared\Web Components\11\OWC11.DLL
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
PhilippeRenaudAuthor Commented:
It was a little related to that. I found the solution. I went to microsoft update then tried again. not working.  I have deleted from add/remove programs the Office 2003 components. then re-install it. It was still not working I went back to microsoft update and now i was seeing updates for Office compenents. I installed them then tried again and now I could successfully open my form.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Visual Basic.NET

From novice to tech pro — start learning today.