Unable to RDP to Windows Server 2008 R2 Service Pack 1

All of a sudden I have had I am having an issue on two differnt servers.  Both running Windows 2008 R2 Service Pack 1.  

The server is setup as a Terminal Server with Licensing installed and the RDP CALS applied.  It has been running for months without an issue.

Any ideas?  Anyone know of recent updates that may have created this issue?
razorsharpskillAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

thomasdavisCommented:
If updates have been applied re-Check firewall settings, AV protection settings, make sure RDP is enabled still. You can test by disabling AV and firewall to see if you can connect again.
0
razorsharpskillAuthor Commented:
Already checked the firewall settings and AV.  I am able to ping it from another workstation.  I am just getting the error unable to reach the server when attempting the RDP connection.
0
thomasdavisCommented:
When trying to RDP are you using the IP or name? Have you tried both?
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

thomasdavisCommented:
check to see if listening on 3389 netstat -a
0
razorsharpskillAuthor Commented:
Tried both.  Not a DNS issue.  This server is also a SQL Server.  I can create an ODBC connection and connect to the database remotely.  I can UNC to the server and open the AdminShare C$.

I have tried uninstalling any updates that were applied to the server without success.  Then also tried reinstalling the updates without success.
0
razorsharpskillAuthor Commented:
It is listening on 3389.
0
thomasdavisCommented:
Just to check the option to allow connection from any computers running rdp is checked.
0
razorsharpskillAuthor Commented:
The option to allow connections from any computer is checked in the computer properties.
0
razorsharpskillAuthor Commented:
Found that there was malware on the server using Port 3389.  Changed the Port to something obsure like 3395 and was able to login via RDP.  This lead to the checking for Malware and checking what was locking up Port 3389.

Thank you for all your help.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
razorsharpskillAuthor Commented:
Found the problem was malware.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.