Solved

nagios error: any help will be appreciated.

Posted on 2012-03-16
5
387 Views
Last Modified: 2012-08-14
Hi

i am new to nagios; i had earlier installed nagios on unbuntu 10.4.3 and monitoring a windows server. but i accidentally deleted the commands.cfg file and i installed nagios again; but this time around it gives me an error.

[03-16-2012 13:17:24] Warning: Attempting to execute the command "/usr/bin/printf "%b" "***** Nagios *****\n\nNotification Type: PROBLEM\n\nService: W3SVC\nHost: My Windows Server\nAddress: 192.168.60.16\nState: UNKNOWN\n\nDate/Time: Fri Mar 16 13:17:24 CDT 2012\n\nAdditional Info:\n\nUsage:check_nt -H host -v variable [-p port] [-w warning] [-c critical][-l params] [-d SHOWALL] [-t timeout]\n" | /bin/mail -s "** PROBLEM Service Alert: My Windows Server/W3SVC is UNKNOWN **" nagios@localhost" resulted in a return code of 127. Make sure the script or binary you are trying to execute actually exists...
[03-16-2012 13:17:24] SERVICE NOTIFICATION: nagiosadmin;winserver;W3SVC;UNKNOWN;notify-service-by-email;Usage:check_nt -H host -v variable [-p port] [-w warning] [-c critical][-l params] [-d SHOWALL] [-t timeout]
0
Comment
Question by:sudhir87
  • 3
5 Comments
 
LVL 11

Expert Comment

by:legolasthehansy
ID: 37730594
Looks like the uninstallation was not clean. I guess it is unwise to fix this as this would take a lot of your time.
DO an uninstall again - make sure you remove /usr/local/nagios folder completely
Install again.
0
 

Author Comment

by:sudhir87
ID: 37730824
i uninstalled i emptied the /usr/local/nagios folder and installed again it is giving me the same error. am i missing something. if i have to delete the nagios running completely how do i do it.
0
 
LVL 19

Expert Comment

by:Gabriel Orozco
ID: 37740672
Did you check you have the binary
/bin/mail

installed? if not, locate it on your distro and install it.
0
 

Accepted Solution

by:
sudhir87 earned 0 total points
ID: 37748473
i removed all the installation files and then installed it; and on the windows client side i checked all the plugins then it started again...im really sad that i couldnt find out what exactly caused the break down but im glad it worked out.thanks for your help guys.
0
 

Author Closing Comment

by:sudhir87
ID: 37764956
the solution was good but did not give much information as to where the initial error happened...
0

Featured Post

Master Your Team's Linux and Cloud Stack

Come see why top tech companies like Mailchimp and Media Temple use Linux Academy to build their employee training programs.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Linux users are sometimes dumbfounded by the severe lack of documentation on a topic. Sometimes, the documentation is copious, but other times, you end up with some obscure "it varies depending on your distribution" over and over when searching for …
Join Greg Farro and Ethan Banks from Packet Pushers (http://packetpushers.net/podcast/podcasts/pq-show-93-smart-network-monitoring-paessler-sponsored/) and Greg Ross from Paessler (https://www.paessler.com/prtg) for a discussion about smart network …
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…

809 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question