port 3389 blocked/not listening after multiple reboots

Hi. I cannot RDP to the server after having trouble booting the server.  This is Win 2003 Server.  Port 3389 is not listening.  All TS services are enabled. Remote Desktop is enabled in Control Panel, System.  When I do netstat -an |find "3389" I get the response UDP 0.0.0.0:3389   *:* instead of the expected response.  Can you help?
KaceSolverAsked:
Who is Participating?
 
KaceSolverAuthor Commented:
This was tracked down to RDP crashing the print spooler caused when a Mac computer connected.  It was the Officejet driver that the Mac was using that had been installed on the server.  We discovered that with the print spooler disabled we could connect.  After removing all the printer drivers from the server everyone could connect again, including the Mac.
0
 
Khandakar Ashfaqur RahmanExpert/ConsultantCommented:
Check your Firewall and also check if 3389 port is in exception.Also be sure that Anti-Virus isn't blocking RDP
0
 
KaceSolverAuthor Commented:
I have done all of these.
0
Cloud Class® Course: Microsoft Windows 7 Basic

This introductory course to Windows 7 environment will teach you about working with the Windows operating system. You will learn about basic functions including start menu; the desktop; managing files, folders, and libraries.

 
Khandakar Ashfaqur RahmanExpert/ConsultantCommented:
Into your server:
telnet 127.0.0.1 3389

Then into client pc:
telnet "Server IP" 3389

What do you see ?
0
 
KaceSolverAuthor Commented:
I don't get the flashing cursor - cannot telnet the port.  It isn't listening.
0
 
Khandakar Ashfaqur RahmanExpert/ConsultantCommented:
If you can't telnet into your server(telnet 127.0.0.1) it means service isn't running properly.You need to check services and dependencies.Start and restart service again if requires.
0
 
KaceSolverAuthor Commented:
Yes I have already tried stopping and restarting services.  I have also tried deleting the RDP-TCP connection in TS and reinstated it.  I have also booted with Remote Desktop enabled and then tried re-enabling it but the port is not listening.
0
 
Khandakar Ashfaqur RahmanExpert/ConsultantCommented:
Remove Remote Desktop then install again.
0
 
KaceSolverAuthor Commented:
I have done that too I'm afraid. I also reinstalled SP2 but when I rebooted it did not like the new configuration and used a previous config.  Not sure if that helps work it out?
0
 
Khandakar Ashfaqur RahmanExpert/ConsultantCommented:
Run Microsoft Baseline Security Analuzer:
http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=19892

Check if there's any update missing or post the result.
Are you using group policy ?
Also check the Event log if there's any error
0
 
KaceSolverAuthor Commented:
Hi.  I'll try this shortly when I can get access to the sever and will post the result. I can' see anything in event viewer that helps and we are not using group policy. Thanks.
0
 
Khandakar Ashfaqur RahmanExpert/ConsultantCommented:
Also try the following:

Open command prompt and type:
tasklist /svc


Post the output.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.