Exchange 2003 Iphone

I have 2 user's only who have IPhone 4 that can't get their mail to sync. Calendar items come in just fine, so it's only email. when I use the Exrca I get the following error.  I did check and the allow inherit permissions box is checked.

Attempting the initial sync to the Inbox folder. This initial sync won't return any data.
       An error occurred while the Sync command was being tested.
       
      Additional Details
       Exchange ActiveSync command Sync failed with error code ServerError.
Darth_mark67Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Alan HardistyCo-OwnerCommented:
Can you please have a read of my article and check your IIS settings:

http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/A_1798-Exchange-2003-Activesync-Connection-Problems-FAQ.html

Incorrect IIS settings can cause such problems.

Alan
0
Darth_mark67Author Commented:
Thank you Alan,

I went through it but I'm still getting this erro: (weird that calendar, notes and everything is working fine)

      An ActiveSync session is being attempted with the server.
       Errors were encountered while testing the Exchange ActiveSync session.
       
      Test Steps
       
      Attempting to send the OPTIONS command to the server.
       The OPTIONS response was successfully received and is valid.
       
      Additional Details
      Attempting the FolderSync command on the Exchange ActiveSync session.
       The FolderSync command completed successfully.
       
      Additional Details
      Attempting the initial sync to the Inbox folder. This initial sync won't return any data.
       An error occurred while the Sync command was being tested.
       
      Additional Details
       Exchange ActiveSync command Sync failed with error code ServerError.
0
Alan HardistyCo-OwnerCommented:
Are you missing the error code out of the results?  It looks like you have copied / pasted most of the error, but not all of it and the best bit is the bot that isn't there which would help to identify what might be wrong.
0
Darth_mark67Author Commented:
Test Steps
       
      Attempting to resolve the host name mail.domain.com in DNS.
       The host name resolved successfully.
       
      Additional Details
      Testing TCP port 443 on host mail.domain.com to ensure it's listening and open.
       The port was opened successfully.
      Testing the SSL certificate to make sure it's valid.
       The certificate passed all validation requirements.
       
      Test Steps
      Checking the IIS configuration for client certificate authentication.
       Client certificate authentication wasn't detected.
       
      Additional Details
      Testing HTTP Authentication Methods for URL https://mail.domain.com/Microsoft-Server-ActiveSync/.
       The HTTP authentication methods are correct.
       
      Additional Details
      An ActiveSync session is being attempted with the server.
       Errors were encountered while testing the Exchange ActiveSync session.
       
      Test Steps
       
      Attempting to send the OPTIONS command to the server.
       The OPTIONS response was successfully received and is valid.
       
      Additional Details
      Attempting the FolderSync command on the Exchange ActiveSync session.
       The FolderSync command completed successfully.
       
      Additional Details
      Attempting the initial sync to the Inbox folder. This initial sync won't return any data.
       An error occurred while the Sync command was being tested.
       
      Additional Details
       Exchange ActiveSync command Sync failed with error code ServerError.
0
Alan HardistyCo-OwnerCommented:
I've not come across that error before!

Having read this question:
http://www.experts-exchange.com/Q_26936086.html

The suggestion there is to export the mailbox to a .PST file, then delete the mailbox (remove the Exchange Attributes) and then add a new mailbox and import the mail back again.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.