Solved

AnyConnect and SBS certificates conflict - Can they coexist?

Posted on 2012-03-16
1
499 Views
Last Modified: 2012-03-18
My problem getting SBS/Exchange server to receive mail through a new ASA 5505 was solved when it was determined 'I' was suffering from bug CSCti38867, where the ASA fails to proxy arp.  As a result, I am no longer using a separate static IP for the external interface of the ASA and the public IP of my Exchange server.  The interface is now the public IP.

I'm greatly relieved to have found the solution to this bug, even if it meant settling for a single IP.  However, I have a GoDaddy SSL cert on my server for use with the RWW and OWA functions of SBS 2003.  The problem is, now that I'm setting up AnyConnect, when I attempt to connect to the public IP on the ASA, AnyConnect sees the SBS certificate.  I had created a self-signed identity cert on the ASA for use with AnyConnect via IPSec, but the client bombs out anyway.

I thought I read that it's possible to get a GoDaddy SSL (or I assume other basic SSL) cert to perform 'double duty'.  I'm not sure mine is compatible (the extensions didn't seem to conform to what was mentioned in that article--you can tell I haven't spent much time with certs).  Can I keep my current SSL cert and configure the ASA and AnyConnect in such a way that it ignores it and just deals with the self-signed cert, or am I forced to replace the SSL cert?  Any help on setting this up is much appreciated.  Thanks!
0
Comment
Question by:mrpierce2
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
1 Comment
 

Accepted Solution

by:
mrpierce2 earned 0 total points
ID: 37735428
Guess no one was interested in this one.

Turns out all I had to do was change the SSL and DTLS ports.  Without directing AnyConnect to look at a specific port it's going to 443 (SSL) by default, which is why my SBS SSL certificate was popping up.

In the ASDM ( I'm using version 6.4(7) ) ....

- Configuration
- Remote Access VPN
- Network (Client) Access
  - AnyConnect Connection Profiles
    - "Port Settings..." button
      - Change both 'SSL Ports' to 8443, or whatever is appropriate for your configuration
0

Featured Post

On Demand Webinar: Networking for the Cloud Era

Did you know SD-WANs can improve network connectivity? Check out this webinar to learn how an SD-WAN simplified, one-click tool can help you migrate and manage data in the cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

There’s a movement in Information Technology (IT), and while it’s hard to define, it is gaining momentum. Some call it “stream-lined IT;” others call it “thin-model IT.”
You deserve ‘straight talk’ from your cloud provider about your risk, your costs, security, uptime and the processes that are in place to protect your mission-critical applications.
Both in life and business – not all partnerships are created equal. As the demand for cloud services increases, so do the number of self-proclaimed cloud partners. Asking the right questions up front in the partnership, will enable both parties …
Both in life and business – not all partnerships are created equal. Spend 30 short minutes with us to learn:   • Key questions to ask when considering a partnership to accelerate your business into the cloud • Pitfalls and mistakes other partners…
Suggested Courses
Course of the Month7 days, 21 hours left to enroll

617 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question