Solved

tnsnames.ora not visible in Toad

Posted on 2012-03-16
15
11,801 Views
Last Modified: 2012-04-21
I have a machine which has tnsnames.ora and sqlnet.ora in the right places with right values. When I do Session/New Connections in TOAD, it has the proper Oracle home value under 'Connect Using'. However, I see the 'SQLNET Editor' button enabled with green check but the 'TNSNames Editor' button is disabled. I was thinking that if Oracle home is properly defined, it knows where to look for tnsnames.ora.

Any ideas?
0
Comment
Question by:soccerplayer
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 7
  • 6
  • 2
15 Comments
 

Author Comment

by:soccerplayer
ID: 37731457
My Oracle is installed on Windows.
0
 
LVL 23

Expert Comment

by:David
ID: 37731516
You need the TNS_ADMIN variable defined either at the system or user level.  Confirm there is no value first by going to a command prompt and running SET to list the in-use variables.  It should look something like $ORACLE_HOME/network/admin.

TNS_ADMIN is set under the Control Panel | System | Advanced | Environment Variables.

Reboot the PC in order to enable the string.  TOAD should then recognize the variable and map it.
0
 

Author Comment

by:soccerplayer
ID: 37731768
When I do 'set' at Windows command prompt, I don't see either ORACLE_HOME or TNS_ADMIN.
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 23

Expert Comment

by:David
ID: 37731771
My bad, you would have ORACLE_HOME only if the database software was installed.  You can execute a search on "tnsnames.ora"; set TNS_ADMIN to its drive:path name.  Make sense?
0
 

Author Comment

by:soccerplayer
ID: 37731786
I don't have TNS_ADMIN defined anywhere in my machine but Toad is working fine. It is somebody else's machine that I am trying to get working.
0
 
LVL 16

Expert Comment

by:Wasim Akram Shaik
ID: 37732191
I dont think that toad would look for a TNS_ADMIN variable..

The problem you might be having here is because of the tnsnames.ora file not being present in your $ORACLE_HOME/Network/Admin Path


As dvz suggested, Place tnsnames.ora file over the TNS_ADMIN path, toad will automatically detect that file and that button would get automatically enabled..

But yes, you have to make sure that your ORACLE_HOME variable is set properly..

but dvz, even if the client is present then ORACLE_HOME variable gets set right, we don't need the database software at all times..
0
 
LVL 16

Expert Comment

by:Wasim Akram Shaik
ID: 37732196
Also I am sure, if toad is working fine as author had mentioned.., I think, there is an oracle client, which is allowing himto connect(or may be toad itself is having a built in client)
0
 

Author Comment

by:soccerplayer
ID: 37733767
When I do:
set

in Windows command prompt, the tnsnames.ora does not exist in the Oracle path but I can connect to Oracle fine. I also don't have TNS_ADMIN defined anywhere (not in System/Advanced/Environment Variables). It works perfectly fine on my machine. How can that be?
0
 
LVL 16

Expert Comment

by:Wasim Akram Shaik
ID: 37734141
When I do:
set

in Windows??

What have you set?? didn't get you...

There is no need of TNS_ADMIN, ORACLE_HOME has to be defined and it should be present in environment variable, thats enough for an oracle client to connect to oracle.. by default toad also uses the same oracle client to connect to oracle and to make use of TNSNamesEditor in toad, you have to place the tnsnames.ora file in the $ORACLE_HOME/Network/Admin path(which is referred as TNS_ADMIN),
0
 

Author Comment

by:soccerplayer
ID: 37740268
I have Oracle server on a Unix box and Oracle client on Windows. In Windows, under the results of the 'set', command I don't have ORACLE_HOME or TNS_ADMIN defined. In System/Advanced/Environment Variables, I don't have ORACLE_HOME or TNS_ADMIN defined. In my path, I have:

D:\oracle\product\10.2.0\client_2\bin;

I have tnsnames.ora and sqlnet.ora defined in both D:\Oracle\product\10.2.0\client_2\NETWORK\ADMIN\ and D:\Oracle\product\10.2.0\client_2\NETWORK\ADMIN\SAMPLE\.

In Unix, when I do:
echo $ORACLE_HOME
I see the whole path for Oracle, i.e., ../oracle/oratools/product/10.2.0.

On the Unix server, I have tnsnames.ora and sqlnet.ora defined in both .../NETWORK/ADMIN/ and .../NETWORK/ADMIN/SAMPLE/. This is visible to other users as well.

In my Toad, I see the TNSNames Editor button fine. This other user doesn't.
0
 
LVL 16

Expert Comment

by:Wasim Akram Shaik
ID: 37740649
---In my Toad, I see the TNSNames Editor button fine. This other user doesn't.

The User which doesn't see the button.. does he has the same configuration which you have mentioned in the steps above in windows machine..

We don't have to check anything at server end for this particular issue.

On the user machine where in Toad is unable to use TNSNames Editor, create the environment variables ORACLE_HOME and assign it the location/path where the oracle client is installed.

after this restart the system.. this should resolve your problem..
0
 

Author Comment

by:soccerplayer
ID: 37741962
How come I don't have ORACLE_HOME and TNS_ADMIN defined and everything works fine? Just curious.
0
 
LVL 16

Expert Comment

by:Wasim Akram Shaik
ID: 37741982
I am not sure how its working fine even if you don't have these things defined..

but defining the  ORACLE_HOME will resolve this problem

May be i think because of the ORACLE_HOME Path defined in the PATH (D:\oracle\product\10.2.0\client_2\bin) is doing the trick for you..

Else, you could do the same thing of pointing the path to ORACLE_HOME in the other system where Toad is not working and can see whether the same thing makes the toad to work for you(for tnsnames editor button)
0
 

Author Comment

by:soccerplayer
ID: 37755579
Issue is not resolved yet. Getting the error:

Toad error - Can't initialize OCI. Error -1

Researching...
0
 
LVL 16

Accepted Solution

by:
Wasim Akram Shaik earned 500 total points
ID: 37755726
hold on...!!!

let me the versions of Windows and Toad, by the past posts of yours i can see that your oracle is 10g.

i think this(Toad error - Can't initialize OCI. Error -1 ) is more of a compatibility issue nothing related to tnsnames.ora.
0

Featured Post

Announcing the Most Valuable Experts of 2016

MVEs are more concerned with the satisfaction of those they help than with the considerable points they can earn. They are the types of people you feel privileged to call colleagues. Join us in honoring this amazing group of Experts.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Why doesn't the Oracle optimizer use my index? Querying too much data Most Oracle developers know that an index is useful when you can use it to restrict your result set to a small number of the total rows in a table. So, the obvious sideā€¦
Shell script to create broker configuration file using current broker Configuration, solely for purpose of backup on Linux. Script may need to be modified depending on OS-installation. Please deploy and verify the script in a test environment.
This video shows setup options and the basic steps and syntax for duplicating (cloning) a database from one instance to another. Examples are given for duplicating to the same machine and to different machines
This video shows how to configure and send email from and Oracle database using both UTL_SMTP and UTL_MAIL, as well as comparing UTL_SMTP to a manual SMTP conversation with a mail server.

729 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question