• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1094
  • Last Modified:

Failed to Apply Usage Based Optimization for Aggregation Design

When I try to use the Usage Based Optimization to apply Aggregation Design to my measure group, it shows me the following error message.

The connection string cannot be found. Open Microsoft SQL Server Management Studio and, in the Analysis Server Properties page, check the value of the Log\QueryLog\QueryLogConnectionString property.

I encountered this error like two weeks ago.  At that time I just reset the connection string and every things seem to be fine.  A week ago, I successfully applied the Usage Based Optimization for one of my cubes.  However when I tried to apply UBO for my other cubes today, I encountered the same issue again!  I believe no one has changed the property of the connection string.

Also if I query the Query Log table, I can see those latest queries made by the users.  I'm sure the queries are still logging into this table.

This is really strange.  Anyone else has encountered the same issue?  Thanks.
0
thomaszhwang
Asked:
thomaszhwang
  • 4
  • 4
3 Solutions
 
TempDBACommented:
Would you mind just reviewing your connectionstring while applying the aggregation design to the measure group. May be something fishy is going on there.
0
 
thomaszhwangAuthor Commented:
I checked already.  The Connection String to the Query Log table is somehow encrypted.  I'm sure no one did that.  It must be something else trigger the encryption.  Any idea?
0
 
TempDBACommented:
Nope. Generally it should be visible in non-encrypted form.
0
Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 
thomaszhwangAuthor Commented:
I know, but somehow it's just encrypted...

I can reset it, but a few days later.  It gets encrypted again...
0
 
TempDBACommented:
Are you by any chance using the "Encrypt=yes" property?
0
 
thomaszhwangAuthor Commented:
You mean in the connection string?

I don't even know we have that option.  I used the dialog to set the server name and database - that's it.
0
 
thomaszhwangAuthor Commented:
It turned out to be a permission issue.  Thanks anyway.
0
 
TempDBACommented:
Thanks thomas for sharing the answer.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: Microsoft Azure 2017

Azure has a changed a lot since it was originally introduce by adding new services and features. Do you know everything you need to about Azure? This course will teach you about the Azure App Service, monitoring and application insights, DevOps, and Team Services.

  • 4
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now