• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1620
  • Last Modified:

Windows 7 Clock keeps changing to 5 minutes fast

Clock changes to 5 minutes fast on Windows 7 computer. This causes problems with logging into Microsoft Cloud services because it says that it can't make a secure connection. Why does the clock change and how can we stop it? It has happened twice in the last week.
0
mrmyth
Asked:
mrmyth
6 Solutions
 
systanCommented:
Try go to in Data and Time Properties in Control Panel
Disable or Uncheck [Automatically synchronize with an Internet Time Server]
0
 
mrmythAuthor Commented:
Thank you for your answer, why would that cause problems?
0
 
burrcmCommented:
Which internet time provider is it set to sync to? time.windows.com is generally reliable.

Chris B
0
Improve Your Query Performance Tuning

In this FREE six-day email course, you'll learn from Janis Griffin, Database Performance Evangelist. She'll teach 12 steps that you can use to optimize your queries as much as possible and see measurable results in your work. Get started today!

 
mrmythAuthor Commented:
I'll have to check.
0
 
shahzoorCommented:
As i totally agree with systan

Here is a video tutorial explaining a bit more about the problem

follow this tutorial
http://www.youtube.com/watch?v=JJL6geu7ovk
0
 
CSI-Windows_comCommented:
If the computer is in a domain it will be getting it's time from a domain controller - if the domain controller is 5 minutes fast - you will keep being sync'ed up to it.
0
 
footechCommented:
I'm going to second burrcm.  Synchronizing with an external time source is almost always a good thing.  "time.windows.com" isn't a very reliable source however.  The RTC (Real Time Clock) built into your computer is also not very accurate and will tend to drift.  So you either need to set or sync the clock manually and remember to do it periodically, or just have the Windows Time service sync to a good source automatically (you can select one of the other options or type in your own like "us.pool.ntp.org").  Or a third option would be to get a third party time sync program and use it instead of the Windows Time service.
0
 
Darr247Commented:
You could try setting windows to sync more often... the setting is in the Registry, at
HKLM\SYSTEM\CurrentControlSet\services\W32Time\TimeProviders\NtpClient
in the SpecialPollInterval key,  and the value is in seconds. Windows default is to sync once per week (604,800 seconds in Decimal)... 86400 seconds would make it sync once per day. I wouldn't recommend going smaller than 21600 seconds (that's every 6 hours, or 4x per day).

If you're going to sync to another source besides the time.windows.com or nist.gov sites, it's generally a good idea to email them and ask first, so they can alert you to criteria that might get you blocked (like syncing every minute, et cetera).
0
 
mrmythAuthor Commented:
It was the domain controller. The server was five minutes off. I will check to see what it's syncing to, to see why it was off.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Improve Your Query Performance Tuning

In this FREE six-day email course, you'll learn from Janis Griffin, Database Performance Evangelist. She'll teach 12 steps that you can use to optimize your queries as much as possible and see measurable results in your work. Get started today!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now