Solved

Best way to connect to VMWare Win7 remotely

Posted on 2012-03-17
9
682 Views
Last Modified: 2012-03-17
Hey guys

I have built a computer with which has Ubuntu 11 installed as a host PC, and then I have 2 x Windows 7 Home Prem installations running on it on VMWare Workstation as virtual guests. The purpose of this machine is that I can connect to VM-1 from home, and a business partner of mine could connect to VM-2 from her house. I have a static IP address at home from my ISP.
I have already tried LogMeIn Free account for it but the quality of it isn't as good as RDP I'm used to. Additionally, strangely the keyboard layout went from UK to US while connected through LogMeIn. So I'd like to have the quality of RDP if possible, what do you think is the best way for me?

Thanks
0
Comment
Question by:kirret
  • 2
  • 2
  • 2
  • +2
9 Comments
 
LVL 119
ID: 37732173
You should be able to connect using RDP, if you setup your routers to Port Forward 3389 TCP.
0
 
LVL 9

Assisted Solution

by:Ashok Dewan
Ashok Dewan earned 200 total points
ID: 37732342
You can use  RDP by using portforwarding as hanccocka said. I think it best. either you can use VNC program. http://www.realvnc.com/ . In both situation you need to portforwarding.

If you do not know , how to do port forward then you can check this link http://portforward.com/

You need to open you router(modem) page from your web browser to configure port forward.
the address of router is your default gateway. Put that IP address in your web browser to open router page and you may find the option of creating NAT (Virtual Server) in router. create the NAT server by giving your VMware IP address , internal  and external port would be same 3389.
you can test wheather port is opn or not via
http://www.t1shopper.com/tools/port-scan/

RDP uses 3389
and vnc uses 5900
0
 
LVL 37

Assisted Solution

by:Neil Russell
Neil Russell earned 50 total points
ID: 37732366
"and then I have 2 x Windows 7 Home Prem installations running on it "

You can NOT RDP to Home versions of Windows 7. Its is not part of the licensed OS.

You would need to use something like VNC as suguested.
0
Netscaler Common Configuration How To guides

If you use NetScaler you will want to see these guides. The NetScaler How To Guides show administrators how to get NetScaler up and configured by providing instructions for common scenarios and some not so common ones.

 
LVL 1

Expert Comment

by:DareDevilE12
ID: 37732377
You can try also with teamviewer!!!!

Regards
0
 

Author Comment

by:kirret
ID: 37732404
If I had Win7 Pro installed on that 1 machine, would I be able to RDP then considering that VMWare host gives this machine separate subnet IP address? Router gives out 192.168.0.x but my Linux host with VMWare gives my virtual machines 192.168.25.x
0
 
LVL 1

Expert Comment

by:DareDevilE12
ID: 37732420
You have to configure at VM workstation the virtual machines to use NAT on the network adapter.

Regards
0
 
LVL 9

Assisted Solution

by:Ashok Dewan
Ashok Dewan earned 200 total points
ID: 37732486
NOTE : If you use NAT option in VMware Machine , then you need to do portforwarding also in Vmware via Edit -> Virtual Network Editor -> Click on NAT option to highlight the NAT button then click on NAT setting. Reason because if NAT option enabled then your guest is using different subnet range as compare to ubuntu machine.

Other option. If you will use bridge mode option then you do not need to do portforwarding in Vmware. Just only need to do in ROUTER as described above by me.  Reason is that because you will use same range of subnet as your Ubuntu host machine.

You can access remote desktop of your VMware machine from anywhere via public ip which has been assign by your ISP.
Let me know if any issue.
0
 
LVL 119

Accepted Solution

by:
Andrew Hancock (VMware vExpert / EE MVE^2) earned 250 total points
ID: 37733170
Yes, if you had Pro, and it's easier if you change to BRIDGED. Otherwise you need to use Advanced NAT rules.
0
 

Author Closing Comment

by:kirret
ID: 37733512
OK, I've installed Windows 7 Pro, changed VMWare to use BRIDGED network settings, enabled Remote Desktop Connection on that PC, added a rule to the firewall to forward port 3389 to the host PC and RDP works like a charm from my own PC using my external IP.
Thanks
0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Quadro graphics cards for ESX 6 19 38
ignore other .htaccess 2 43
awk variable in printf 1 22
Why VM HD shows  2 different Datastore under storage? 3 54
In this step by step tutorial with screenshots, we will show you HOW TO: Enable SSH Remote Access on a VMware vSphere Hypervisor 6.5 (ESXi 6.5). This is important if you need to enable SSH remote access for additional troubleshooting of the ESXi hos…
When rebooting a vCenters 6.0 and try to connect using vSphere Client we get this issue "Invalid URL: The hostname could not parsed." When we get this error we need to do some changes in the vCenter advanced settings to fix the issue.
Teach the user how to configure vSphere clusters to support the VMware FT feature Open vSphere Web Client: Verify vSphere HA is enabled: Verify netowrking for vMotion and FT Logging is in place or create it: Turn On FT for a virtual machine: Verify …
With the advent of Windows 10, Microsoft is pushing a Get Windows 10 icon into the notification area (system tray) of qualifying computers. There are many reasons for wanting to remove this icon. This two-part Experts Exchange video Micro Tutorial s…

786 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question