Solved

Exchange 2007 ActiveSync errors

Posted on 2012-03-17
17
1,038 Views
Last Modified: 2012-03-20
Hello, I'm having an issue with connecting to an Exchange server via activesync.

When using .testexchangeconnectivity.com I get an error:

Testing of the OPTIONS command failed. For more information, see Additional Details.
Additional Details

ExRCA couldn't find MS-Server-ActiveSync and MS-ASProtocolVersions header. Headers received were: Allow: OPTIONS, TRACE, GET, HEAD, POST

After some searching I find several resolutions but none of them seem to have worked.

-I've removed anonymous access and left only basic authentication in IIS.
-In basic settings on the activesync virtual directory I fixed an issue that was making the test connection fail...

Seems like there's an issue with the activesync virtual directory but I don't know what it is. For example, in Exchange Management Shell I run $Site = [ADSI]"IIS://localhost/W3SVC/1/Root/Microsoft-Server-ActiveSync"
 and $site I get no results or errors.
(though I might be using this wrong)

I'm not at all sure what's happening here and I'm not finding anything online that seems to fit the situation I'm in. I'm testing this with the intent of using some smart devices to connect to Exchange

Exchange 2007 on Server 2008 - Single domain/single domain server
 
Ideas? Thanks!
0
Comment
Question by:underIce
  • 9
  • 8
17 Comments
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 37733117
Do you have a Cisco / Sonicwall firewall by any chance?

If not - what sort do you have?
0
 

Author Comment

by:underIce
ID: 37733131
I have a Watchguard XTM.

It is passing back and forth:
Headers received were: Allow: OPTIONS, TRACE, GET, HEAD, POST
Public: OPTIONS, TRACE, GET, HEAD, POST
So some traffic is getting through.
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 37733702
Have you got HTTPS Content Inspection enabled on the Watchguard?  If you have - please disable it and test Activesync again.
0
 

Author Comment

by:underIce
ID: 37734796
I don't see any setting exactly named HTTPS Content Inspection , but there's something close. In the HTTPS proxy server there's a Content Inspection page which has a "enable deep inspection of HTTPS content"

That is not enabled. The HTTPS Proxy server itself cannot be diabled or removed.
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 37735348
Okay - might be a problem with the Activesync virtual directory.  Can you please remove it and re-create it:

Remove:
http://technet.microsoft.com/en-us/library/bb124752(v=exchg.80).aspx

Re-Create:
http://technet.microsoft.com/en-us/library/aa997160(v=exchg.80).aspx

Then test again please.
0
 

Author Comment

by:underIce
ID: 37738041
Thanks, I'll perform that remoal/add.

The example is writtne like this: Remove-ActiveSyncVirtualDirectory -Identity "Contoso.com\Microsoft-Server-ActiveSync"

Nothing I've tried to put in to replace contoso.com works. How do I find what to fill in there? I'm not finding anything obvious in IIS 7 and I've tried everything that makes sense to me...
0
 

Author Comment

by:underIce
ID: 37738248
Also, when I try and get the properties for the Active Sync virtual directory:

Get-ActiveSyncVirtualDirectory

I get an error:

Unable to create IIS directory entry. Error message is: access is denied
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 37738390
The Activesync Virtual Directory usually needs something like "Default Website\Microsoft-Server-Activesync"
0
Are your AD admin tools letting you down?

Managing Active Directory can get complicated.  Often, the native tools for managing AD are just not up to the task.  The largest Active Directory installations in the world have relied on one tool to manage their day-to-day administration tasks: Hyena. Start your trial today.

 

Author Comment

by:underIce
ID: 37738429
I thought of that, but the Active Sync virtual direcory isn't in the default web site. It's in the SBS Web Applications web site.

SBS Web Applications
--Microsoft-Server-ActiveSync

So I tried Remove-ActiveSyncVirtualDirectory -Identity "SBS Web Applications\Microsoft-Server-ActiveSync"

Got the error The operation could not be performed because "SBS Web Applications\Microsoft-Server-ActiveSync" could not be found.
0
 

Author Comment

by:underIce
ID: 37739240
hmmm...I see that all the Exchange websites are in the default web site. The Active Sync virtual directory is in the SBS Web Application web site. That isn't right...I don't think.

If that's the issue, can I move the Active Sync virtual directory into the default web site, or should I move the exchange web sites to SBS Web Apllications? By move I guess I mean delete and recreate.

Is it simpler to delete and recreate the AS VD in the default web site? If I delete and recreate the Exchange web sites in the SBS Web Application site, will there be any user issues (OWA etc)?

Any special configuration to do if I move the Exchange web sites to the SBS site?

What's the best course of action here?

These are the contents in each web site:

default web site
aspnet
clientwebservice
Exchweb
owa
public
selfupdate
wss

SBS Web Applications
aspnet_client
autodiscover
BPService
EWS
Microsoft Server ActiveSync
OAB
Remote
Rpc
RPVwithCert
Unified messaging
WebHelp
0
 
LVL 76

Accepted Solution

by:
Alan Hardisty earned 500 total points
ID: 37739394
Don't move it - it is correct where it is.

Just remove it and re-create it.
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 37739402
So are you on an SBS 2008 server?
0
 

Author Comment

by:underIce
ID: 37739475
It's working now....I went ahead and deleted it and recreated it in the default web site...there don't seem to be any issues.

I don't mind saying that that link cost me tons of time. The syntax in the link was wrong. You need to add the web site onto the end of it. So it'd go somethig like this: Remove-ActiveSyncVirtualDirectory -Identity "Contoso.com\Microsoft-Server-ActiveSync (SBS Web Applications)"


But I worked it out
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 37739921
It probably would have helped to know you were on SBS a lot earlier in the question and even having the question in the SBS zone, would have been useful.

SBS is a totally different beast to Exchange 2007 on Windows 2008 and the IIS directories / websites are very different.
0
 

Author Closing Comment

by:underIce
ID: 37740552
Got me looking in the right places...
0
 

Author Comment

by:underIce
ID: 37740562
If I had known it was relevant I would have, if it's such a different beast that would have been a helpful comment to make up front as well. But as I said, you got me thinking about it in the right way so that was helpful.

Ended up to be a pretty simple fix...
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 37741044
Difficult for me to guess your environment - but as long as you have the problem fixed - that is the important thing.

If you add the SBS zone to any future questions involving this server, it would help others to help you.

Best wishes

Alan
0

Featured Post

Netscaler Common Configuration How To guides

If you use NetScaler you will want to see these guides. The NetScaler How To Guides show administrators how to get NetScaler up and configured by providing instructions for common scenarios and some not so common ones.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Marketers need statistics and metrics like everybody else needs oxygen. In this article we explain how to enable marketing campaign statistics for Microsoft Exchange mail.
This process describes the steps required to Import and Export data from and to .pst files using Exchange 2010. We can use these steps to export data from a user to a .pst file, import data back to the same or a different user, or even import data t…
This tutorial will walk an individual through the steps necessary to join and promote the first Windows Server 2012 domain controller into an Active Directory environment running on Windows Server 2008. Determine the location of the FSMO roles by lo…
This tutorial will show how to configure a new Backup Exec 2012 server and move an existing database to that server with the use of the BEUtility. Install Backup Exec 2012 on the new server and apply all of the latest hotfixes and service packs. The…

863 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

22 Experts available now in Live!

Get 1:1 Help Now