• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 968
  • Last Modified:

XAMPP httpd.conf 127.0.0.1 but no localhost

In httpd.conf I add this:
<Directory />
      Options FollowSymLinks
      AllowOverride None
      Order deny,allow
      Deny from all
      Allow from localhost 127.0.0.1
</Directory>

So dropbox can sync htdocs.

Problem is I have to use 127.0.0.1 in the browser to view my websites i.e. I cannot use localhost. Maybe not resolving machine readable address or can I add this human readable address to the httpd.conf file - what is the syntax please?

Tried this but no luck:
<Directory />
      Options FollowSymLinks
      AllowOverride None
      Order deny,allow
      Deny from all
      Allow from localhost 127.0.0.1
</Directory>

Cheers
0
Johny_Brav0
Asked:
Johny_Brav0
1 Solution
 
Dave BaldwinFixer of ProblemsCommented:
Look in your 'hosts' file.  See if it has "127.0.0.1  localhost " as one of the lines.  Normally that would be true.  If you're on Win7, it might "::1 localhost" instead which is the IPV6 version.
0
 
Johny_Brav0Author Commented:
That is the answer - thank you.
0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now