Module Custom HTML is not display all its components

hi there,
I have work with joomla before and i have noticed something weird this time around. When i click on create a new Module Custom HTML i get the option but when i need to view the html version of the text nothing is there. I mean the normal paragraph, no bold,Italic, Underline and all the items there abd when i try to save the module nothing happens, nothing gets saved =(

Any suggestions? im using latest Joomla 2.5
Thanks,
COHFL
whatisee.jpg
DefaultView.jpg
COHFLAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

COHFLAuthor Commented:
i guess i can summarized this whole question by saying my joomla is missing TinyMCE editor
Member_5340450Commented:
So the installation is bad?

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Joomla

From novice to tech pro — start learning today.