Solved

Is There A Way To Permanently Have Linux Ubuntu 64-Bit Keep The Number Lock Key Always ON On My Desktop Computer When I Startup/Restart Ubuntu?

Posted on 2012-03-17
31
745 Views
Last Modified: 2012-05-07
Hello. I have a question to ask you.

Actually, I am using my Linux Ubuntu 64-bit operating system as I write this and with all the of testing and playing with now; I am hooked! It is in 'my humble opinion' better than Windows in some many facets -- faster, clean, efficient, ease of use, organized, and especially free. Every major version that is released of Ubuntu, it gets much better and more automated like Windows.  Since Android for Smartphones is Linux based and that in particular facet of computing is growing in popularity and the new Beta version of Windows 8 is dissing the desktop environment in favor of tiles; I have heard that many users are thinking of going to Linux operating systems like Ubuntu. It is hard to go back to Windows now Ubuntu was better than I last attempted to use Ubuntu with version 8. I love the big bold and easily to interpret Ubuntu icons instead of the stick-like Windows icons. I am sick of Windows to keep installing to get everything I want. Honestly, I will continue to use Windows, but Ubuntu will also get as much or more use from now on.  

Okay, enough of my personal thoughts. I thought I would share them with you.

My question:

Just an issue with Ubuntu -- When I startup Ubuntu 64-bit, I notice each and every time regardless of the setting from the last Ubuntu session (system start/restart), that I have to always turn on my number lock key for the numeric keypad on the right side of my desktop keyboard. It is always OFF when I start a Ubuntu session (system restart). Is there a way to permanently have Ubuntu keep the number lock key always ON when I startup Ubuntu 64-bit? I never have this problem with Windows 7 64-bit remembering my number lock setting from the past Windows session.          

Any answers or solutions to this issue? Some Ubuntu setting I need to change? Some third party program installation to achieve this, etc.?

Please reply.

Thank you!
0
Comment
Question by:Bazingeroo
  • 17
  • 7
  • 5
  • +1
31 Comments
 
LVL 76

Assisted Solution

by:arnold
arnold earned 200 total points
Comment Utility
Check the bios settings on the desktop to make sure it has the setting to always have num lock on.
What desktop do you have brand/model?
0
 

Author Comment

by:Bazingeroo
Comment Utility
@ arnold:

Hello. Nice to meet you.

Thank you for your reply.

This is a custom made computer. However, the motherboard is an ASUS P5Q motherboard. A couple of years old.

I hope this helps.

Please reply.

Thank you!
0
 
LVL 44

Assisted Solution

by:Darr247
Darr247 earned 100 total points
Comment Utility
I think arnold has it right... look for an option like so in the BIOS

ASUS Bootup Num-Lock On/Off Option
0
 
LVL 27

Accepted Solution

by:
serialband earned 200 total points
Comment Utility
The bios is one way, but there are other ways to do this in the OS https://help.ubuntu.com/community/NumLock
0
 

Author Comment

by:Bazingeroo
Comment Utility
@ arnold, Darr247, serialband, & anyone:

Hello. Nice to meet you all.

Thank you all for your comments.

I have checked my BIOS and found that the number lock key function is ON and it has been right along. Works fine in my Windows 7 64-bit right along.

In particular to serialband's comment: I see by following the Ubuntu tutorial weblink with instructions/diagrams on "NumLock" - "Enable Numlock on Login"; I followed them and now I get NumLock *AFTER* I get past my Ubuntu login screen and *AFTER* my desktop loads up where on my keyboard the NumLock LED light finally comes on.

Question:

Great, *PARTIALLY* SOLVED! :) Now, how do I get the numlock function to run *BEFORE*  the Ubuntu login screen so when I am at the Ubuntu login screen, I also have the ability to have numlock functions there as well?

I see on the same webpage link from serialband that instructs me "Enable NumLock during startup" section. I have tried running the first script in Terminal:

Enabling Numlock on startup can be done of several different ways. First install numlockx:

sudo apt-get install numlockx    

...and the script runs without a problem. I reboot/restart Unbuntu to test it out and it still doesn't have numlock ON at the Ubuntu login screen. That is all I have done per that weblink's webpage instructions to date.

Question:

Is there more that I need to do or something to make numlock ON during startup? I am going to stop here at the moment and await further instruction(s) from you. I do not want to go too far without your help here.

Please reply.

Thank you!
0
 
LVL 27

Expert Comment

by:serialband
Comment Utility
That's just the starting part.  You also have to place the settings in the startup scripts as described directly below it.  All you did was install the capability, you still have to turn it on.
0
 

Author Comment

by:Bazingeroo
Comment Utility
@ serialband:

Hello again.  Thanks for your continued help.

I have followed your comments by still working on the weblink by doing all three actions. I redid the first part (“Enabling NumLock on startup can be done of several different ways. First install numlockx:”) to assure this component is installed. Second, I also completed the “Enabling NumLock from ”, “Enabling NumLock from startx”, and “Enabling NumLock for Virtual Consoles (TTYs)”. That is where I stopped. The last part “Enable NumLock in KDE” appears it does not apply to me, am I correct? I followed the steps anyways and the steps appeared not applicable to my Ubuntu v11.10. Then I take a snapshot of the actions I performed in Terminal, I rebooted Ubuntu and then I noticed I STILL do NOT get the NumLock available at Ubuntu Login screen.

I attached the a copy of the snapshot for your inspection. I cannot figure that is going on here? Any  ideas? I am not an expert with Ubuntu command line actions, so I am cautious and need careful assistance.

Please reply with criticism, suggestions, and offerings. Any more ideas or answers?

Please reply.

Thank you!
Screenshot-at-2012-03-19-00-54-4.png
0
 
LVL 27

Expert Comment

by:serialband
Comment Utility
You just did 3 separate items.  You only need to run do one of them.

The "sudo sed ..." command just places the numlock enable command just before the exit in /etc/rc.local which is what you want if you use the graphical interface.  You should do a "cat /etc/rc.local to see if you see the command in there.
Assuming your rc.local file was initially empty with comments, you should have the following last lines in /etc/rc.local:
# Numlock enable
#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.

# Numlock enable
[ -x /usr/bin/numlockx ] && numlockx on

exit 0

Open in new window


If you don't use the graphical interface then you run /usr/bin/numlockx on, just before you run startx.

The 3rd section is for setting the 6 default ttys, but you also need to add that to the rc.local file for it to run.  If you run it as the user without sudo, you get those errors.  Add that to the rc.local file if you want to have numlocks on by default in the tty's.  If you don't use them, you can leave this out.
0
 

Author Comment

by:Bazingeroo
Comment Utility
@ serialband & anyone:

Hello again. Thank you for your comment serialband and your continued interest with this perplexing issue.

I did both commands this time on another new install full installation of Ubuntu v.11.04 64-bit on one of my spare hard drives independent of Windows 7 64-bit and followed your previous comments' instructions from your weblink. Using Terminal, under “Enable NumLock during startup”; I executed by installing the numblockx command line and then followed picking the first one “Place command with init scripts” command line. I rebooted Ubuntu and at the Ubuntu login screen, by number lock LED was still not lit on my keyboard and the keypad on my keyboard did not work when I tried to type a number on the keypad. So something more is at play here? What do you think I need to do next? Any ideas?

I would like to get to the bottom of this!

I have included a screen shot from Terminal regarding the actions performed for your inspection. Maybe this can shed some light on the problem???

In regards to your comment referencing my /etc/rc.local file, I found it was the 'same' as yours as well. I have attached a screen shot too for your inspection.  
 
Please reply.

Thank you!
Screenshot-1.png
Screenshot-2.png
0
 

Author Comment

by:Bazingeroo
Comment Utility
@ serialband & anyone:

Hello. Could someone please try to help resolve this issue in reference to the above comment why my numlock key function still is not automatically ON at the Linux Ubuntu Login screen? Any further answers would be wonderful!

Please reply.

Thank you!
0
 
LVL 76

Expert Comment

by:arnold
Comment Utility
What is the status of the num lock settings within the bios?
0
 

Author Comment

by:Bazingeroo
Comment Utility
@ arnold:

Hello. Nice to see you again. Thank your for your continued interest.

To answer your question... ...it is always been "ON" in BIOS. Under my "Boot Settings Configuration", the "Bootup Num-Lock" is "ON".

Let me explain, I am running two operating systems on my computer. One is Windows 7 64-bit. They do NOT share a common boot. They are totally independent operating systems and boot independently. They are on totally different hard drives too. I DO HAVE my number lock key ON at the logon screen for Windows 7.  Just not for Linux Ubuntu. I hope this tidbit 'may' shine some light on this issue???

Please reply.

Thanks!
0
 
LVL 76

Expert Comment

by:arnold
Comment Utility
I see. See if one of the references help
You've tried some https://wiki.archlinux.org/index.php/Activating_Numlock_on_Bootup
0
 

Author Comment

by:Bazingeroo
Comment Utility
@ arnold:

Hello again. Thank you for your help.

Okay, update...

I am 'trying' some solutions from your weblink... ...for one of them (the first one), I have opened the rc.local file in my etc folder. Now I am using Notepad to access and add a command line. Now, for some reason, I cannot save the file after editing it in Notepad. I get "error" "Access Denied". Please see my screenshot number 1 attached to this comment. Okay, so how do I effectively modify a file? It seems like I am having permission errors? Okay, so I try to change the permissions for the file rc.local. Cannot do that either. Please see my screenshot number 2 attached to this comment. I am fairly new to Ubuntu, so please give me the instructions and especially how I can access file/folder permissions in Ubuntu? Please explain.

Please reply.

Thank you!
Screenshot---3-26-12-PM-No.-1.png
Screenshot---3-26-12-PM-No.-2.png
0
 
LVL 76

Expert Comment

by:arnold
Comment Utility
You likely did not elevate your rights to be able to save your modification.
You would need to use sudo to get admin/root rights.
When you hit the num lock key on the keyboard, does it light up?
0
How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

 

Author Comment

by:Bazingeroo
Comment Utility
@ arnold:

Hello again. Thank you again.

Okay, let me ask you this. I was modifying the rc.local file from the program Notepad and adding the line to /etc/rc.local file as instructed from the instructions from your weblink. I was actually attempting by adding the 'first' command line from this weblink. This didn't allow me to modify the rc.local file as from the screenshots I previously presented to you. The question is, how do I get permissions when modifying the files using Notepad???

I think you are suggesting me use Terminal with the sudo command, am I correct? Please let me know. I am fairly new to Ubuntu.

For the heck of it to save time, I did try it using the sudo command in Terminal with the first line command from your weblink. Therefore the full command line read:

sudo for tty in /dev/tty?; do /usr/bin/setleds -D +num < "$tty"; done

I received back when executed...

bash, syntax error near unexpected token 'do'

Obviously, something is not correct. From the weblink, I believe they want me to modify the rc.local file 'directly' and to use the program Notepad in order to do this. I am just having issues with permissions.  

To answer your question, if I hit the num lock key WHILE I AM IN the Ubuntu Login screen; YES, I can turn on the num lock key MANUALLY in order for me to use it. However, the objective of this question is so that the num lock key comes ON "AUTOMATICALLY" (“permanently”) when Ubuntu opens into the login screen and not manually have to turn it on each time only for the Ubuntu login screen.

Please reply.

Thank you!
0
 

Author Comment

by:Bazingeroo
Comment Utility
@ anyone:

Would anyone like to try a chance to see if they can assist me with this issue I am experiencing?

Please reply.

Thank you!
0
 
LVL 27

Expert Comment

by:serialband
Comment Utility
Sorry, I've been busy with work and finally got back.

I think rc.local may not be running, otherwise you would have the numlock turned on at startup.  Try "which numlockx" at the command line to make sure it's installed.  It should be in /usr/bin/numlockx

The following line in the rc.local file is a test to see if /usr/bin/numlockx exists.
[ -x /usr/bin/numlockx ] && numlockx on

If it fails before the "&&", the 2nd half which turns on numlock doesn't run.  If numlockx does exist, then this means that, for some reason, your startup script /etc/rc.local isn't running during boot.

Try "sudo notepad /etc/rc.local" at the command line.  That should elevate your privileges in notepad.  I've never used notepad in ubuntu, since I'm hardly ever connected at the console.  Multiple remote connections work best for with with just the command line.

The
sudo for tty in /dev/tty?; do /usr/bin/setleds -D +num < "$tty"; done
line does nothing for the Xwindow interface.  It's for setting the text consoles.
0
 

Author Comment

by:Bazingeroo
Comment Utility
@ serialband & anyone:

Hello again. I appreciate your dedication and response to this perplexing issue, serialband!

A. Regarding your first response in your last comment:

“I think rc.local may not be running, otherwise you would have the numlock turned on at startup. Try 'which numlockx' at the command line to make sure it's installed. It should be in /usr/bin/numlockx .”

My answer: When I enter the command line “which numlockx”; I did get the response back:

/usr/bin/numlockx

B. Regarding your second response in your last comment:
 
“The following line in the rc.local file is a test to see if /usr/bin/numlockx exists.
[ -x /usr/bin/numlockx ] && numlockx on ”

My answer: When I enter this command line, I get a prompt again with no other data or information following that executed command line. Does this mean that the command line was a success... ...or no issues? I would assume so, how about you?  

C. Regarding your third response in your last comment:

“Try 'sudo notepad /etc/rc.local' at the command line.  That should elevate your privileges in notepad.”

My answer: When I enter this command line (since I am not using Notepad at this point) entering everything into Terminal, I get to enter my password, then I get this message:

wine: /home/troy/.wine is not owned by you

Okay, for the heck of it, I decided to try to Ubuntu system reboot/restart to see if I get the numlock ON at the Ubuntu login screen. I do not. Once the logged into Ubuntu and the desktop appeared, then I had the numlock key ON as usual for some time now ever since your comment ID: 37734006 tutorial while changing system settings in the Ubuntu GUI. Hmmm... ...strange!

If there are any more ideas or answers you may have, please comment.

Thank you!
0
 
LVL 27

Expert Comment

by:serialband
Comment Utility
Try this line instead at the command prompt:

     [ -x /usr/bin/numlockx ] && echo "numlockx exists"

It should return

    numlockx exists

"[ -x /usr/bin/numlockx ] && numlockx on" shouldn't return anything.  It's just supposed to turn on your numlock, if it wasn't already on, you won't see anything.  If it was off, you should see your numlock LED turn on.

Basically, if you get a result at your command line, then the command should work, which suggests that rc.local isn't being loaded when X starts during bootup.

As for notepad, do you know how to use any unix editors?  You can try any of those instead.
0
 

Author Comment

by:Bazingeroo
Comment Utility
@ serialband:

Hello. Thank you for your comment and continued help.

Okay, YES, I do get the response as you indicated, "numlockx exists".

Okay, so you indicate in your last comment that it, "...suggests that rc.local isn't being loaded when X starts during bootup".

So how do I get this file (rc.local to load when X starts)  to load or confirm whether or not this file is loading when x starts then?

Please share with me.

Thank you!
0
 
LVL 76

Expert Comment

by:arnold
Comment Utility
rc.local runs at bootup/startup for settings to effect X startup has to be dealt/set within the X configuration.

Do you have ledcontrol package installed?
http://manpages.ubuntu.com/manpages/natty/man8/ledd.8.html
http://ubuntu-for-humans.blogspot.com/2010/06/enable-numlock-on-system-start-up.html
0
 

Author Comment

by:Bazingeroo
Comment Utility
@ arnold:

Hello again. Thanks for your continued help.

After reading your comment, I had found the same program package in my Ubuntu Software Center. the reliable program package to install called “scriptable keyboard led control” searchable with “ledcontrol” without the quotes in the Dash. It installed successfully. This fulfills the first part weblink you have provided called ledcontrol package. Great. That is done.

Second, I used your second weblink and followed the instructions with Terminal and created the required script. Every command line went successfully until the last command line where I received a negative response. For the very last command line I had to enter from your second weblink, I receive:

update-rc.d: /etc/init.d//etc/init.d/numlockon: file does not exist

I do not know if I should of received a positive response or not for this line command? If so, what should of it been? ...nothing, just another command prompt to indicate the command line was a success?

Anyways, I rebooted my Ubuntu v11.10 64-bit operating system and at the Ubuntu login screen I still did NOT get the NumLock LED light ON... ...and as usual, I did NOT did any key on the numeric keypad to work too. Once logged in as usual, and at the Ubuntu desktop, the NumLock is ON and the numeric keypad works.

Also I found something interesting too after installing the ledcontrol. I found that once Ubuntu boots, the scriptlock LED on my keyboard slowly flashes until after I logged in and then it stops once the Ubuntu desktop finally loads. Is this normal? What is the purpose of this?

So basically, there may be some issue I have indicated above preventing me from your answers you have given me; but I am not sure or not what is really going on here?

Please reply.

Thank you.
0
 
LVL 76

Expert Comment

by:arnold
Comment Utility
The line to run is:

sudo update-rc.d /etc/init.d/numlockon defaults

I do not currently access to a system to confirm whether the /etc/init.d/ is part of the script such that the following miht work
sudo update-rc.d numlockon defaults
You do not need sudo if you already elevated account rights.
0
 

Author Comment

by:Bazingeroo
Comment Utility
@ arnold & serialband & anyone:

Hello again. Thank you for your reply, arnold.

I entered what arnold has asked in his last post and added more as well to just see what responses I could receive. I have attached a screen clipping and I hope this serves you well in that tell me what is going on here.

I see we are getting no where here without any progress. Plus this question/thread is getting a little long now -- don't you agree? I will give one more response from each one of you or anyone as well as to a possible resolution or at least to make some positive headway of any kind. If I cannot get any positive leads in one more response, I will close this question/thread as a "deleted question".

Please reply.

Thank you!
Screenshot-at-2012-04-03-21-23-4.png
0
 
LVL 76

Expert Comment

by:arnold
Comment Utility
Look to see whether and what you have in /etc/init.d/numlockon.
I currently do not have an equivalent system to reference, the error suggests that the script that is present does not conform to the format/settings outline in http://wiki.debian.org/LSBInitScripts
0
 

Author Comment

by:Bazingeroo
Comment Utility
@ arnold:

Hello again.

Still working on this issue. Maybe we can get to the bottom of this issue.

Thank you for your latest comment.

Okay, I checked inside my directory to reply to your last comment's statement, "Look to see whether and what you have in /etc/init.d/numlockon." I do have that file in that directory. I have attached a screenshot of my very file (numlockon) of that directory you suggest I check out. Now, I am not a Linux Ubuntu programmer, but for me it looks okay, but again, I could be really wrong too. Please inspect the screenshot I have attached and let me know if it is right or wrong. If wrong, please explain what it should display instead. We will take it from there.

Please reply.

Thank you!
Screenshot-at-2012-04-14-21-54-0.png
0
 
LVL 44

Expert Comment

by:Darr247
Comment Utility
The asterisk by the filename in GEdit's title bar means the file was changed since opening.

Did you save the changes?
0
 

Author Comment

by:Bazingeroo
Comment Utility
@ arnold, Darr247, & serialband:

Hello again.

Okay, an update...

I recently upgraded to the latest version of Linux Ubuntu – stable release v.12.04 64-bit LTS from my older v.11.10 64-bit. For curiosity sake, I was wondering if this issue still presented itself would or finally resolve itself with the distribution upgrade. That is, the numlock function to run *BEFORE* the Ubuntu login screen so when I am at the Ubuntu login screen, the numlock function is functional. If you recall earlier on, the numlock ON issue was 'partially' solved when the numlock function running after the desktop loads. I discovered that a distribution upgrade has no effect. I also verified all procedures and methodologies from expert comments from the onset of the first expert comment from above as a follow through to see if any of the outcomes still resulted in the same conclusions or would I receive something different now as a result with a new Linux Ubuntu distribution version. I discovered there was no difference in results from the conclusions of the expert suggestions.

I will also note in the very last comment by Darr247 where he made point to address the asterisk in the file name displayed in gedit named aptly: *numlockon (/etc/init.d) . I rechecked that file path location to see if that file still demonstrated the asterisk in gedit. I see it has NOT this time. That is the asterisk is not present; however the file correctly exists. This assumes it was saved now and saved correctly.

So, we are at a loss of solutions to this perplexing issue. That is, how to get the numlock function to run *BEFORE* the Ubuntu login screen so when I am at the Ubuntu login screen, the numlock function is functional.

What I am going to do is this at this time... ...I am going to ask some experts online and personally, for some solutions with hands on interaction with this issue. It is possible they may readily discover what is actually happening on hand.

If anyone here on EE can add any additional comments, please do. I will routinely check back here to see if anyone has added to the conversation with this baffling thread/comment.

If I find an answer to this issue, I will gladly share it with all of you for others to know.

Reply, if you wish.

Thank you!
0
 

Assisted Solution

by:Bazingeroo
Bazingeroo earned 0 total points
Comment Utility
@ arnold, Darr247, & serialband:

Hello again.

I am back and I have it SOLVED!!! I see this question/thread has been open for some time now and I am happy to close it now. :-)

Okay, as promised, I will share the solution with you. I e-mailed someone of a friend and he provided me the solution. I hope this valuable and useful for you.  

What I need to do is this:

 I needed to edit lightdm.conf . To do so:

Open in Terminal and enter the command line:
gksudo gedit /etc/lightdm/lightdm.conf

...and add the script line in GEdit to the lightdm.conf:
     greeter-setup-script=/usr/bin/numlockx on    

Then save the file in gedit and exit Terminal. Issue solved.

Therefore, finally getting an answer to conclude this question.

However it is required that I needed to add or make sure that the following are completed as well and PRIOR IN THIS ORDER to the editing of the lightdm.conf file that some experts have alluded to here (above). This is the COMPLETE process from the default clean installation distribution of recent Linux Ubuntu versions:    

1. I have my BIOS for my ASUS P5Q motherboard's "Bootup Num-Lock" set to "ON".
2. Enable Numlock On Login (which REALLY means 'Enable Numlock *AFTER* Login'): Power Button icon -> “System Settings...” -> “Keyboard Layout” window, select: “Options...” ->  “Keyboard Layout Options...”, select: “Miscellaneous compatibility options” & check the box "Default numeric keypad keys" -> Select “Close” NOTE: This setting takes effect *AFTER* Login and has NO effect AT the Login screen or consoles.
3.  Enable NumLock During Startup: Install numlockx by entering in Terminal: sudo apt-get install numlockx     <--This has no effect, but it is still required to do I am told.
4. Then do what I have just instructed above which in combination with number 3 above, is also 'enable numlock during startup' and then you are done.

That is it.

Next, I am going to award points and solution titles.

Again, thank you all!!!
0
 

Author Closing Comment

by:Bazingeroo
Comment Utility
@ arnold, Darr247, & serialband:

Hello again.

Therefore, I am going to award points. Now, this evaluation of points and solution titles will be given the fairest and most equitable means possible. I will explain...

First, I will say that each one of the experts here within this thread have supplied an answer that are solutions to this question/thread-- that is each experts first comments. Following my third post (including my initial posted question for the thread), all expert comments then go astray for solutions to this issue. I will add that I am also an answerer for my own question/thread as well – my last comment. So who gets the one Accepted Solution? How are points displaced among expert comments?

As I said, each expert has provided an answer and solution. arnold addressing the BIOS settings issue. Darr247 re-addressing arnold's BIOS settings issue with a visual of the BIOS setting. serial addressing the 'enabling numlock on login' which TRULY means 'enabling numlock AFTER login' and the 'enable numlock during startup' which was a requirement as if it were some prerequisite, but it had no effect. That is where I came in with the help of an acquaintance to TRULY find the answer and solution to 'enable numlock during startup' in my last comment above.

Let me be known I cannot take the points per EE rules. So they will be fairly dispensed among the three experts.

Therefore, I am giving serialband 200 points and the Accepted Solution since he presented me the strongest and most complete and complex answer in his comment noted as the Accepted Solution above to this issue with the weblink. I am giving arnold 200 points and the Assisted Solution as noted above since he presented me the lesser but still required and significant answer in his first comment. I am giving Darr247 100 points and also the Assisted Solution as noted above since he utilized arnold's significant answer and further clarified it for me in a visual representation . I am giving myself the Assisted Solution for my last comment directly above with no points since I found from an outside source the answer, like arnold, to another lesser but still required and significant answer.

Again, thank you all!!!
0

Featured Post

Enabling OSINT in Activity Based Intelligence

Activity based intelligence (ABI) requires access to all available sources of data. Recorded Future allows analysts to observe structured data on the open, deep, and dark web.

Join & Write a Comment

Setting up Secure Ubuntu server on VMware 1.      Insert the Ubuntu Server distribution CD or attach the ISO of the CD which is in the “Datastore”. Note that it is important to install the x64 edition on servers, not the X86 editions. 2.      Power on th…
You ever wonder how to backup Linux system files just like Windows System Restore?  Well you can use Timeshift in Linux to perform those similar action.  This tutorial will show you how to backup your system files and keep regular intervals. Note…
Connecting to an Amazon Linux EC2 Instance from Windows Using PuTTY.
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.

728 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now