Cannot registerDLL file in win7 64bit "the module was loaded but the entry point could not be found"


I am having an issue I need to register a dll in win 7 64 bit in order to play Skyrim.
It's a fresh install of win7 64 bit with all updates.

Tried the following:

regsvr32 X3DAudio1_7.dll


regsvr32 C:\Windows\SysWOW64\X3DAudio1_7.dll

The file is present in both system folders.

The exact error is:

The module C:\Windows\SysWOW64\X3DAudio1_7.dll
was loaded but the entry-point DLLRegister server was not found.

Please help.

Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

regsvr32 C:\Windows\SysWOW64\X3DAudio1_7.dll

create a batch file of this command ...right click on the batch file and click on run as admin..

Post results.

Can also disable uac and then try registering the dll files.

CompTroubAuthor Commented:
ded9 thanks did as you suggested results are the same unfortunately.
Protecting & Securing Your Critical Data

Considering 93 percent of companies file for bankruptcy within 12 months of a disaster that blocked access to their data for 10 days or more, planning for the worst is just smart business. Learn how Acronis Backup integrates security at every stage

CompTroubAuthor Commented:
IanTH thanks as stated the dll files are there and also copied  them from a previously working system however they are not registered that is the issue.
I hope there is not typo error..i mean the filename ...uppercase lowercase.

If you have any antivirus software installed then uninstall it ...reboot and then try to register the file..also make sure the file or folder has full permission.

Also this forum might have a answer to your question

CompTroubAuthor Commented:
No typo everything is copy and paste.

That forum does not really help as this is a specific Windows problem not to do with Skyrim.
They tell you to register the files but that is what  I cannot do!
the c: drive is locked down in windows 7 its not like xp and vista

try doing it in safe mode press f8 during boot
CompTroubAuthor Commented:
No joy in safe mode either, I also tried to set full permissions for everyone from another OS as it's a dual boot. Still no fun.
CompTroubAuthor Commented:
OK fixed it by downloading and installing the MS DirectX library.

Thanks for the help.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
If the file does not have the DLLRegister Entrypoint then it cannot be registered using regsvr32.exe.

While researching I did see that someone had success copying it into the DirectX10 folder under the Skyrim folder.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 7

From novice to tech pro — start learning today.